summaryrefslogtreecommitdiff
path: root/games-emulation/pcsx2_patches
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-19 11:02:19 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-19 11:02:19 +0000
commit8c58ead574346296889d58006e1bf184da00be3a (patch)
treea7f2072c85179ee02c63febb294a7853dd137de1 /games-emulation/pcsx2_patches
parentf9a583991092848eb54269744b512063a4d59de0 (diff)
gentoo auto-resync : 19:11:2023 - 11:02:18
Diffstat (limited to 'games-emulation/pcsx2_patches')
-rw-r--r--games-emulation/pcsx2_patches/Manifest2
-rw-r--r--games-emulation/pcsx2_patches/pcsx2_patches-0_p20231117.ebuild55
2 files changed, 57 insertions, 0 deletions
diff --git a/games-emulation/pcsx2_patches/Manifest b/games-emulation/pcsx2_patches/Manifest
index cd691642f9e2..e35bfd52d37b 100644
--- a/games-emulation/pcsx2_patches/Manifest
+++ b/games-emulation/pcsx2_patches/Manifest
@@ -1,4 +1,6 @@
DIST pcsx2_patches-0_p20231015.tar.gz 626844 BLAKE2B cde4e81aa354839f4e49a20cbf3d375704b9a09cf30283bfe61c0b2fcd213dd0e33431875eba3d7f5fc4ca45cb779ba1916f787464a922a5cfc484e75b727205 SHA512 6a53806ff8f348946539fb3f960e91bc40d01f8c7d6acd2e07cfbea938bd5abf4d820b1c26f19b46d103438d32325c02942a879ce3f500e30a6f5fe8b776d46c
+DIST pcsx2_patches-0_p20231117.tar.gz 638316 BLAKE2B 331d2ceec0c9e10d5b8cf344a432561173083a37000f8fa3f3890e001a588884e7253bf93d5ca624d36489c9e2f4c0a865de3357d415e9f25d422bedd1106b93 SHA512 7a55a70627b045fd426e88c94e72f191adf72ee01917f9963d4bbfc4a9f96e361efb7bb86487aec4067886458779b42228fd0c5c62f2f07dfada99ba89550d8c
EBUILD pcsx2_patches-0_p20231015.ebuild 1514 BLAKE2B fff36eb37657fca9a82c4003bf415dddf48376fe8a47e7c7b510804c2750e1f9d662e3177772479e17fdca51eb08311851590908b324eb34eac974e0582e910f SHA512 f18af92e33e78482bb1501ede2c3b3be88ad80353572c7a2f3f227d282796f11d71fa3c9262fb64bf76f1783d8ae2c09d73e8c09c1b6333c2c42fcec00b16451
+EBUILD pcsx2_patches-0_p20231117.ebuild 1514 BLAKE2B 46122b5471eab43ada8a8270baa9a6e7690a80e1aa7282f9d5ed866fb082835974e76f230765b8aafe6054c19edb43e2e9441c4cb83833c00ed3086d2089c43a SHA512 3377df1d49035780c33ca1acad2753138629d483cf59e5c99c4e40a9cb145e810b51e388c862778e9b4c27cc62cb5825f05fd3a1f5ed5e98729a6f4af03dce2b
EBUILD pcsx2_patches-9999.ebuild 1474 BLAKE2B b93d9a65771de4e9699a31e4a8d0b1cefc57a9851fdcb07d711d1aa79ea3b9e8f8b1bfa17d5d1b000be19be72a8ece7d72981bd2dfb06409cefec8ca878a374a SHA512 191e544e1100c701906a01b711c3111d743b3a4a68805a5c22d86fdab5d50e49bb04182ba7933c0e1f555ba50a9c09c4eba7480396adb1547b1bbc893b011a8b
MISC metadata.xml 362 BLAKE2B 3b213785f8a28bc1e2f540e27b025d4397dec5f7885fcc8f7e3fa56186b8f023ef97de5ff7b927a8c09ad1f79baee546d08b25cf865e344197a1640470f37641 SHA512 f00b1d14ba779989c235775de6f2470e18b29f2813723eae51015681af2d2c798aeddaa9657897c83b8bcb0b124ea77b34cf6370e37104fa24a968834ea5fabb
diff --git a/games-emulation/pcsx2_patches/pcsx2_patches-0_p20231117.ebuild b/games-emulation/pcsx2_patches/pcsx2_patches-0_p20231117.ebuild
new file mode 100644
index 000000000000..d90b0959a70f
--- /dev/null
+++ b/games-emulation/pcsx2_patches/pcsx2_patches-0_p20231117.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+inherit python-any-r1
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/PCSX2/pcsx2_patches.git"
+else
+ HASH_PCSX2_PATCHES=d6195fdc69add33dcc29fd973568896a8e8e6247
+ SRC_URI="
+ https://github.com/PCSX2/pcsx2_patches/archive/${HASH_PCSX2_PATCHES}.tar.gz
+ -> ${P}.tar.gz
+ "
+ S=${WORKDIR}/${PN}-${HASH_PCSX2_PATCHES}
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Collection of game patches for use with PCSX2 (e.g. widescreen hacks)"
+HOMEPAGE="https://github.com/PCSX2/pcsx2_patches/"
+
+# these are normally distributed by upstream with PCSX2 which is GPL-3+
+LICENSE="GPL-3+"
+SLOT="0"
+
+BDEPEND="${PYTHON_DEPS}"
+
+src_compile() {
+ # upstream uses a constantly replaced "latest" patches.zip (currently no
+ # real releases), and github's .zip archives cannot be used either due to
+ # having the patches/ subdirectory -- so we use a snapshot and repack
+ # (could use app-arch/zip, but python is more likely to skip a dependency)
+ ebegin "Creating patches.zip"
+ "${PYTHON}" - <<-EOF
+ import pathlib
+ from zipfile import ZipFile, ZIP_DEFLATED
+
+ patches = pathlib.Path("patches/")
+
+ with ZipFile("patches.zip", "w", ZIP_DEFLATED, compresslevel=9) as archive:
+ for file in patches.iterdir():
+ archive.write(file, arcname=file.name)
+ EOF
+ eend ${?} || die
+}
+
+src_install() {
+ insinto /usr/lib/pcsx2/resources
+ doins patches.zip
+
+ einstalldocs
+}