summaryrefslogtreecommitdiff
path: root/games-emulation/pcsx2_patches
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-24 09:51:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-24 09:51:20 +0100
commit3c4a961cb5e1350d7d40db49eabbcd7ef649306d (patch)
tree43957aca3f4296eb8c6c43d543f94884d775072c /games-emulation/pcsx2_patches
parent49d36e9793573ab563c841fc0aebeb7d62c58859 (diff)
gentoo auto-resync : 24:08:2023 - 09:51:20
Diffstat (limited to 'games-emulation/pcsx2_patches')
-rw-r--r--games-emulation/pcsx2_patches/Manifest2
-rw-r--r--games-emulation/pcsx2_patches/pcsx2_patches-0_p20230822.ebuild54
2 files changed, 56 insertions, 0 deletions
diff --git a/games-emulation/pcsx2_patches/Manifest b/games-emulation/pcsx2_patches/Manifest
index c483559f8d6a..2ea13fe5ce34 100644
--- a/games-emulation/pcsx2_patches/Manifest
+++ b/games-emulation/pcsx2_patches/Manifest
@@ -1,4 +1,6 @@
DIST pcsx2_patches-0_p20230722.tar.gz 605026 BLAKE2B 47bc0d7676d50f5e1ec60cc473e9290070996e8159260a35a2aaabb771bc7341d248050cb5e13bb72d857709abf522f5c48a1b5a1b9f6ccbaae2c014c2511fbf SHA512 d31863829d47b77d23479e1c498990719cbfb1ddbf25786a0be9f2c2540b9c7f24f080815f4fc37ee710d4d0b75c4d9eb1dabc82564b0d092aeebab6010dc851
+DIST pcsx2_patches-0_p20230822.tar.gz 618444 BLAKE2B a51bba04e4bd52f8d04e5529ce05c7d22cd550bd00a5268b29addba24ca45f9c248ba9a7012a54e0187dfd75c423748b09e3afdafdd421177e8b08cbfd4809e4 SHA512 8a8ae2ed4a4b5ebca9f8a9d0b12d6fb9c862bc68496f167dc02fac4c1b39767a9bd9ff84373e43484b7a06693b06f07f2e9b283d3ec3de0202807f46801ce190
EBUILD pcsx2_patches-0_p20230722.ebuild 1514 BLAKE2B 9a570a7def69ed0723aa17462b4a4869e673096535ea2c940ea1243de2eae81ce84e87f783ae34064feeb45ffe4453d0d87c450579e135d1d59e81cfc8b53d05 SHA512 99a3433881c58c8daf053b6ec98913763436bd2e512852088f9da6393d795f2b95354077b9302dfacc7b8b7c12161a1277012f7e0da2639e9fdf4fe286fc13ac
+EBUILD pcsx2_patches-0_p20230822.ebuild 1514 BLAKE2B 99701adafa3e66012660661648b8d8929ed0448fc76ce6b1aa5c221f65d649ef38d26908afac1e9fcaf9a22e3c0ea1e32cc25eb2eee23fa3facbc5b2a9f21749 SHA512 9d53ddf429e4f16c8dd576aefed07ddfb9fc086a84bdc5f975becd8965ae89068c0aa7436ec925e8b9cb2de8f89fb6250a983a1b68213b85a11d2666ef82f274
EBUILD pcsx2_patches-9999.ebuild 1474 BLAKE2B f504882547fff78ed299bff906ebbfe28cd5831b052589f49d8dcf02f5dedf63b083f188e36255f7991cd3c15b748f177486f245af4ae73fcdc3c4b435735472 SHA512 ce3e4fdb3e1cca2efbbf40166d7de36db5a60a6876dbc7266e12640140e908f0c1f02ad0407b3fafd2562ac95d7e16e1020a61b9b1b5b358a10dd0ceb5fbd3d7
MISC metadata.xml 362 BLAKE2B 3b213785f8a28bc1e2f540e27b025d4397dec5f7885fcc8f7e3fa56186b8f023ef97de5ff7b927a8c09ad1f79baee546d08b25cf865e344197a1640470f37641 SHA512 f00b1d14ba779989c235775de6f2470e18b29f2813723eae51015681af2d2c798aeddaa9657897c83b8bcb0b124ea77b34cf6370e37104fa24a968834ea5fabb
diff --git a/games-emulation/pcsx2_patches/pcsx2_patches-0_p20230822.ebuild b/games-emulation/pcsx2_patches/pcsx2_patches-0_p20230822.ebuild
new file mode 100644
index 000000000000..8a5ef4418d69
--- /dev/null
+++ b/games-emulation/pcsx2_patches/pcsx2_patches-0_p20230822.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+inherit python-any-r1
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/PCSX2/pcsx2_patches.git"
+else
+ HASH_PCSX2_PATCHES=39769eef1c17a0b1743d5e6b61ec392a19ee08cf
+ SRC_URI="
+ https://github.com/PCSX2/pcsx2_patches/archive/${HASH_PCSX2_PATCHES}.tar.gz
+ -> ${P}.tar.gz"
+ S=${WORKDIR}/${PN}-${HASH_PCSX2_PATCHES}
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Collection of game patches for use with PCSX2 (e.g. widescreen hacks)"
+HOMEPAGE="https://github.com/PCSX2/pcsx2_patches/"
+
+# these are normally distributed by upstream with PCSX2 which is GPL-3+
+LICENSE="GPL-3+"
+SLOT="0"
+
+BDEPEND="${PYTHON_DEPS}"
+
+src_compile() {
+ # upstream uses a constantly replaced "latest" patches.zip (currently no
+ # real releases), and github's .zip archives cannot be used either due to
+ # having the patches/ subdirectory -- so we use a snapshot and repack
+ # (could use app-arch/zip, but python is more likely to skip a dependency)
+ ebegin "Creating patches.zip"
+ "${PYTHON}" - <<-EOF
+ import pathlib
+ from zipfile import ZipFile, ZIP_DEFLATED
+
+ patches = pathlib.Path("patches/")
+
+ with ZipFile("patches.zip", "w", ZIP_DEFLATED, compresslevel=9) as archive:
+ for file in patches.iterdir():
+ archive.write(file, arcname=file.name)
+ EOF
+ eend ${?} || die
+}
+
+src_install() {
+ insinto /usr/share/pcsx2/resources
+ doins patches.zip
+
+ einstalldocs
+}