summaryrefslogtreecommitdiff
path: root/games-emulation/pcsx2/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-11 00:10:45 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-11 00:10:45 +0100
commit82002be95de85b10f5953f5e10ced81a40ec1fba (patch)
tree3e95915eeab9799a67d9b0c508260ca31a4694ab /games-emulation/pcsx2/files
parentfc6ff4de73d70ead4ce3a005b4f5328f2b23129b (diff)
gentoo auto-resync : 11:10:2023 - 00:10:45
Diffstat (limited to 'games-emulation/pcsx2/files')
-rw-r--r--games-emulation/pcsx2/files/pcsx2-1.7.4667-system-chdr.patch6
-rw-r--r--games-emulation/pcsx2/files/pcsx2-1.7.4667-system-gtest.patch15
-rw-r--r--games-emulation/pcsx2/files/pcsx2-1.7.4667-system-zstd.patch13
-rw-r--r--games-emulation/pcsx2/files/pcsx2-1.7.4795-rapidyaml-0.5.patch8
4 files changed, 0 insertions, 42 deletions
diff --git a/games-emulation/pcsx2/files/pcsx2-1.7.4667-system-chdr.patch b/games-emulation/pcsx2/files/pcsx2-1.7.4667-system-chdr.patch
deleted file mode 100644
index 9787cd380337..000000000000
--- a/games-emulation/pcsx2/files/pcsx2-1.7.4667-system-chdr.patch
+++ /dev/null
@@ -1,6 +0,0 @@
---- a/cmake/SearchForStuff.cmake
-+++ b/cmake/SearchForStuff.cmake
-@@ -164 +164,2 @@
--add_subdirectory(3rdparty/libchdr EXCLUDE_FROM_ALL)
-+pkg_check_modules(chdr REQUIRED IMPORTED_TARGET libchdr)
-+alias_library(chdr-static PkgConfig::chdr)
diff --git a/games-emulation/pcsx2/files/pcsx2-1.7.4667-system-gtest.patch b/games-emulation/pcsx2/files/pcsx2-1.7.4667-system-gtest.patch
deleted file mode 100644
index 858efc3b3e47..000000000000
--- a/games-emulation/pcsx2/files/pcsx2-1.7.4667-system-gtest.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- a/cmake/SearchForStuff.cmake
-+++ b/cmake/SearchForStuff.cmake
-@@ -96,6 +95,0 @@
--if(ENABLE_TESTS)
-- if(NOT EXISTS "${CMAKE_SOURCE_DIR}/3rdparty/gtest/CMakeLists.txt")
-- message(WARNING "ENABLE_TESTS was on but gtest was not found, unit tests will not be enabled")
-- set(ACTUALLY_ENABLE_TESTS Off)
-- endif()
--endif()
---- a/tests/ctest/CMakeLists.txt
-+++ b/tests/ctest/CMakeLists.txt
-@@ -20 +20,2 @@
--add_subdirectory(gtest)
-+find_package(GTest REQUIRED)
-+alias_library(gtest_main GTest::gtest_main)
diff --git a/games-emulation/pcsx2/files/pcsx2-1.7.4667-system-zstd.patch b/games-emulation/pcsx2/files/pcsx2-1.7.4667-system-zstd.patch
deleted file mode 100644
index 27b2e82852e8..000000000000
--- a/games-emulation/pcsx2/files/pcsx2-1.7.4667-system-zstd.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-This can use system zstd already but will not find it given
-it does not install cmake files, so use pkg-config.
-https://bugs.gentoo.org/872254
---- a/cmake/SearchForStuff.cmake
-+++ b/cmake/SearchForStuff.cmake
-@@ -114,5 +114,2 @@
--find_optional_system_library(zstd 3rdparty/zstd 1.4.5)
--if (${zstd_TYPE} STREQUAL System)
-- alias_library(Zstd::Zstd zstd::libzstd_shared)
-- alias_library(pcsx2-zstd zstd::libzstd_shared)
--endif()
-+pkg_check_modules(zstd REQUIRED IMPORTED_TARGET libzstd)
-+alias_library(Zstd::Zstd PkgConfig::zstd)
diff --git a/games-emulation/pcsx2/files/pcsx2-1.7.4795-rapidyaml-0.5.patch b/games-emulation/pcsx2/files/pcsx2-1.7.4795-rapidyaml-0.5.patch
deleted file mode 100644
index c4d11083ad45..000000000000
--- a/games-emulation/pcsx2/files/pcsx2-1.7.4795-rapidyaml-0.5.patch
+++ /dev/null
@@ -1,8 +0,0 @@
-Continuation of https://github.com/PCSX2/pcsx2/commit/a59f95317a3fd
---- a/pcsx2/GameDatabase.cpp
-+++ b/pcsx2/GameDatabase.cpp
-@@ -1040,3 +1040,3 @@
- const u32 index = static_cast<u32>(s_hash_database.size());
-- for (const ryml::NodeRef& n : node["hashes"].children())
-+ for (const auto& n : node["hashes"].children())
- {