summaryrefslogtreecommitdiff
path: root/games-emulation/openmsx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /games-emulation/openmsx
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'games-emulation/openmsx')
-rw-r--r--games-emulation/openmsx/Manifest2
-rw-r--r--games-emulation/openmsx/openmsx-17.0.ebuild112
2 files changed, 114 insertions, 0 deletions
diff --git a/games-emulation/openmsx/Manifest b/games-emulation/openmsx/Manifest
index 37c9cb44bd99..4487aa8d6d42 100644
--- a/games-emulation/openmsx/Manifest
+++ b/games-emulation/openmsx/Manifest
@@ -1,4 +1,6 @@
AUX openmsx-16.0-libsdl-joystick-fix.patch 2101 BLAKE2B b2381fe41d014106f87a11ccc8f5f301bf033d4ff281a11280b4b8459cf62f81c29a2d07220466ab7cb59005f14157857f3ff566e1f00ddfc104ba68b199dfd5 SHA512 f2aa3b1e69879db9a315e6485db67382228827caa2d362f9f1843a76741d2bb6f909ed05664d88608c01910914e3c40d2e5600a78b276111e242f51145e3c9cb
DIST openmsx-16.0.tar.gz 3997584 BLAKE2B 040bb3f6ff0338740b5212aae21db2c97fcee0e8c8ada1bc84a59d94b1b72180c4b2d5eff8cc4ae84dd95bc77f121e15c2f818f1f2e05ba7dc4781b63770db38 SHA512 a06ec56a8a768356b628e59e587ec85898643b04379da5c72bbbd8e48a0533da34a451b7e4d2a2f540f14e6bbcf833534a1bdac9014ce0c35dfd4ca179618f48
+DIST openmsx-17.0.tar.gz 4045461 BLAKE2B 46c70ce3f853aecebf8bdeddc5786903634d88d013497383490d79b0dbf455f48a70b3658b9913db197cf7e66cbc6f4da37da58b1b24d77c75b731e842c663df SHA512 4fc87efd2bfbcd12bebb4e005b18b1cb2048f5d8f3188ef9b55f1e003c8d021fb47bd67d647137daa6a8640b5656b0db363f3b62158d690ddb5f7bf1af3459e1
EBUILD openmsx-16.0-r1.ebuild 2940 BLAKE2B 63a22b96330eb87055d2910d910aa5ee31f30354a3aa87ad290572975b77401613eb18e9986ca3e2456fb4c15b0ad2922215968eb0c65fdf7767fe64742068ce SHA512 46be0450204bb95639a0822f6bf90824c8b728ceae2c67e79731da1b52f6a82ca0c62fe8fe41ef3a0dcf4bc71535e54c46d09976d90d12d18efe14713814dab6
+EBUILD openmsx-17.0.ebuild 2882 BLAKE2B 2aa8a567b5080dd487b9c7c69138df9acf2e3523fe57a57d5cfa74a7659028d1d8eba3aaa04696f941865c8878f175b8bc8249dda1dc5884b61a959c6dc12834 SHA512 4ce326368598aa63b83eb8da63f6f4f5250f4b8c5ba2bc078e4c2fbaaa26a14b9b261885e729c1f16d152fb66ec37c9a4fc36e5200acbde404c9659e824aa896
MISC metadata.xml 441 BLAKE2B bf3b3c54e5f7f516be2e3a275aa4bf7bccd83a868fae021f2d7d0c7b4fe007708d3e45c2c47ed6b0b02ddf7fc84f770c739e16c53d1e7ca17107511b9c2f83ac SHA512 240545c7c338a6b69134a851ee14f3657e2463fe5f6bc47ddba64beb3dc3b037146e81d10a712fc5addbe54507e2269a2b7bd58a2f0d6133cd4fe5327f266c4c
diff --git a/games-emulation/openmsx/openmsx-17.0.ebuild b/games-emulation/openmsx/openmsx-17.0.ebuild
new file mode 100644
index 000000000000..e64f1d8a6d6c
--- /dev/null
+++ b/games-emulation/openmsx/openmsx-17.0.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9,10} )
+
+inherit desktop flag-o-matic python-any-r1 readme.gentoo-r1 toolchain-funcs xdg
+
+DESCRIPTION="MSX emulator that aims for perfection"
+HOMEPAGE="https://openmsx.org/"
+SRC_URI="https://github.com/openMSX/openMSX/releases/download/RELEASE_${PV//./_}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+joystick"
+
+RDEPEND="dev-lang/tcl:0=
+ media-libs/alsa-lib
+ media-libs/libogg
+ media-libs/libpng:0=
+ media-libs/libsdl2[joystick=,sound,video]
+ media-libs/libtheora
+ media-libs/libvorbis
+ media-libs/sdl2-ttf
+ >=media-libs/glew-1.3.2:0=
+ sys-libs/zlib
+ virtual/opengl"
+DEPEND="${RDEPEND}"
+BDEPEND="${PYTHON_DEPS}"
+
+DOC_CONTENTS="
+If you want to if you want to emulate real MSX systems and not
+only the free C-BIOS machines, put the system ROMs in one of
+the following directories: /usr/share/${PN}/systemroms
+or ~/.openMSX/share/systemroms
+"
+
+src_prepare() {
+ default
+ sed -i \
+ -e '/^LDFLAGS:=/d' \
+ -e '/LINK_FLAGS_PREFIX/d' \
+ -e '/LINK_FLAGS+=/s/-s//' \
+ -e '/LINK_FLAGS+=\$(TARGET_FLAGS)/s/$/ $(LDFLAGS)/' \
+ build/main.mk \
+ || die
+ sed -i -e '/SYMLINK/s:true:false:' build/custom.mk || die
+ sed -i -e 's/GPL.txt//' doc/node.mk || die
+
+ # Build system only configured to use bundled version - but not from the
+ # directory it's distributed in
+ cp "${S}/Contrib/catch2/catch.hpp" "${S}/src/unittest" || die
+}
+
+src_configure() {
+ tc-export CXX
+
+ # Doesn't compile without this, and build system doesn't consistently add
+ # it properly for all compilers
+ append-cxxflags '-std=c++17'
+
+ default
+}
+
+src_compile() {
+ emake \
+ CXXFLAGS="${CXXFLAGS}" \
+ INSTALL_SHARE_DIR="${EPREFIX}/usr/share/${PN}" \
+ V=1
+}
+
+src_test() {
+ # To get tests, we need to build with OPENMSX_FLAVOUR=unittest and then the
+ # build is stored in a directory of the pattern
+ # ${WORKDIR}/derived/*-unittest/. This is separate from the actual build,
+ # stored in ${WORKDIR}/derived/*-opt. The unittest binary and the workdir
+ # binary are in each of these directories under their `bin` directories.
+ emake \
+ V=1 \
+ CXXFLAGS="${CXXFLAGS}" \
+ OPENMSX_FLAVOUR=unittest
+
+ # There will only ever be one *-unittest directory
+ "${S}"/derived/*-unittest/bin/openmsx || die
+}
+
+src_install() {
+ # To guarantee installing the proper binary in case tests were built,
+ # specify the default OPENMSX_FLAVOUR
+ emake \
+ V=1 \
+ INSTALL_BINARY_DIR="${ED}/usr/bin" \
+ INSTALL_SHARE_DIR="${ED}/usr/share/${PN}" \
+ INSTALL_DOC_DIR="${ED}/usr/share/doc/${PF}" \
+ OPENMSX_FLAVOUR=opt \
+ install
+
+ einstalldocs
+ readme.gentoo_create_doc
+
+ for i in 16 32 48 64 128 256 ; do
+ newicon -s "${i}" "share/icons/openMSX-logo-${i}.png" "${PN}.png"
+ done
+ make_desktop_entry "${PN}" "openMSX"
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+ xdg_pkg_postinst
+}