summaryrefslogtreecommitdiff
path: root/games-emulation/openmsx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-25 10:31:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-25 10:31:10 +0000
commit2900e684ae4bdce1f20652587728095cd01a30a1 (patch)
treedb7b5054b7d0de362a2960a0a7268ffc37b8e1f9 /games-emulation/openmsx
parentff8c6e4babf1a2911b8d61b6bb7e80290355cb70 (diff)
gentoo auto-resync : 25:11:2023 - 10:31:10
Diffstat (limited to 'games-emulation/openmsx')
-rw-r--r--games-emulation/openmsx/Manifest2
-rw-r--r--games-emulation/openmsx/openmsx-19.1.ebuild113
2 files changed, 115 insertions, 0 deletions
diff --git a/games-emulation/openmsx/Manifest b/games-emulation/openmsx/Manifest
index f309bd12747d..7d0850a40891 100644
--- a/games-emulation/openmsx/Manifest
+++ b/games-emulation/openmsx/Manifest
@@ -1,5 +1,7 @@
AUX openmsx-18.0-add-ctime.patch 362 BLAKE2B 23c1c79f0356391f40a2cb64e0e1c82ee46057e06365ddc223876b488f0a258d291466c55f012de1c97fc9f0f496ee0359f6bd6ec7d30866b07895959410ea6a SHA512 c550de0cb5d39513ba626323ce8cee5cfcaf545e9759ebf845b4249c9477bbf914c4fe5efd1f9031f590db2fa47c67e81da948983add72cb05c991fa63cfa860
AUX openmsx-18.0-gcc13.patch 626 BLAKE2B 833be69f78396b890c4fdac73e02ea0a9140236e34a00ec2cce7e35463086bd7b2297d0168125c6cae746742f97393c519631f869d1d5fd85e63dc0dbd88e27a SHA512 60b0c6bee5d371388788d6a5116b8e01e361be4b6a698d1ccc0fbccca15a9a443753c9fe4a085ca87ea28b5e553674c27fe2382a727adb19c9373651d8ba9877
DIST openmsx-18.0.tar.gz 4151084 BLAKE2B 0d5b4e4745c12689e4227408481367b4b4faaa4c7c2830ec0c4b9a5eb90c4b415628cd21834384d39fa4a820c725431848e98f7ef722c437f7bb4f96ae7b14c4 SHA512 f395fae8eac3bcb9334251c1c266a8c4d2951d6510a7c4885ddbc95aaed39f4ef8ae12a177d4a9ff44745ca368055f55f9983029b47441f4fd9731696f79809f
+DIST openmsx-19.1.tar.gz 4216833 BLAKE2B 7d1ed4dfb76d0d9d3eecf1447395b4bec775f6c92edf8164583de3b0fe9fc98bce00c47206340e2cde417ba5580785ec92be04ec7a6c5cf2f1a03cd5769ce746 SHA512 107208f7a9324beb348e8dd7f9ad878ee04ee3948159448065ff2a8c78a9c890e38cb2cbcada754bfc3698a6ba53b0ad1a9ac837d6071eb330b18ea2bdb0fbc7
EBUILD openmsx-18.0-r2.ebuild 2985 BLAKE2B 42ca9a7f545dd7d07702d3f179124102edfec4dca46d26a0668abd8b9455a500c04b2bc30245cb42b61f242a7c06c6a70af420647bdbcce78ae82f915a148f0f SHA512 17be880189f6c60db1758b998315c56440a9742772ea54b40bb895fbdf9fa102d5b5237454b9fe92189e1b0c8888eccfa3240aa463fcc5928f04b06d6bb1f062
+EBUILD openmsx-19.1.ebuild 2944 BLAKE2B 0e34a08709358189a0dd05c61b78f51cffc1b7d383bc30351769d5f3296755351685e07892d55de7316684bf9875da5f3f7496bcaad41a51a403c32114c1b927 SHA512 d53ee61795bd8d7efeab997158ee954f92a64c745b688e537145528d1053ca4aedcdf5e146425c6177409d691696e131ef866ef4d18062790364740340f0b0a9
MISC metadata.xml 442 BLAKE2B 579f3b84332385ce6f79c1f927bb3d4b1b112954695bd30425849946ec3994158a855fc9dbff8407775ad532a105e518ba30b4e72f3e42d3b64e2cadffaa9220 SHA512 a24a4c4cef293439f8ea46ad1261507160ea5024cbc53947915e6306a1356d5682440fa1eb230a98e715214c53024fa7ffe4aa97f1bb3f385c66c1ee69b8323f
diff --git a/games-emulation/openmsx/openmsx-19.1.ebuild b/games-emulation/openmsx/openmsx-19.1.ebuild
new file mode 100644
index 000000000000..ef83b43a1552
--- /dev/null
+++ b/games-emulation/openmsx/openmsx-19.1.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10,11,12} )
+
+inherit desktop flag-o-matic python-any-r1 readme.gentoo-r1 toolchain-funcs xdg
+
+DESCRIPTION="MSX emulator that aims for perfection"
+HOMEPAGE="https://openmsx.org/"
+SRC_URI="https://github.com/openMSX/openMSX/releases/download/RELEASE_${PV//./_}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+joystick"
+
+RDEPEND="dev-lang/tcl:0=
+ media-libs/alsa-lib
+ media-libs/harfbuzz:=
+ media-libs/libogg
+ media-libs/libpng:0=
+ media-libs/libsdl2[joystick=,sound,video]
+ media-libs/libtheora
+ media-libs/libvorbis
+ media-libs/sdl2-ttf
+ >=media-libs/glew-1.3.2:0=
+ sys-libs/zlib
+ virtual/opengl"
+DEPEND="${RDEPEND}"
+BDEPEND="${PYTHON_DEPS}"
+
+DOC_CONTENTS="
+If you want to if you want to emulate real MSX systems and not
+only the free C-BIOS machines, put the system ROMs in one of
+the following directories: /usr/share/${PN}/systemroms
+or ~/.openMSX/share/systemroms
+"
+
+src_prepare() {
+ default
+ sed -i \
+ -e '/^CXXFLAGS:=/d' \
+ -e '/^LDFLAGS:=/d' \
+ -e '/LINK_FLAGS_PREFIX/d' \
+ -e '/LINK_FLAGS+=/s/-s//' \
+ -e '/LINK_FLAGS+=\$(TARGET_FLAGS)/s/$/ $(LDFLAGS)/' \
+ build/main.mk \
+ || die
+ sed -i -e 's/-fsanitize=address//' build/flavour-unittest.mk || die
+ sed -i -e '/SYMLINK/s:true:false:' build/custom.mk || die
+ sed -i -e 's/GPL.txt//' doc/node.mk || die
+
+ # Build system only configured to use bundled version - but not from the
+ # directory it's distributed in
+ cp "${S}/Contrib/catch2/catch.hpp" "${S}/src/unittest" || die
+}
+
+src_configure() {
+ tc-export CXX
+
+ # Doesn't compile without this, and build system doesn't consistently add
+ # it properly for all compilers
+ append-cxxflags '-std=c++17'
+
+ default
+}
+
+src_compile() {
+ emake \
+ INSTALL_SHARE_DIR="${EPREFIX}/usr/share/${PN}" \
+ V=1
+}
+
+src_test() {
+ # To get tests, we need to build with OPENMSX_FLAVOUR=unittest and then the
+ # build is stored in a directory of the pattern
+ # ${WORKDIR}/derived/*-unittest/. This is separate from the actual build,
+ # stored in ${WORKDIR}/derived/*-opt. The unittest binary and the workdir
+ # binary are in each of these directories under their `bin` directories.
+ emake \
+ V=1 \
+ OPENMSX_FLAVOUR=unittest
+
+ # There will only ever be one *-unittest directory
+ "${S}"/derived/*-unittest/bin/openmsx || die
+}
+
+src_install() {
+ # To guarantee installing the proper binary in case tests were built,
+ # specify the default OPENMSX_FLAVOUR
+ emake \
+ V=1 \
+ INSTALL_BINARY_DIR="${ED}/usr/bin" \
+ INSTALL_SHARE_DIR="${ED}/usr/share/${PN}" \
+ INSTALL_DOC_DIR="${ED}/usr/share/doc/${PF}" \
+ OPENMSX_FLAVOUR=opt \
+ install
+
+ einstalldocs
+ readme.gentoo_create_doc
+
+ for i in 16 32 48 64 128 256 ; do
+ newicon -s "${i}" "share/icons/openMSX-logo-${i}.png" "${PN}.png"
+ done
+ make_desktop_entry "${PN}" "openMSX"
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+ xdg_pkg_postinst
+}