summaryrefslogtreecommitdiff
path: root/games-emulation/nestra
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-emulation/nestra
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-emulation/nestra')
-rw-r--r--games-emulation/nestra/Manifest6
-rw-r--r--games-emulation/nestra/files/nestra-0.66-exec-stack.patch10
-rw-r--r--games-emulation/nestra/files/nestra-0.66-include.patch73
-rw-r--r--games-emulation/nestra/metadata.xml8
-rw-r--r--games-emulation/nestra/nestra-0.66-r3.ebuild49
5 files changed, 146 insertions, 0 deletions
diff --git a/games-emulation/nestra/Manifest b/games-emulation/nestra/Manifest
new file mode 100644
index 000000000000..f9cdd9ebcf3e
--- /dev/null
+++ b/games-emulation/nestra/Manifest
@@ -0,0 +1,6 @@
+AUX nestra-0.66-exec-stack.patch 239 BLAKE2B 47255490442da874ddea390664928aa77734c67d2dbe84cfe8be82e5fe6042408ca5650164f3c1e8aa396db71be9234933cc18a423b2c08f3c311f589675ec95 SHA512 a65ca4225707a496fcb3fbc968ba301b654c9357b33a6153cb19905080cf1f5ee76bbf6b5510e1886de8a2cfb2c5ebaed3a166d518db50aecfb5953c36ee9a43
+AUX nestra-0.66-include.patch 1297 BLAKE2B 98a52017fc1919fde5125771b267f0ef2b0c73ef29f81f3e2bac3672c6bab5be005028310d031486d143568efbd8ccf7c2d58c4d9bee9d5532e3ac872465fe83 SHA512 f95568a3433094555067a89c59a38519ee2bef6cdce8a0ba962976c5df6be3332fa18c0c4b6635c807ed2b22a40a75e22b9a26282b5e8190659f59c64f212389
+DIST nestra-0.66.tar.gz 49757 BLAKE2B 0ec8603cd9afc33a1b194e1c39cdc8d3173d1ad4c7c76e6e00214883cdfcd8f2cf35bfb4b74e131822aaf8c7864a50980d642bc87aca26372f06b8fab145a7cf SHA512 25f9d0c0359b46ddcd451552e7737b0f955a18e7a4ebd30d5494b12f787b9c45a49579207328c06c10efc7f8283bc688eb2061c538523ed257825b2394d978ce
+DIST nestra_0.66-10.diff.gz 2414 BLAKE2B 5b83ac9eee4d8c141dc473000b5f713ab4eb0a38707334d4fd044b9617f01b83c4a19670ef27874f6511f1f9b1d578ba35d5ba9ac244621b19ca3b9c00d5a30d SHA512 4ea1ad97f6c2eca0434dee4031e0486cc1c7c25237a467d4bf33bd0656b52441143855e07b29e1bdcf95514e19fe68ecb8f73d0972d17d9e3b6fd7a92d2db8c6
+EBUILD nestra-0.66-r3.ebuild 1046 BLAKE2B f36be92637c5125c5019b8c95ab8c8eb28a91999725c2a4de24ea76a46bfca945600dc0eab1b3ed4e8aa126ae7375192858f5d33d782fb087055043a1c77a0a4 SHA512 ae7ec1c29eb73c5cd9f478f84b517fae99dd0e7c3bc421e6850236577c260d35204fa37d6b78963012f1045b1ab30a3db1622feb1be156d93a159856093a4330
+MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-emulation/nestra/files/nestra-0.66-exec-stack.patch b/games-emulation/nestra/files/nestra-0.66-exec-stack.patch
new file mode 100644
index 000000000000..d9e9b3c61147
--- /dev/null
+++ b/games-emulation/nestra/files/nestra-0.66-exec-stack.patch
@@ -0,0 +1,10 @@
+--- a/x86.S.orig 2006-01-09 20:02:58.000000000 -0500
++++ b/x86.S 2006-01-09 20:03:38.000000000 -0500
+@@ -1458,3 +1458,7 @@
+ leal 0x1(%eax),%ebx
+ popl %eax
+ jmp i_next
++
++#ifdef __ELF__
++.section .note.GNU-stack,"",@progbits
++#endif
diff --git a/games-emulation/nestra/files/nestra-0.66-include.patch b/games-emulation/nestra/files/nestra-0.66-include.patch
new file mode 100644
index 000000000000..096fd18af47f
--- /dev/null
+++ b/games-emulation/nestra/files/nestra-0.66-include.patch
@@ -0,0 +1,73 @@
+--- a/comptbl.c
++++ b/comptbl.c
+@@ -9,6 +9,7 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <errno.h>
++#include <stdlib.h>
+
+ #define ALLOC_SIZE 0x400000 /* 4MB */
+ #define TBL_BASE ((unsigned char *)0x10000000)
+--- a/d6502.c
++++ b/d6502.c
+@@ -1,6 +1,7 @@
+ /* 6502 disassembler */
+ /* Public Domain */
+
++#include <stdio.h>
+ #include "globals.h"
+
+ char Opcodes_6502[256][4]={
+--- a/emu.c
++++ b/emu.c
+@@ -12,6 +12,7 @@
+ #include <sys/mman.h>
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+
+ #include "mapper.h"
+ #include "io.h"
+--- a/fb.c
++++ b/fb.c
+@@ -2,6 +2,8 @@
+ /* Framebuffer/pixmap rendering */
+ /* Public Domain */
+
++#include <stdlib.h>
++#include <string.h>
+ #include <stdio.h>
+ #include "mapper.h"
+ #include "globals.h"
+--- a/io.c
++++ b/io.c
+@@ -5,6 +5,7 @@
+ to do I/O operations. */
+
+ #include <stdio.h>
++#include <string.h>
+ #include "mapper.h"
+ #include "io.h"
+ #include "globals.h"
+--- a/mapper.c
++++ b/mapper.c
+@@ -1,6 +1,7 @@
+ /* Nestra mapper.c */
+ /* Public Domain */
+
++#include <string.h>
+ #include "mapper.h"
+ #include "consts.h"
+
+--- a/x11.c
++++ b/x11.c
+@@ -1,6 +1,9 @@
+ /* Nestra x11.c */
+ /* Public Domain */
+
++#include <stdlib.h>
++#include <string.h>
++#include <stdio.h>
+ #include <X11/Xlib.h>
+ #include <X11/keysym.h>
+ #include <X11/Xutil.h>
diff --git a/games-emulation/nestra/metadata.xml b/games-emulation/nestra/metadata.xml
new file mode 100644
index 000000000000..78274e0fa550
--- /dev/null
+++ b/games-emulation/nestra/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/games-emulation/nestra/nestra-0.66-r3.ebuild b/games-emulation/nestra/nestra-0.66-r3.ebuild
new file mode 100644
index 000000000000..44ca1daa1d33
--- /dev/null
+++ b/games-emulation/nestra/nestra-0.66-r3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit epatch toolchain-funcs flag-o-matic
+
+PATCH="${P/-/_}-10.diff"
+DESCRIPTION="NES emulation for Linux/x86"
+HOMEPAGE="http://nestra.linuxgames.com/"
+SRC_URI="http://nestra.linuxgames.com/${P}.tar.gz
+ mirror://debian/pool/contrib/n/nestra/${PATCH}.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11[abi_x86_32(-)]"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ default
+ epatch "${WORKDIR}"/${PATCH}
+ eapply "${FILESDIR}"/${P}-exec-stack.patch
+ eapply "${FILESDIR}"/${P}-include.patch
+
+ append-ldflags -Wl,-z,noexecstack
+ use amd64 && multilib_toolchain_setup x86
+
+ sed -i \
+ -e "s:-L/usr/X11R6/lib:${LDFLAGS}:" \
+ -e 's:-O2 ::' \
+ -e "s:gcc:$(tc-getCC) ${CFLAGS}:" \
+ -e "s:ld:$(tc-getLD) -m elf_i386 $(raw-ldflags):" \
+ Makefile || die
+}
+
+src_compile() {
+ use amd64 && multilib_toolchain_setup x86
+ default
+}
+
+src_install() {
+ dobin nestra
+ einstalldocs
+ doman nestra.6
+}