summaryrefslogtreecommitdiff
path: root/games-emulation/nestopia
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-emulation/nestopia
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-emulation/nestopia')
-rw-r--r--games-emulation/nestopia/Manifest4
-rw-r--r--games-emulation/nestopia/metadata.xml15
-rw-r--r--games-emulation/nestopia/nestopia-1.47_p20170105.ebuild53
-rw-r--r--games-emulation/nestopia/nestopia-9999.ebuild53
4 files changed, 125 insertions, 0 deletions
diff --git a/games-emulation/nestopia/Manifest b/games-emulation/nestopia/Manifest
new file mode 100644
index 000000000000..247412e32beb
--- /dev/null
+++ b/games-emulation/nestopia/Manifest
@@ -0,0 +1,4 @@
+DIST nestopia-1.47_p20170105.tar.gz 1283456 BLAKE2B 50e70f6f952e3b11b056e398b1b83ffd9458e89a877a8a05c4f9360f047c3a8e1edff2a1316a5d3967db050705dee066bae3452743985b7ce438294fe31d6b78 SHA512 58d1a932a6b90589c66503b2013b1a8162072e77e0416851a1430fa146e7fd85ff7363b70292c69d4c4513e3750aa53436a312c0240a843e42fbb89b554e7a70
+EBUILD nestopia-1.47_p20170105.ebuild 1082 BLAKE2B 6e30ba349b4995b866a9f4fde1b5fe497e5031e6e61556310baa68cdf91cc5acd40c173fb62377d5f9e0dc18f17c344c80c1fdd3517c709c680555ad5fa925a1 SHA512 4b15b0fa719b37017cd6cb06bea788ab3a573d2c6ff94c1b63f753d1cff0ce37d8adae034c387dcb76cbefd65234fda5d4da9fdc9c3eff0d896a663b47e3c91f
+EBUILD nestopia-9999.ebuild 1082 BLAKE2B 6e30ba349b4995b866a9f4fde1b5fe497e5031e6e61556310baa68cdf91cc5acd40c173fb62377d5f9e0dc18f17c344c80c1fdd3517c709c680555ad5fa925a1 SHA512 4b15b0fa719b37017cd6cb06bea788ab3a573d2c6ff94c1b63f753d1cff0ce37d8adae034c387dcb76cbefd65234fda5d4da9fdc9c3eff0d896a663b47e3c91f
+MISC metadata.xml 443 BLAKE2B 260d80735b1430b2c650ae8fceb8c3ab778df8a824c35cc57c1e1b9b3df9ea6feb5185e63af15ec6deca7a39df24b429b7bbb767cc225e115b62c78d9e1471c9 SHA512 287e7bddf8af98427bbebf4e3ed59aa60f314f12cd8c5ffbd95c101a13b4d63b6017f750ecc554df4034d22845a6d0c18aca85a21ed2c04316a53426e054268b
diff --git a/games-emulation/nestopia/metadata.xml b/games-emulation/nestopia/metadata.xml
new file mode 100644
index 000000000000..42c366120ded
--- /dev/null
+++ b/games-emulation/nestopia/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">rdanbrook/nestopia</remote-id>
+ <remote-id type="sourceforge">nestopiaue</remote-id>
+ </upstream>
+ <use>
+ <flag name="gui">Enable GUI</flag>
+ </use>
+</pkgmetadata>
diff --git a/games-emulation/nestopia/nestopia-1.47_p20170105.ebuild b/games-emulation/nestopia/nestopia-1.47_p20170105.ebuild
new file mode 100644
index 000000000000..932f8edc7412
--- /dev/null
+++ b/games-emulation/nestopia/nestopia-1.47_p20170105.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils gnome2-utils
+
+DESCRIPTION="A portable Nintendo Entertainment System emulator written in C++"
+HOMEPAGE="http://0ldsk00l.ca/nestopia/"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/rdanbrook/nestopia.git"
+else
+ inherit vcs-snapshot
+ SRC_URI="https://github.com/rdanbrook/${PN}/archive/d7fae2aff1a93eac997d2b480652a1d068a2b6cf.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="doc gui"
+
+RDEPEND="
+ app-arch/libarchive:=
+ media-libs/libao
+ media-libs/libepoxy
+ media-libs/libsdl2[sound,joystick,video]
+ sys-libs/zlib
+ gui? ( x11-libs/gtk+:3 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_GTK=$(usex gui)
+ -DENABLE_DOC=$(usex doc)
+ -DCMAKE_INSTALL_DOCDIR=share/doc/${PF}
+ )
+ cmake-utils_src_configure
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-emulation/nestopia/nestopia-9999.ebuild b/games-emulation/nestopia/nestopia-9999.ebuild
new file mode 100644
index 000000000000..932f8edc7412
--- /dev/null
+++ b/games-emulation/nestopia/nestopia-9999.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils gnome2-utils
+
+DESCRIPTION="A portable Nintendo Entertainment System emulator written in C++"
+HOMEPAGE="http://0ldsk00l.ca/nestopia/"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/rdanbrook/nestopia.git"
+else
+ inherit vcs-snapshot
+ SRC_URI="https://github.com/rdanbrook/${PN}/archive/d7fae2aff1a93eac997d2b480652a1d068a2b6cf.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="doc gui"
+
+RDEPEND="
+ app-arch/libarchive:=
+ media-libs/libao
+ media-libs/libepoxy
+ media-libs/libsdl2[sound,joystick,video]
+ sys-libs/zlib
+ gui? ( x11-libs/gtk+:3 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_GTK=$(usex gui)
+ -DENABLE_DOC=$(usex doc)
+ -DCMAKE_INSTALL_DOCDIR=share/doc/${PF}
+ )
+ cmake-utils_src_configure
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}