summaryrefslogtreecommitdiff
path: root/games-emulation/nestopia
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-11 17:44:39 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-11 17:44:39 +0000
commit3b4acc0bc0b77136b371d8a3119066f80f221efe (patch)
tree783e83143e3a293f008138b22980d2351aaf60a5 /games-emulation/nestopia
parentdf26c7469c1f2af2e643d43e2e32a6c9142e4885 (diff)
gentoo auto-resync : 11:01:2023 - 17:44:39
Diffstat (limited to 'games-emulation/nestopia')
-rw-r--r--games-emulation/nestopia/Manifest4
-rw-r--r--games-emulation/nestopia/nestopia-1.52.0.ebuild45
-rw-r--r--games-emulation/nestopia/nestopia-9999.ebuild7
3 files changed, 53 insertions, 3 deletions
diff --git a/games-emulation/nestopia/Manifest b/games-emulation/nestopia/Manifest
index 56afeef7dad3..087bd43bd130 100644
--- a/games-emulation/nestopia/Manifest
+++ b/games-emulation/nestopia/Manifest
@@ -1,4 +1,6 @@
DIST nestopia-1.51.1.tar.gz 1578970 BLAKE2B 5db7a380239c207843d5edadf5a174059d4566cd7b68aca01515db4940be3a6f6d02421f1499df28d4ac026ec435650452eb43306d1e49487063a06bce16b961 SHA512 68da5e9ab7b848d895a8893a18ef50d90758258fbf7f86ca5df0fe95e74bad761aa436dca79b402439a12fd4dd1430b22e45ee202168be3f9f751190a7ae6131
+DIST nestopia-1.52.0.tar.gz 1589971 BLAKE2B faa2418ae79a19448df411303c1c6740f74f42501d7232fee5e4bc8c60f26ee5187e106cb76fb2f8286a1b14ecb0ced1376a15381775ab67dc62e720ebae4601 SHA512 d7b36a07c1def146b3596124d3d084c39865916069092eceb3c1a22a030573c94fff7f3525e161d671fedd672f81ef536a42b4d0b37779c5993ffc158cdd3c0b
EBUILD nestopia-1.51.1.ebuild 910 BLAKE2B 238ed320de4c45cf6407d53af3bc527c8c9ddc0f49b56d353f31cd010a25341bcead6dbdca62666d1540b5771d0459a40c0dbfd35db7a6ec7dc696650a1b8dd2 SHA512 c6755c63518cda53f4aa18f785233dcf91713c309ce4a7096eb138b0388330d201f5e60d21c526e349e155c5bdbb986a0dce005fe3f94d497d93652dc403decf
-EBUILD nestopia-9999.ebuild 811 BLAKE2B c0a41d59d5fc01a5dc482db6bcfe9168c1ff0712970b689ef3d50cb99579948e42a8adfe93657a4ff02a65e19741023ea8b0befcffa4a4f79518488f6200d6f9 SHA512 a1de1ff37dd2c334233c059cf2671310129d3fab9275ae1dc15ec33713cad6e6f867ae99b23d608b91db7b459b9dee7739aa65857b47e9882605acb50210105e
+EBUILD nestopia-1.52.0.ebuild 910 BLAKE2B a7b7d5ff73f5c0bdaff6f5793015688dc3ec2221a0d39bc5ddb41c7023e51df14408e5b11444de9b11b56e7e7af05b038b5f732b2f70e94af25241d68166b36e SHA512 6311a000aa0a14a3f4aa2cde75b0cc0bb69f030bab84fcb73c7455fe11d970ed7cefd5120c65db0a373ccc4876d39d006bdacb2f4c75df51ab14137540cf4b89
+EBUILD nestopia-9999.ebuild 910 BLAKE2B a7b7d5ff73f5c0bdaff6f5793015688dc3ec2221a0d39bc5ddb41c7023e51df14408e5b11444de9b11b56e7e7af05b038b5f732b2f70e94af25241d68166b36e SHA512 6311a000aa0a14a3f4aa2cde75b0cc0bb69f030bab84fcb73c7455fe11d970ed7cefd5120c65db0a373ccc4876d39d006bdacb2f4c75df51ab14137540cf4b89
MISC metadata.xml 336 BLAKE2B a4797bc2d4937f6e37f6f8136a35e4088d9682e1b8571e13f5a84e7300c2533b74b237a8a9c983ce75ac073b0d261e9a0fcd35ce7acd6c1e2fac30a7a5aaade3 SHA512 9ee7bf3a223dea8e590bf8f9d9776a3a88c63ae74e78e02b0a79a30a220417639920e004c8078dca2cc9bbdee95546e703aa3a93891bf388f9c7d998c8c6bd5f
diff --git a/games-emulation/nestopia/nestopia-1.52.0.ebuild b/games-emulation/nestopia/nestopia-1.52.0.ebuild
new file mode 100644
index 000000000000..646a1b125a96
--- /dev/null
+++ b/games-emulation/nestopia/nestopia-1.52.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic xdg
+
+DESCRIPTION="Portable Nintendo Entertainment System emulator written in C++"
+HOMEPAGE="http://0ldsk00l.ca/nestopia/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/0ldsk00l/nestopia.git"
+else
+ SRC_URI="https://github.com/0ldsk00l/nestopia/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="doc"
+
+RDEPEND="
+ app-arch/libarchive:=
+ media-libs/libglvnd
+ media-libs/libsdl2[joystick,sound]
+ sys-libs/zlib:=
+ x11-libs/fltk:1[opengl]"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/autoconf-archive
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ # silence the narrowing warnings on clang (#830469)
+ append-cxxflags -Wno-narrowing
+
+ econf $(use_enable doc)
+}
diff --git a/games-emulation/nestopia/nestopia-9999.ebuild b/games-emulation/nestopia/nestopia-9999.ebuild
index c6bdbe0d6fb8..646a1b125a96 100644
--- a/games-emulation/nestopia/nestopia-9999.ebuild
+++ b/games-emulation/nestopia/nestopia-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit autotools xdg
+inherit autotools flag-o-matic xdg
DESCRIPTION="Portable Nintendo Entertainment System emulator written in C++"
HOMEPAGE="http://0ldsk00l.ca/nestopia/"
@@ -38,5 +38,8 @@ src_prepare() {
}
src_configure() {
+ # silence the narrowing warnings on clang (#830469)
+ append-cxxflags -Wno-narrowing
+
econf $(use_enable doc)
}