summaryrefslogtreecommitdiff
path: root/games-emulation/nestopia-jg
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-15 17:55:24 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-15 17:55:24 +0000
commit3392d5e937023e57811edc670b0ed7d3aba55c6d (patch)
tree32c103a9b86223dcc05105e88f05d471bcaf0886 /games-emulation/nestopia-jg
parent046c3c0984fd20387a9f86cdd0842fd81e70d94f (diff)
gentoo auto-resync : 15:01:2023 - 17:55:24
Diffstat (limited to 'games-emulation/nestopia-jg')
-rw-r--r--games-emulation/nestopia-jg/Manifest4
-rw-r--r--games-emulation/nestopia-jg/metadata.xml22
-rw-r--r--games-emulation/nestopia-jg/nestopia-jg-1.52.0.ebuild45
-rw-r--r--games-emulation/nestopia-jg/nestopia-jg-9999.ebuild45
4 files changed, 116 insertions, 0 deletions
diff --git a/games-emulation/nestopia-jg/Manifest b/games-emulation/nestopia-jg/Manifest
new file mode 100644
index 000000000000..706483ce2587
--- /dev/null
+++ b/games-emulation/nestopia-jg/Manifest
@@ -0,0 +1,4 @@
+DIST nestopia-1.52.0.tar.bz2 451267 BLAKE2B a70e1251a5b9dcb17a5d8e8233c12cc90189a0471aa3faf955c15d7331e44c4a67d6ddd101326820c219c3b5e09780a7191a45c14267e6da156d968a5b9bfce0 SHA512 5b2876ec3dcc90b94b99184d964bdeee8f194e07f8b8efeb9f425a118c3cc51e3d54901d922988047bfcb7fa5f3be97ed4e694c1451046a98e99678625d1f6f4
+EBUILD nestopia-jg-1.52.0.ebuild 865 BLAKE2B 1f8c74e6b9d1df39cb47e0e5c880590aa89ca78610f200989dd9d287f2d072794b013ea1b743270dce86d316640f42c6280e52f183c68e097670ab0a76cec5a7 SHA512 3846e74b721890616fbc754f031f24472ac6b56b344f28c82c1f6f3cb65a211d62b07406aee2850da7b75815afa36ceb17a470f50c97b9a6369d7540b191c2e9
+EBUILD nestopia-jg-9999.ebuild 865 BLAKE2B 1f8c74e6b9d1df39cb47e0e5c880590aa89ca78610f200989dd9d287f2d072794b013ea1b743270dce86d316640f42c6280e52f183c68e097670ab0a76cec5a7 SHA512 3846e74b721890616fbc754f031f24472ac6b56b344f28c82c1f6f3cb65a211d62b07406aee2850da7b75815afa36ceb17a470f50c97b9a6369d7540b191c2e9
+MISC metadata.xml 796 BLAKE2B a64e25c4a154aa153b1814d894768434c21c7a6cfe5dc73695fee083ab99f365ed952bbffbd9d7c1cea66fbdfccaf1a4c6506ffa9b9f954ca2374f7191b739f4 SHA512 260ed80b88b7ba5000f3187415fe56409656161d8cc9c2840dff3e64ff43fe0355ecf3bfac5bafeb5a5a3d69f897cd17f8b95ca14473d494d54aee5d7011f081
diff --git a/games-emulation/nestopia-jg/metadata.xml b/games-emulation/nestopia-jg/metadata.xml
new file mode 100644
index 000000000000..6150882ce3c3
--- /dev/null
+++ b/games-emulation/nestopia-jg/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'https://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>orbea@riseup.net</email>
+ <name>orbea</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ Nestopia JG is an emulator for the Nintendo Entertainment
+ System/Famicom, including support for the Famicom Disk
+ System. Though originally a fork, Nestopia JG is now the
+ de facto upstream branch of the Nestopia emulator.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://gitlab.com/jgemu/nestopia/-/issues</bugs-to>
+ <remote-id type="gitlab">jgemu/nestopia</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-emulation/nestopia-jg/nestopia-jg-1.52.0.ebuild b/games-emulation/nestopia-jg/nestopia-jg-1.52.0.ebuild
new file mode 100644
index 000000000000..ed6cc71cbb13
--- /dev/null
+++ b/games-emulation/nestopia-jg/nestopia-jg-1.52.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_PN=${PN%-*}
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Jolly Good Fork of Nestopia"
+HOMEPAGE="https://gitlab.com/jgemu/nestopia"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/jgemu/${MY_PN}.git"
+else
+ SRC_URI="https://gitlab.com/jgemu/${MY_PN}/-/archive/${PV}/${MY_P}.tar.bz2"
+ S="${WORKDIR}/${MY_P}"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-2+"
+SLOT="1"
+
+DEPEND="
+ media-libs/jg:1=
+"
+RDEPEND="
+ ${DEPEND}
+ games-emulation/jgrf
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_compile() {
+ emake CXX="$(tc-getCXX)" PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_install() {
+ emake install \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}"/usr \
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF} \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)"
+}
diff --git a/games-emulation/nestopia-jg/nestopia-jg-9999.ebuild b/games-emulation/nestopia-jg/nestopia-jg-9999.ebuild
new file mode 100644
index 000000000000..ed6cc71cbb13
--- /dev/null
+++ b/games-emulation/nestopia-jg/nestopia-jg-9999.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_PN=${PN%-*}
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Jolly Good Fork of Nestopia"
+HOMEPAGE="https://gitlab.com/jgemu/nestopia"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/jgemu/${MY_PN}.git"
+else
+ SRC_URI="https://gitlab.com/jgemu/${MY_PN}/-/archive/${PV}/${MY_P}.tar.bz2"
+ S="${WORKDIR}/${MY_P}"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-2+"
+SLOT="1"
+
+DEPEND="
+ media-libs/jg:1=
+"
+RDEPEND="
+ ${DEPEND}
+ games-emulation/jgrf
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_compile() {
+ emake CXX="$(tc-getCXX)" PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_install() {
+ emake install \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}"/usr \
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF} \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)"
+}