summaryrefslogtreecommitdiff
path: root/games-emulation/mupen64plus-ui-console
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-06 23:13:57 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-06 23:13:57 +0000
commita8b0d35ab742f31538d515dea39716e566d533c0 (patch)
tree40c6c87a13f0e5ef1111ed1bdd9191f3bd1c1e59 /games-emulation/mupen64plus-ui-console
parent8fcdcec5fbdd0e3a77391e4f354218014f59f358 (diff)
gentoo resync : 06.01.2018
Diffstat (limited to 'games-emulation/mupen64plus-ui-console')
-rw-r--r--games-emulation/mupen64plus-ui-console/Manifest2
-rw-r--r--games-emulation/mupen64plus-ui-console/mupen64plus-ui-console-2.5-r1.ebuild (renamed from games-emulation/mupen64plus-ui-console/mupen64plus-ui-console-2.5.ebuild)17
2 files changed, 16 insertions, 3 deletions
diff --git a/games-emulation/mupen64plus-ui-console/Manifest b/games-emulation/mupen64plus-ui-console/Manifest
index 653942f91f6e..4e31b84ce720 100644
--- a/games-emulation/mupen64plus-ui-console/Manifest
+++ b/games-emulation/mupen64plus-ui-console/Manifest
@@ -1,3 +1,3 @@
DIST mupen64plus-ui-console-src-2.5.tar.gz 47852 BLAKE2B 060d93c82b63c5870feffd665513d3a9046c3583103ccd16014865b621f33e2eafc93af5813332ab9416c4b01b6f767ed8b4ff4d08939abee60193638ce9cdb5 SHA512 70293a768c2bc5f80a2f71db229021d497d675536f5dc5eb098f91b62081f993f308d410adebce208a89880f57b037d5b42fa2f95c42ce94ffe2fca326a53046
-EBUILD mupen64plus-ui-console-2.5.ebuild 1703 BLAKE2B ee7210c37222c96db2e1c90a6937d376adec461a8de1a5fa4d5b7e2f4bbf4b377f4ef16cbc3770d26725abecffd9bb40925836c28c5d74ee75031fb48a550a9e SHA512 9303f9b439a36b73ece5ed5e5abbfd3a0123f241da4b0b11365aee7bf706d233351c29debee4ce8df4bf83a81ee7259229ca23f114e6f9136d08bd85759f3a71
+EBUILD mupen64plus-ui-console-2.5-r1.ebuild 1972 BLAKE2B fbac239e530710cc18c847be2464b13ff491b00cfb585276058f9a5b81b2817ee3e2603f5aa1ed8cdbd4e4da9cc30c7aed50732b4b463a26fce35c5f3bed8e20 SHA512 bdcc0d134c8bc1651443e671ffe99ad2de7ad2ad6a32643b560fd260522602045e386ead435bc3d927f3864129a7efb7a5f83e404bc29e88c0cf9b484d9b092a
MISC metadata.xml 346 BLAKE2B 823a53023d0e1834cac987cde3eebf3164767e2793ef0805c28c90a04f040b6d34d8acb8d1f28a528f74b0c269a99bfe8b7d648c5c38c6a89df59846096b79fe SHA512 2e43f2c7bd5fdfffbf8c9ece665093b942d1e3c76b27f851fff7de030ecfc0f38e82e730740e1688413b47e0ba1b752f96ebcd1d1c2a6107bcbd8185630db4c8
diff --git a/games-emulation/mupen64plus-ui-console/mupen64plus-ui-console-2.5.ebuild b/games-emulation/mupen64plus-ui-console/mupen64plus-ui-console-2.5-r1.ebuild
index f3b2fb7bfeaf..d937a15d77d5 100644
--- a/games-emulation/mupen64plus-ui-console/mupen64plus-ui-console-2.5.ebuild
+++ b/games-emulation/mupen64plus-ui-console/mupen64plus-ui-console-2.5-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
MY_P=${PN}-src-${PV}
-inherit eutils multilib toolchain-funcs
+inherit eutils gnome2-utils multilib toolchain-funcs xdg-utils
DESCRIPTION="A fork of Mupen64 Nintendo 64 emulator, console UI"
HOMEPAGE="http://www.mupen64plus.org/"
@@ -28,6 +28,9 @@ src_prepare() {
# avoid implicitly appending CPU flags
sed -i -e 's:-mmmx::g' -e 's:-msse::g' projects/unix/Makefile || die
+
+ # avoid appending -fPIE/-fno-PIE
+ sed -i -e '/^if.*PIE/,/endif/d' projects/unix/Makefile || die
}
src_compile() {
@@ -75,3 +78,13 @@ src_install() {
emake "${MAKEARGS[@]}" DESTDIR="${D}" install
einstalldocs
}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}