summaryrefslogtreecommitdiff
path: root/games-emulation/mupen64plus-rsp-hle
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-emulation/mupen64plus-rsp-hle
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-emulation/mupen64plus-rsp-hle')
-rw-r--r--games-emulation/mupen64plus-rsp-hle/Manifest3
-rw-r--r--games-emulation/mupen64plus-rsp-hle/metadata.xml11
-rw-r--r--games-emulation/mupen64plus-rsp-hle/mupen64plus-rsp-hle-2.5.ebuild68
3 files changed, 82 insertions, 0 deletions
diff --git a/games-emulation/mupen64plus-rsp-hle/Manifest b/games-emulation/mupen64plus-rsp-hle/Manifest
new file mode 100644
index 000000000000..e5c156f654bb
--- /dev/null
+++ b/games-emulation/mupen64plus-rsp-hle/Manifest
@@ -0,0 +1,3 @@
+DIST mupen64plus-rsp-hle-src-2.5.tar.gz 46998 BLAKE2B 3bb5ee627fa4c367e7dd1ef0ac0a1eae1267cf82ac66a35f4dcd972703b9cba832224cab1be20c75e9f61af2afae0c8eb7dd6ba806a47c57eef6e6c5da9e8a5a SHA512 564d96050890cc61df05163f99a0be8198e870f0d4071e87828bf58b283b2be8ca7de20ed03482ea8c45725bdd6f6baea618c068cced407892cf2add6ef373c6
+EBUILD mupen64plus-rsp-hle-2.5.ebuild 1435 BLAKE2B 5568b185559e3c6a5785f696fe81c612df394fef03322a365aca1d0f8d566ba8192d84fd7884cf423fefc66d45a026ead20ef834e6bff730f339e7f033c9672e SHA512 27e3c65ff9d57bf70dc9894f3e90962971d069aecc06f7c9db2dadae82af36f1fb0d2bbe10c70a8f8ce01378382ca8216ca05c7d9aab4ec9ded7ce919021eaba
+MISC metadata.xml 343 BLAKE2B 997f47a4d8c1fccab5b16dd49ab4e791ec1ae114b820ad75839f981e9a72f409951a22abfbb68788ade5dcb1be2dd91aba4fc9771c00519307ee28455ab7aa9d SHA512 7ffba7fdacc44215dba6cf994646ea38ebf94870accc3d6150ca609fcf5dc7b343a52fe6fc0511e5741f24afc20b11c2e1104d39215f7cffdeaf1098efaf709e
diff --git a/games-emulation/mupen64plus-rsp-hle/metadata.xml b/games-emulation/mupen64plus-rsp-hle/metadata.xml
new file mode 100644
index 000000000000..58ffff278779
--- /dev/null
+++ b/games-emulation/mupen64plus-rsp-hle/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">mupen64plus/mupen64plus-rsp-hle</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-emulation/mupen64plus-rsp-hle/mupen64plus-rsp-hle-2.5.ebuild b/games-emulation/mupen64plus-rsp-hle/mupen64plus-rsp-hle-2.5.ebuild
new file mode 100644
index 000000000000..b326e6251588
--- /dev/null
+++ b/games-emulation/mupen64plus-rsp-hle/mupen64plus-rsp-hle-2.5.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MY_P=${PN}-src-${PV}
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="A fork of Mupen64 Nintendo 64 emulator, HLE RSP plugin"
+HOMEPAGE="http://www.mupen64plus.org/"
+SRC_URI="https://github.com/mupen64plus/${PN}/releases/download/${PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=games-emulation/mupen64plus-core-2.0-r1:0="
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch_user
+
+ # avoid implicitly appending CPU flags
+ sed -i -e 's:-mmmx::g' -e 's:-msse::g' projects/unix/Makefile || die
+}
+
+src_compile() {
+ MAKEARGS=(
+ # Note: please keep this in sync in all of mupen64plus-* packages
+
+ -C projects/unix
+
+ # this basically means: GNU userspace
+ UNAME=Linux
+
+ # verbose output
+ V=1
+
+ CROSS_COMPILE="${CHOST}-"
+ CC="$(tc-getCC)"
+ CXX="$(tc-getCXX)"
+ PKG_CONFIG="$(tc-getPKG_CONFIG)"
+ # usual CFLAGS, CXXFLAGS and LDFLAGS are respected
+ # so we can leave OPTFLAGS empty
+ OPTFLAGS=
+
+ # paths, some of them are used at compile time
+ PREFIX=/usr
+ LIBDIR=/usr/$(get_libdir)
+
+ # disable unwanted magic
+ LDCONFIG=:
+ INSTALL_STRIP_FLAG=
+ )
+
+ use amd64 && MAKEARGS+=( HOST_CPU=x86_64 )
+ use x86 && MAKEARGS+=( HOST_CPU=i386 )
+
+ emake "${MAKEARGS[@]}" all
+}
+
+src_install() {
+ emake "${MAKEARGS[@]}" DESTDIR="${D}" install
+ einstalldocs
+}