summaryrefslogtreecommitdiff
path: root/games-emulation/melonds
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-18 12:24:45 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-18 12:24:45 +0100
commit16be64511bd21e32a29645b49e37611507709790 (patch)
treebfb80060e55c09b383ac0257408890c961550171 /games-emulation/melonds
parent4d6e1311ded368813dc93f130293f64148e22c45 (diff)
gentoo auto-resync : 18:08:2024 - 12:24:44
Diffstat (limited to 'games-emulation/melonds')
-rw-r--r--games-emulation/melonds/Manifest4
-rw-r--r--games-emulation/melonds/melonds-0.9.5_p20240815.ebuild99
-rw-r--r--games-emulation/melonds/melonds-9999.ebuild37
3 files changed, 125 insertions, 15 deletions
diff --git a/games-emulation/melonds/Manifest b/games-emulation/melonds/Manifest
index 073093f6895f..65d1d9eed1c9 100644
--- a/games-emulation/melonds/Manifest
+++ b/games-emulation/melonds/Manifest
@@ -1,4 +1,6 @@
DIST melonDS-0.9.5_p20231231.tar.gz 3103695 BLAKE2B 36923cf1e7faf58a05eeac2152faf4ac6387a932fc7accf4be339c752171c6e2d6d7a61d5c9de40e02163a5552701c2f313da85515380e529188260b633445dc SHA512 fe99a37ba347eb6aed470d7b93e4ddbcb32ae81045d64509441ce0fa3b08da31d32b42fef7aca5f01556ae7321fb534ebc369f091e1a8852f4a45eaa7bd941a1
+DIST melonDS-0.9.5_p20240815.tar.gz 3400066 BLAKE2B c2e530ee12e1ba6cb9d7bc1ac233be984a00a9b182b4f8cab3082dad3b6e0449239455f422113ca8efcbcfafd8a4b8bca3b3dc84c79936e467f001b21b90f79d SHA512 7845be503f272aa2b7e070b19c46893274fc3d44ace3ae1ce11e33da8e58766127cb1c89dcb92bd8084f33a8cc7c0241b7416423ec93fe45858211cd69e1766e
EBUILD melonds-0.9.5_p20231231.ebuild 1855 BLAKE2B 8acb07748455903f21e5cff3750b4628dc7669a590ea9e7afbb3eee306cf6e61154482ef05e7e57b75fd58ae710f4223b64f3cbf1ee2e11eb6a66506142724f0 SHA512 3a8bba10a5ef274c60c9e79799113ab5949d496672a0dc88729cc252f2e323980499674e5424c7d3038ebefd22f3b2db889c554ec7913f8917f21757121a50f0
-EBUILD melonds-9999.ebuild 1760 BLAKE2B 702d5d42416ba7cfda674c6d27c6cb71b1239b801043f07155e5a32b966f3ad841ad4921c1fd89895b9b4e8f1ca0279469237b8e97c70a60059ad088fb70eb91 SHA512 1f04d14c494669b35e4b8a05a7d12fb5f46fec4e24cfd9f187a1b865bccbaeef83bd40bc0bf9c3b0b394b036ad82e402b5b0451ddaaf051326ce7f2c80e5a786
+EBUILD melonds-0.9.5_p20240815.ebuild 1908 BLAKE2B a963ffba7432f9c7233d6151425db0f23b08e60890ff79ecac9e0ec392e9fdecab6d6d18212f38184d6e2c826ce99e56290b72e017df8c5db9aa35ea5b98ef21 SHA512 893a32c3b167ed689df0bb1ddafed6266b3a3c7f12940d517b20f867732133c1b2fbafecbdc76390d56ea034b931e418b6ed85d1ae091225b93203551103b1ef
+EBUILD melonds-9999.ebuild 1811 BLAKE2B e16d80541b1f9c2009168421a216d2de4e3869324090bf84bd95b846c7b4872832a0c370993728dddce3c3495af2f278c54a856abfcd35c4ec2ab7a5a25ae56b SHA512 20926a1635d4891567f702461d934b056aa5d719a03589c8d4929b6e02613930f7b2d8d0462198cbc3d24ebf246a042a99e07e47aa9aecc13209761034f5cd92
MISC metadata.xml 404 BLAKE2B e9abe00b5ee8196030846be4e7a9e224c0fb7356f88a39949b219bb7355bcac50f6ca28b299a40f056e5a105903cb156aed77731fb3ed61d2ef88becf35d0dc3 SHA512 6e2926035441d9c93759ad92cb2c026a10d28b8354e90d56361b4afc1aa6e7f0e4bb49900ad9f6025f8f9b7070df5691583074f30620196f1305919bd7cfdbdb
diff --git a/games-emulation/melonds/melonds-0.9.5_p20240815.ebuild b/games-emulation/melonds/melonds-0.9.5_p20240815.ebuild
new file mode 100644
index 000000000000..954ab038e91d
--- /dev/null
+++ b/games-emulation/melonds/melonds-0.9.5_p20240815.ebuild
@@ -0,0 +1,99 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+REAL_PN="melonDS"
+REAL_P="${REAL_PN}-${PV}"
+
+[[ "${PV}" == *p20240815 ]] && COMMIT="0e6235a7c4d3e69940a6deae158a5a91dfbfa612"
+
+inherit cmake flag-o-matic readme.gentoo-r1 toolchain-funcs xdg
+
+DESCRIPTION="Nintendo DS emulator, sorta"
+HOMEPAGE="http://melonds.kuribo64.net
+ https://github.com/Arisotura/melonDS"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/Arisotura/${REAL_PN}.git"
+else
+ SRC_URI="https://github.com/Arisotura/${REAL_PN}/archive/${COMMIT}.tar.gz
+ -> ${REAL_P}.tar.gz"
+ S="${WORKDIR}/${REAL_PN}-${COMMIT}"
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD-2 GPL-2 GPL-3 Unlicense"
+SLOT="0"
+IUSE="+jit +opengl wayland"
+
+RDEPEND="
+ app-arch/libarchive
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ media-libs/libsdl2[sound,video]
+ net-libs/enet:=
+ net-libs/libpcap
+ net-libs/libslirp
+ wayland? (
+ dev-libs/wayland
+ )
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ wayland? (
+ kde-frameworks/extra-cmake-modules:0
+ )
+"
+
+# used for JIT recompiler
+QA_EXECSTACK="usr/bin/melonDS"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="You need the following files in order to run melonDS:
+- bios7.bin
+- bios9.bin
+- firmware.bin
+- romlist.bin
+Place them in ~/.config/melonDS
+Those files can be extracted from devices or found somewhere on the Internet ;-)"
+
+src_prepare() {
+ filter-lto
+ append-flags -fno-strict-aliasing
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ local -a mycmakeargs=(
+ -DBUILD_SHARED_LIBS="OFF"
+ -DENABLE_JIT="$(usex jit)"
+ -DENABLE_OGLRENDERER="$(usex opengl)"
+ -DENABLE_WAYLAND="$(usex wayland)"
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ tc-export AR
+ cmake_src_compile
+}
+
+src_install() {
+ readme.gentoo_create_doc
+ cmake_src_install
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ readme.gentoo_print_elog
+}
diff --git a/games-emulation/melonds/melonds-9999.ebuild b/games-emulation/melonds/melonds-9999.ebuild
index ff839958a635..e20ccdc8096e 100644
--- a/games-emulation/melonds/melonds-9999.ebuild
+++ b/games-emulation/melonds/melonds-9999.ebuild
@@ -3,8 +3,8 @@
EAPI=8
-MY_PN="melonDS"
-MY_P="${MY_PN}-${PV}"
+REAL_PN="melonDS"
+REAL_P="${REAL_PN}-${PV}"
inherit cmake flag-o-matic readme.gentoo-r1 toolchain-funcs xdg
@@ -15,18 +15,18 @@ HOMEPAGE="http://melonds.kuribo64.net
if [[ "${PV}" == *9999* ]] ; then
inherit git-r3
- EGIT_REPO_URI="https://github.com/Arisotura/${MY_PN}.git"
+ EGIT_REPO_URI="https://github.com/Arisotura/${REAL_PN}.git"
else
- SRC_URI="https://github.com/Arisotura/${MY_PN}/archive/${PV}.tar.gz
- -> ${MY_P}.tar.gz"
- S="${WORKDIR}/${MY_P}"
+ SRC_URI="https://github.com/Arisotura/${REAL_PN}/archive/${PV}.tar.gz
+ -> ${REAL_P}.tar.gz"
+ S="${WORKDIR}/${REAL_P}"
KEYWORDS="~amd64"
fi
-IUSE="+jit +opengl wayland"
LICENSE="BSD-2 GPL-2 GPL-3 Unlicense"
SLOT="0"
+IUSE="+jit +opengl wayland"
RDEPEND="
app-arch/libarchive
@@ -36,12 +36,21 @@ RDEPEND="
dev-qt/qtnetwork:5
dev-qt/qtwidgets:5
media-libs/libsdl2[sound,video]
+ net-libs/enet:=
net-libs/libpcap
net-libs/libslirp
- wayland? ( dev-libs/wayland )
+ wayland? (
+ dev-libs/wayland
+ )
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ wayland? (
+ kde-frameworks/extra-cmake-modules:0
+ )
"
-DEPEND="${RDEPEND}"
-BDEPEND="wayland? ( kde-frameworks/extra-cmake-modules:0 )"
# used for JIT recompiler
QA_EXECSTACK="usr/bin/melonDS"
@@ -64,10 +73,10 @@ src_prepare() {
src_configure() {
local -a mycmakeargs=(
- -DBUILD_SHARED_LIBS=OFF
- -DENABLE_JIT=$(usex jit)
- -DENABLE_OGLRENDERER=$(usex opengl)
- -DENABLE_WAYLAND=$(usex wayland)
+ -DBUILD_SHARED_LIBS="OFF"
+ -DENABLE_JIT="$(usex jit)"
+ -DENABLE_OGLRENDERER="$(usex opengl)"
+ -DENABLE_WAYLAND="$(usex wayland)"
)
cmake_src_configure
}