summaryrefslogtreecommitdiff
path: root/games-emulation/melonds/melonds-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /games-emulation/melonds/melonds-9999.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'games-emulation/melonds/melonds-9999.ebuild')
-rw-r--r--games-emulation/melonds/melonds-9999.ebuild17
1 files changed, 7 insertions, 10 deletions
diff --git a/games-emulation/melonds/melonds-9999.ebuild b/games-emulation/melonds/melonds-9999.ebuild
index 0d497e9b94fc..0cde97c7b287 100644
--- a/games-emulation/melonds/melonds-9999.ebuild
+++ b/games-emulation/melonds/melonds-9999.ebuild
@@ -1,15 +1,12 @@
-# Copyright 2019-2021 Gentoo Authors
+# Copyright 2019-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-# NOTICE:
-# melonds bundles teakra, its upstream haven't had a release since 2020
-
EAPI=8
MY_PN="melonDS"
MY_P="${MY_PN}-${PV}"
-inherit cmake flag-o-matic readme.gentoo-r1 toolchain-funcs xdg
+inherit cmake readme.gentoo-r1 toolchain-funcs xdg
DESCRIPTION="Nintendo DS emulator, sorta"
HOMEPAGE="
@@ -32,6 +29,7 @@ SLOT="0"
DEPEND="
app-arch/libarchive
+ dev-libs/teakra
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtnetwork:5
@@ -55,7 +53,11 @@ DOC_CONTENTS="You need the following files in order to run melonDS:
Place them in ~/.config/melonDS
Those files can be found somewhere on the Internet ;-)"
+PATCHES=( "${FILESDIR}"/melonds-system-teakra.patch )
+
src_prepare() {
+ rm -r ./src/teakra || die
+
cmake_src_prepare
}
@@ -73,16 +75,11 @@ src_compile() {
}
src_install() {
- # install teakra
- dolib.so "${BUILD_DIR}/src/teakra/src/libteakra.so"
-
cmake_src_install
-
readme.gentoo_create_doc
}
pkg_postinst() {
xdg_pkg_postinst
-
readme.gentoo_print_elog
}