summaryrefslogtreecommitdiff
path: root/games-emulation/mednafen
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:58:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:58:29 +0100
commit0cf2f20608308acdf3cb922c3736446bbd8f3388 (patch)
tree07815070629c7c11000a7f51ceb8ccbccb49a809 /games-emulation/mednafen
parent1798c4aeca70ac8d0a243684d6a798fbc65735f8 (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-emulation/mednafen')
-rw-r--r--games-emulation/mednafen/Manifest3
-rw-r--r--games-emulation/mednafen/mednafen-0.9.46.ebuild115
-rw-r--r--games-emulation/mednafen/metadata.xml15
3 files changed, 0 insertions, 133 deletions
diff --git a/games-emulation/mednafen/Manifest b/games-emulation/mednafen/Manifest
deleted file mode 100644
index 5d0b95a33574..000000000000
--- a/games-emulation/mednafen/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST mednafen-0.9.46.tar.xz 3187988 BLAKE2B c33da02bfb0cce37e9029efc98d11e233686c41c7ecb51110a3fe805b3a13f2fef293dd86b7bc7a3ff172f7f0f507e07804a2927e5b41c1927ca52673f068dfb SHA512 ea624f076922570001393d5d04cc1b20b3d005d31de4095ee5c7a985be2b61e8d3aa5e78c64e751e8233adc89a31be955372caeb2818d0a5cc71ba9380931620
-EBUILD mednafen-0.9.46.ebuild 3367 BLAKE2B c8029cf25b7211db7a4e3b04eb679cd15cf73307731aba5f4306ab80f4893d3c8e39e56df79fe9c22ee561dfe80ece9cbcc95cec8250a3eb6e766e0b5fb763ed SHA512 3dc665af4a7a96d244d40d01897c53311a55c626f04ace5b1e9db32708613ea816338a042790f4bca5c3d399d8d8f99e857c8f88686210ea0c828d0d70e02a0f
-MISC metadata.xml 475 BLAKE2B f1a569bb5271cd8e5e62dc19873ce2dd5ac1cce0a84ad8c8afd68e38451301eeb7db8200636abcbdca35e0e3d310cb1bc72e3a8e0fe048f24ee483c8ba22fdc7 SHA512 d13e5f6522d5150282ed8bfb44bcdef66a30c392abdd8bf142a0c04fa3d2fd9dc09395510c771fb110cc6123e4f738cc28f33f93cf75a8f5538063eef4ce8cc5
diff --git a/games-emulation/mednafen/mednafen-0.9.46.ebuild b/games-emulation/mednafen/mednafen-0.9.46.ebuild
deleted file mode 100644
index a42d9936b35c..000000000000
--- a/games-emulation/mednafen/mednafen-0.9.46.ebuild
+++ /dev/null
@@ -1,115 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools flag-o-matic pax-utils
-
-DESCRIPTION="Argument-driven multi-system emulator utilizing OpenGL and SDL"
-HOMEPAGE="https://mednafen.github.io/"
-SRC_URI="https://mednafen.github.io/releases/files/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="alsa altivec cjk debugger jack nls pax_kernel"
-
-RDEPEND="
- dev-libs/libcdio
- >=dev-libs/lzo-2.10
- media-libs/libsdl[sound,joystick,opengl,video]
- media-libs/libsndfile
- sys-libs/zlib[minizip]
- virtual/opengl
- alsa? ( media-libs/alsa-lib )
- jack? ( media-sound/jack-audio-connection-kit )
- nls? ( virtual/libintl )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- nls? ( sys-devel/gettext )"
-
-S=${WORKDIR}/${PN}
-
-pkg_pretend() {
- if has ccache ${FEATURES}; then
- ewarn
- ewarn "If you experience build failure, try turning off ccache in FEATURES."
- ewarn
- fi
-}
-
-src_prepare() {
- default
-
- # Unfortunately, upstream is insane and thinks mucking with CFLAGS is okay, if
- # it prevents "users who don't understand the consequences of what they're doing".
- # We use sed's here, as they're more forward-compatible than patches which need to
- # be constantly rebased. DO NOT REPLACE THEM UNLESS YOU HAVE PERMISSION FROM GAMES.
- sed -e '/-fno-fast-math/d' \
- -e '/-fno-unsafe-math-optimizations/d' \
- -e '/-fno-aggressive-loop-optimizations/d' \
- -e '/-fno-ipa-icf/d' \
- -e '/-fno-printf-return-value/d' \
- -e '/-fomit-frame-pointer/d' \
- -e '/-fno-pic/d' \
- -e '/-fno-pie/d' \
- -e '/-fno-PIC/d' \
- -e '/-fno-PIE/d' \
- -e '/-nopie/d' \
- -e '/-no-pie/d' \
- -e '/-fno-stack-protector/d' \
- -e '/-fno-stack-protector-all/d' \
- -e '/-fno-stack-protector-strong/d' \
- -e '/-mtune=haswell/d' \
- -i configure.ac || die
-
- # Furthermore, upstream is also insane about bundling libraries and considers it
- # "an aesthetics issue" and is even unwilling to make unbundling optional.
- # Libs to unbundle: minilzo, minizip
- sed -e '/PKG_PROG_PKG_CONFIG/a PKG_CHECK_MODULES([LZO], [lzo2])' \
- -i configure.ac || die
- sed -e '/bin_PROGRAMS/a mednafen_CPPFLAGS = \$(LZO_CFLAGS)' \
- -i src/Makefile.am || die
- sed -e 's:"compress/minilzo.h":<lzo1x.h>:' \
- -i src/{mednafen,qtrecord}.cpp || die
- sed -e 's:compress/ioapi.c::' \
- -e 's:compress/unzip.c::' \
- -e 's:compress/minilzo.c::' \
- -i src/compress/Makefile.am.inc || die
- sed -e 's:"compress/unzip.h":<minizip/unzip.h>:' \
- -i src/file.cpp || die
- sed -e 's:\(mednafen_LDADD.*trio/libtrio\.a\):\1 -lminizip \$(LZO_LIBS):' \
- -i src/Makefile.am || die
- # delete bundled files just to be sure...
- rm src/compress/{ioapi.?,*lzo*,unzip.?} || die
-
- # The insanity continues... upstream now believes it needs to
- # warn users when compiling with -fPIC/-fPIE enabled
- sed -e '/Compiling with position-independent code generation enabled is not recommended, for performance reasons/d' \
- -i src/types.h || die
-
- eautoreconf
-}
-
-src_configure() {
- # very dodgy code (bug #539992)
- strip-flags
- append-flags -fomit-frame-pointer -fwrapv
-
- econf \
- $(use_enable alsa) \
- $(use_enable altivec) \
- $(use_enable cjk cjk-fonts) \
- $(use_enable debugger) \
- $(use_enable jack) \
- $(use_enable nls)
-}
-
-src_install() {
- default
- dodoc Documentation/cheats.txt
-
- if use pax_kernel; then
- pax-mark m "${ED%/}"/usr/bin/mednafen || die
- fi
-}
diff --git a/games-emulation/mednafen/metadata.xml b/games-emulation/mednafen/metadata.xml
deleted file mode 100644
index 0afad2b3f24e..000000000000
--- a/games-emulation/mednafen/metadata.xml
+++ /dev/null
@@ -1,15 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>games@gentoo.org</email>
- <name>Gentoo Games Project</name>
- </maintainer>
- <use>
- <flag name="debugger">Build with internal debugger</flag>
- <flag name="pax_kernel">Triggers a paxmarking of the binary</flag>
- </use>
- <upstream>
- <remote-id type="sourceforge">mednafen</remote-id>
- </upstream>
-</pkgmetadata>