summaryrefslogtreecommitdiff
path: root/games-emulation/m64py
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-emulation/m64py
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-emulation/m64py')
-rw-r--r--games-emulation/m64py/Manifest3
-rw-r--r--games-emulation/m64py/m64py-0.2.4.ebuild53
-rw-r--r--games-emulation/m64py/metadata.xml15
3 files changed, 71 insertions, 0 deletions
diff --git a/games-emulation/m64py/Manifest b/games-emulation/m64py/Manifest
new file mode 100644
index 000000000000..c03daa0feb37
--- /dev/null
+++ b/games-emulation/m64py/Manifest
@@ -0,0 +1,3 @@
+DIST m64py-0.2.4.tar.gz 209621 BLAKE2B 05fe7044ec096767ae1eb57aad9f326b157d67ea709ca0bb74cdd68ae16a23eb662a2842bef5e038d1b29cbf0a5252669ff54268d1227390f47e8c9029b63e6a SHA512 ab78565466c6dcfe604cdc00b7e63dee2f0f33514dbf4f9115af646b1f6562042516513d054bd5cb489ad89c9d30431e9ce531f8b27925ecb9c6f7b509836348
+EBUILD m64py-0.2.4.ebuild 1067 BLAKE2B a21eeabf0ac3bb7c88486ca1ac12efac04c58ade8c666b9efd73c011a1f499879d522c0cb721177b8014a23f4b322fe5229e2eafeceb42ed8b433448609d5e96 SHA512 8a66a89849ace632528543c73725a3ba1c2e60e84a4b81a4c9af4e0cb36bea9c622a4ad130d9ecdef0e74d9a089856ddeed0ae7af858a857e2672af073d8acb6
+MISC metadata.xml 455 BLAKE2B 094f3f1db818c82e55c07512db2e94ed800bfd14595d70aa8ddca7d63e862807c5552210f9a71c01ea0fbcc61f3d46a139a762d1026d75b1f932e15ec7e0e589 SHA512 41d3ca220e71119ec7bf4ea8b1ea92289d901ba3a0058e75423dd50580d03a0cbc9aae2c368fc3c47793e0405c0e167fc546c65f039661b5b11fbb274846301b
diff --git a/games-emulation/m64py/m64py-0.2.4.ebuild b/games-emulation/m64py/m64py-0.2.4.ebuild
new file mode 100644
index 000000000000..7d0c4054d8dc
--- /dev/null
+++ b/games-emulation/m64py/m64py-0.2.4.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="A frontend for Mupen64Plus"
+HOMEPAGE="http://m64py.sourceforge.net/"
+SRC_URI="mirror://sourceforge/m64py/${P}.tar.gz"
+
+LICENSE="GPL-3 LGPL-3 public-domain GPL-2 BSD CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="7z rar"
+
+RDEPEND="
+ dev-python/PyQt5[gui,opengl,widgets,${PYTHON_USEDEP}]
+ dev-python/PySDL2[${PYTHON_USEDEP}]
+ media-libs/libsdl2[joystick,video]
+ >=games-emulation/mupen64plus-core-2.5:0/2-sdl2
+ 7z? (
+ || (
+ dev-python/pylzma[${PYTHON_USEDEP}]
+ app-arch/p7zip
+ )
+ )
+ rar? (
+ || (
+ dev-python/rarfile[${PYTHON_USEDEP}]
+ app-arch/unrar
+ app-arch/rar
+ )
+ )"
+
+python_prepare_all() {
+ # set the correct search path
+ cat >> src/m64py/platform.py <<-_EOF_
+ SEARCH_DIRS = ["/usr/$(get_libdir)/mupen64plus"]
+_EOF_
+
+ distutils-r1_python_prepare_all
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}
diff --git a/games-emulation/m64py/metadata.xml b/games-emulation/m64py/metadata.xml
new file mode 100644
index 000000000000..00cb74caa25a
--- /dev/null
+++ b/games-emulation/m64py/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <use>
+ <flag name='7z'>Ensure support for .7z archives.</flag>
+ <flag name='rar'>Ensure support for .rar archives.</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">m64py</remote-id>
+ </upstream>
+</pkgmetadata>