summaryrefslogtreecommitdiff
path: root/games-emulation/m64py
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-01 20:42:22 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-01 20:42:22 +0000
commit721254b86a09bdedd5eefd0de7899c90ea2ead1a (patch)
tree895fca7b3bd570d8df743dd518a6f36deca1a241 /games-emulation/m64py
parent618c3037024b4e5328531cdc07c6ceb7486f5329 (diff)
gentoo resync : 01.01.2018
Diffstat (limited to 'games-emulation/m64py')
-rw-r--r--games-emulation/m64py/Manifest4
-rw-r--r--games-emulation/m64py/m64py-0.2.4.ebuild53
-rw-r--r--games-emulation/m64py/metadata.xml4
3 files changed, 60 insertions, 1 deletions
diff --git a/games-emulation/m64py/Manifest b/games-emulation/m64py/Manifest
index d5f546ab2c3e..42b0dd98258e 100644
--- a/games-emulation/m64py/Manifest
+++ b/games-emulation/m64py/Manifest
@@ -1,3 +1,5 @@
DIST m64py-0.2.3.tar.gz 304241 BLAKE2B efd7e4fc9a75d2b9525ad40e67f92ff56e0e932d96ee4ba51fc128d0fa8fb88a0811efada86af580501803f4f9d9e94aee23d6a50704c2e05078cc511825f347 SHA512 5471d2ce96007c5cb5492f7ba3bc2a8843455dfea811b114c68862fa5c06a636e6dd6a4304e60bf2273377330b0eb01f2dcdc0340d02ec498ae44cdd2ccc01ff
+DIST m64py-0.2.4.tar.gz 209621 BLAKE2B 05fe7044ec096767ae1eb57aad9f326b157d67ea709ca0bb74cdd68ae16a23eb662a2842bef5e038d1b29cbf0a5252669ff54268d1227390f47e8c9029b63e6a SHA512 ab78565466c6dcfe604cdc00b7e63dee2f0f33514dbf4f9115af646b1f6562042516513d054bd5cb489ad89c9d30431e9ce531f8b27925ecb9c6f7b509836348
EBUILD m64py-0.2.3-r2.ebuild 1966 BLAKE2B 7401531f4c6ac5ae18ad0ebfded531474b3a294bf43499c4a117788f52bf39938be964ac19bb74ce9928ba96c97a097eed79a1f0cca31f1b58eb68a8e05e767f SHA512 ab22af067537fae68a9ba4767e4676c64926ec91131d00469b8bca1dabeb76700a3b9a7afecff30f36d60e99c8b2b330965094379a6f234b17c18e0668507fc0
-MISC metadata.xml 322 BLAKE2B f033bc882b57f392fef8d0f97c0952642705a6a54603534fe6dfe92b97a859bc75a3b654c59de08112f7424254e6fba8345e57ad07ac90a81f5711a9615291b3 SHA512 e05b00f770c010b4d7776a79923b8b683679cdf36a2ab5d995cf907fc1dbeb86f3538753d25a743277937f625d15d9f9d5d2679096e9fa382c1d47b4c240d61c
+EBUILD m64py-0.2.4.ebuild 1067 BLAKE2B a21eeabf0ac3bb7c88486ca1ac12efac04c58ade8c666b9efd73c011a1f499879d522c0cb721177b8014a23f4b322fe5229e2eafeceb42ed8b433448609d5e96 SHA512 8a66a89849ace632528543c73725a3ba1c2e60e84a4b81a4c9af4e0cb36bea9c622a4ad130d9ecdef0e74d9a089856ddeed0ae7af858a857e2672af073d8acb6
+MISC metadata.xml 455 BLAKE2B 094f3f1db818c82e55c07512db2e94ed800bfd14595d70aa8ddca7d63e862807c5552210f9a71c01ea0fbcc61f3d46a139a762d1026d75b1f932e15ec7e0e589 SHA512 41d3ca220e71119ec7bf4ea8b1ea92289d901ba3a0058e75423dd50580d03a0cbc9aae2c368fc3c47793e0405c0e167fc546c65f039661b5b11fbb274846301b
diff --git a/games-emulation/m64py/m64py-0.2.4.ebuild b/games-emulation/m64py/m64py-0.2.4.ebuild
new file mode 100644
index 000000000000..7d0c4054d8dc
--- /dev/null
+++ b/games-emulation/m64py/m64py-0.2.4.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="A frontend for Mupen64Plus"
+HOMEPAGE="http://m64py.sourceforge.net/"
+SRC_URI="mirror://sourceforge/m64py/${P}.tar.gz"
+
+LICENSE="GPL-3 LGPL-3 public-domain GPL-2 BSD CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="7z rar"
+
+RDEPEND="
+ dev-python/PyQt5[gui,opengl,widgets,${PYTHON_USEDEP}]
+ dev-python/PySDL2[${PYTHON_USEDEP}]
+ media-libs/libsdl2[joystick,video]
+ >=games-emulation/mupen64plus-core-2.5:0/2-sdl2
+ 7z? (
+ || (
+ dev-python/pylzma[${PYTHON_USEDEP}]
+ app-arch/p7zip
+ )
+ )
+ rar? (
+ || (
+ dev-python/rarfile[${PYTHON_USEDEP}]
+ app-arch/unrar
+ app-arch/rar
+ )
+ )"
+
+python_prepare_all() {
+ # set the correct search path
+ cat >> src/m64py/platform.py <<-_EOF_
+ SEARCH_DIRS = ["/usr/$(get_libdir)/mupen64plus"]
+_EOF_
+
+ distutils-r1_python_prepare_all
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}
diff --git a/games-emulation/m64py/metadata.xml b/games-emulation/m64py/metadata.xml
index c8f77563ef65..00cb74caa25a 100644
--- a/games-emulation/m64py/metadata.xml
+++ b/games-emulation/m64py/metadata.xml
@@ -5,6 +5,10 @@
<email>mgorny@gentoo.org</email>
<name>Michał Górny</name>
</maintainer>
+ <use>
+ <flag name='7z'>Ensure support for .7z archives.</flag>
+ <flag name='rar'>Ensure support for .rar archives.</flag>
+ </use>
<upstream>
<remote-id type="sourceforge">m64py</remote-id>
</upstream>