summaryrefslogtreecommitdiff
path: root/games-emulation/m64py
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-emulation/m64py
reinit the tree, so we can have metadata
Diffstat (limited to 'games-emulation/m64py')
-rw-r--r--games-emulation/m64py/Manifest5
-rw-r--r--games-emulation/m64py/m64py-0.2.3-r2.ebuild66
-rw-r--r--games-emulation/m64py/metadata.xml11
3 files changed, 82 insertions, 0 deletions
diff --git a/games-emulation/m64py/Manifest b/games-emulation/m64py/Manifest
new file mode 100644
index 000000000000..aff4bdfcd160
--- /dev/null
+++ b/games-emulation/m64py/Manifest
@@ -0,0 +1,5 @@
+DIST m64py-0.2.3.tar.gz 304241 SHA256 87dccbad9f27ab1eae3fb9957ef039e23379d264e68f8ef7470ec38a523ef020 SHA512 5471d2ce96007c5cb5492f7ba3bc2a8843455dfea811b114c68862fa5c06a636e6dd6a4304e60bf2273377330b0eb01f2dcdc0340d02ec498ae44cdd2ccc01ff WHIRLPOOL 2d7727c56a67f6ca3901eb846d46dea881cf6361fe1bbcec6ef2d10247320d92d42d2ea9e75f247faef482f715b051a2c6394e814b83fa5f0c71bd5d1aabf8ba
+EBUILD m64py-0.2.3-r2.ebuild 1966 SHA256 a1fd50ce9c2c927b11f2f6b61117b71b7c93db42e39ccff55285545cdcd80d32 SHA512 ab22af067537fae68a9ba4767e4676c64926ec91131d00469b8bca1dabeb76700a3b9a7afecff30f36d60e99c8b2b330965094379a6f234b17c18e0668507fc0 WHIRLPOOL 1b352f5dbfb1d81e3b4b36504b677da9d81843b682274c2f62fa49cb68f762a71a188a852c1fbe200380683c3f5977e7a4ac6088c9de60522c7eb18ffe40014d
+MISC ChangeLog 3718 SHA256 9eba2fe2c0a24e5d3d009244d3ef3b8fcec9c07592b9c06c3d1e6cb8208ac0b9 SHA512 4791d1abad16bd0941b27e20c42544e7a03c0dbebc3bcfaebda8335073c3ebcfdf43f8ea11fdf057f40fb4494169ec9ad05281eed0003e1e6822243ba378e851 WHIRLPOOL abf64c4843f0fef237d781a12fb62e871cad1a051871219eecef64bfcfd13c0e609aa539793c2e5bf9c081f46581599c5d4b81c25c74084fd3dbc8ff82b9fe75
+MISC ChangeLog-2015 1020 SHA256 adbcc4be574325ab7cbcb7818caadda9186a5899bef4fe6683ae3c578aa46d83 SHA512 251433f3cebf9c15485694158c758f1ef338ee80a22f5f92eb48340ef7d4b48cb9429af24bcea4de9703dd39184982c23a6a6b46388410517996b9455ed28feb WHIRLPOOL 757d5b762d8c18f977a800902f3607b2e72259f17671b394754c3d5ec92b1ab69e022cc4417cf9da23d959340a1bb5932f197d03f88851249f219ce16c345824
+MISC metadata.xml 322 SHA256 a58cd7debf987c07936f6d177f194b4f717e34be7016ff1d53c837ce150ff111 SHA512 e05b00f770c010b4d7776a79923b8b683679cdf36a2ab5d995cf907fc1dbeb86f3538753d25a743277937f625d15d9f9d5d2679096e9fa382c1d47b4c240d61c WHIRLPOOL 0956dab8af89f43c17a3a2b2e22b69a1342005e7f4fee305402314fd7a53557ed326fa8c53f812a440ab8a1a599e765bcbca26847b1243e3897300aefa021baa
diff --git a/games-emulation/m64py/m64py-0.2.3-r2.ebuild b/games-emulation/m64py/m64py-0.2.3-r2.ebuild
new file mode 100644
index 000000000000..1354ee993bba
--- /dev/null
+++ b/games-emulation/m64py/m64py-0.2.3-r2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python3_{4,5} )
+
+inherit distutils-r1 versionator
+
+DESCRIPTION="A frontend for Mupen64Plus"
+HOMEPAGE="http://m64py.sourceforge.net/"
+SRC_URI="mirror://sourceforge/m64py/${P}.tar.gz"
+
+LICENSE="GPL-3 LGPL-3 public-domain GPL-2 BSD CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# SDL & libmupen64plus are through ctypes, so they rely on specific ABI
+RDEPEND="media-libs/libsdl2:0/0[joystick]
+ dev-python/PyQt5[gui,opengl,widgets,${PYTHON_USEDEP}]
+ >=games-emulation/mupen64plus-core-2.5:0/2-sdl2"
+
+python_prepare_all() {
+ # set the correct search path
+ cat >> src/m64py/platform.py <<-_EOF_
+ SEARCH_DIRS = ["/usr/$(get_libdir)/mupen64plus"]
+_EOF_
+
+ # force SDL2 support to match >=mupen64plus-2.5
+ sed -e '/--sdl2/d' \
+ -e '/SDL2/s:=.*$:= True:' \
+ -i src/m64py/opts.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+pkg_postinst() {
+ local vr
+ for vr in ${REPLACING_VERSIONS}; do
+ if ! version_is_at_least 0.2.1-r1 ${vr}; then
+ ewarn
+ ewarn "Starting with mupen64plus-2.0-r1, the plugin install path has changed."
+ ewarn "In order for m64py to find mupen64plus, you will either need to set"
+ ewarn "new paths in configuration dialog or remove your configuration file."
+ ewarn "The new paths are:"
+ ewarn
+ ewarn " Library file: /usr/$(get_libdir)/libmupen64plus.so.2.0.0"
+ ewarn " Plugins directory: /usr/$(get_libdir)/mupen64plus"
+ ewarn " Data directory: /usr/share/mupen64plus"
+ fi
+ done
+
+ if ! type -P rar >/dev/null && ! type -P unrar >/dev/null; then
+ elog
+ elog "In order to gain RAR archive support, please install either app-arch/rar"
+ elog "or app-arch/unrar."
+ fi
+
+ if ! type -P 7z >/dev/null \
+ && ! has_version "dev-python/pylzma[${PYTHON_USEDEP}]"; then
+ elog
+ elog "In order to gain 7z archive support, please install either app-arch/p7zip"
+ elog "or dev-python/pylzma."
+ fi
+}
diff --git a/games-emulation/m64py/metadata.xml b/games-emulation/m64py/metadata.xml
new file mode 100644
index 000000000000..c8f77563ef65
--- /dev/null
+++ b/games-emulation/m64py/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">m64py</remote-id>
+ </upstream>
+</pkgmetadata>