summaryrefslogtreecommitdiff
path: root/games-emulation/m64py
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /games-emulation/m64py
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'games-emulation/m64py')
-rw-r--r--games-emulation/m64py/Manifest2
-rw-r--r--games-emulation/m64py/m64py-0.2.5_p20211222.ebuild70
2 files changed, 72 insertions, 0 deletions
diff --git a/games-emulation/m64py/Manifest b/games-emulation/m64py/Manifest
index 7667a41af109..38b034dbad38 100644
--- a/games-emulation/m64py/Manifest
+++ b/games-emulation/m64py/Manifest
@@ -1,3 +1,5 @@
DIST m64py-0.2.5.tar.gz 201868 BLAKE2B 95cbfe58ae2741caac5e05bcc06af563ee398d2916d07902ba4aaf4213277eea3c6219448db5958e0a2d0ea8ea3f65c88e63cfd2938a8b4ed33231ba57ae724f SHA512 338f5e96dc4657ba2230c32a40cf0e85c5efcccaa0d5fdbe4b4dcef020b910f5d2d88e5c224f8b496ec0378051aaf44358a0438de52fb03b4ece353f55abc61c
+DIST mupen64plus-ui-python-e24679436a93e8aae0aa664dc4b2dea40d8236c1.gh.tar.gz 14669412 BLAKE2B 08232599557503d606db9e44bdd6dbb30b3fa125bfd9b9bcc2cbc4b6ea71b567f5af4338d03e7580707db522249d9426ec4d64dc1e941a43076b2d21bc974b67 SHA512 2ba865041827a7f47d5151db6123abd62c964c024c14356aa5434619736b19ce150178d536cff1c84e93d0544823e173c67c0f08054c13e01f085912a9b8c2c6
EBUILD m64py-0.2.5.ebuild 1043 BLAKE2B 111eb56dc00476b82232271139fd901953a4cee509240cf7886a70edd13dab7e45670c0ff7d122dd844971ffd0a3319c5ab36ed7845b2fda9b875eb46bd55680 SHA512 937341ce08af29ff6dedb16fba2a8ce96619c204e21ebf8baed379c9149a790390f31a0e164e109a3ff6045344559592afba9e0a32931af6141d988aa5a7acd0
+EBUILD m64py-0.2.5_p20211222.ebuild 1442 BLAKE2B 41e2821f3b454027e6cace327bed022fdb7e9b5091cd42d1482da9d47589063d799f213bf87638fb7c9df7d945c4a71d172f09b17d849a83801c296818ab6643 SHA512 685bd315a10a0ed97a98cf0a3d475caf7a2b207bea1de176c406cd156b1420edc71b3aa9736dc5bc0888ab57f68f6639be07a89c05a717582f98330410a56b59
MISC metadata.xml 456 BLAKE2B 2dd1c7b525e4d6f4cd36d5802de988a44de85e13cdc692bf97d570ca34d51046f26e78f3e3d7162449f10aaa1c44f17f60f5b607a86995a87b24399093f3b759 SHA512 fca6b42d62404f72c4fd223d60f1a7ea7f7d5e5a5a31d0a38c1eae88b53f3ade5a515088fb6e97a86effe36bc76ae652119bbdeb404188f09df61b6f5562004f
diff --git a/games-emulation/m64py/m64py-0.2.5_p20211222.ebuild b/games-emulation/m64py/m64py-0.2.5_p20211222.ebuild
new file mode 100644
index 000000000000..7f6898ba649b
--- /dev/null
+++ b/games-emulation/m64py/m64py-0.2.5_p20211222.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 qmake-utils xdg-utils
+
+EGIT_COMMIT="e24679436a93e8aae0aa664dc4b2dea40d8236c1"
+MY_P=mupen64plus-ui-python-${EGIT_COMMIT}
+
+DESCRIPTION="A frontend for Mupen64Plus"
+HOMEPAGE="
+ http://m64py.sourceforge.net/
+ https://github.com/mupen64plus/mupen64plus-ui-python/
+"
+SRC_URI="
+ https://github.com/mupen64plus/mupen64plus-ui-python/archive/${EGIT_COMMIT}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-3 LGPL-3 public-domain GPL-2 BSD CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="7z rar"
+
+RDEPEND="
+ dev-python/PyQt5[gui,opengl,widgets,${PYTHON_USEDEP}]
+ dev-python/PySDL2[${PYTHON_USEDEP}]
+ media-libs/libsdl2[joystick,video]
+ >=games-emulation/mupen64plus-core-2.5:0/2-sdl2
+ 7z? (
+ app-arch/p7zip
+ )
+ rar? (
+ || (
+ dev-python/rarfile[${PYTHON_USEDEP}]
+ app-arch/unrar
+ app-arch/rar
+ )
+ )
+"
+BDEPEND="
+ dev-qt/linguist-tools:5
+"
+
+python_prepare_all() {
+ # set the correct search path
+ cat >> src/m64py/platform.py <<-_EOF_ || die
+ SEARCH_DIRS = ["/usr/$(get_libdir)/mupen64plus"]
+ _EOF_
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ local -x PATH=$(qt5_get_bindir):${PATH}
+ distutils-r1_python_compile
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}