summaryrefslogtreecommitdiff
path: root/games-emulation/jrommanager
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
commite3872864be25f7421015bef2732fa57c0c9fb726 (patch)
tree9cb29a544215119b5c5538e37211b994ce1c87ae /games-emulation/jrommanager
parent480486b52ea64765faf696c88b2c6a26a5a454d4 (diff)
gentoo resync : 04.08.2018
Diffstat (limited to 'games-emulation/jrommanager')
-rw-r--r--games-emulation/jrommanager/Manifest3
-rw-r--r--games-emulation/jrommanager/jrommanager-1.6_p20-r1.ebuild41
-rw-r--r--games-emulation/jrommanager/metadata.xml21
3 files changed, 65 insertions, 0 deletions
diff --git a/games-emulation/jrommanager/Manifest b/games-emulation/jrommanager/Manifest
new file mode 100644
index 000000000000..69eb38e7f14b
--- /dev/null
+++ b/games-emulation/jrommanager/Manifest
@@ -0,0 +1,3 @@
+DIST JRomManager-1.6b20.zip 9284236 BLAKE2B a874837e90bdd8ec6c55850fd0e61cabeb767f4b4eba6517a11f3de036a6fd95f7507593da7b5247824c38077b12ac52c490f5ec0e72077bd972c78810c58ebd SHA512 5d4a98989bd9eb2ba94dd50fe451308d9a628414e33cdc84814c55bf9679c3779253a8fab895e2f7922e3b837949e8065f2799707aeaab94d79a12ba73d83638
+EBUILD jrommanager-1.6_p20-r1.ebuild 975 BLAKE2B e0c596f31ce3b26f834bd9005583b2169ee58b808074e740c697ed58d8bf8ec2fa99b63adaa0a202810ce606f471cb4a1a626929c063d64e20c49cbafee2bcc7 SHA512 a46bca65f51962fe62ce45c1bb9de81c5f5d8076a56126a83a1681aad0602453f826c266401d0424bee312c99295310a2aa1c980a200e60299d99134f00bf451
+MISC metadata.xml 831 BLAKE2B 814a9b1567202d8a7cf26370e0670a726ded26886231f46358a13b4538d4b4a048d09f116e1d6a743be16790b3aec8fc35911a2446fc851d8af48446255de334 SHA512 c7516078eb437a57048567be0d904c643a0860d6fee189cc92de1e300d15be1fc5143e42d2c2f8d412e893c8a00edc1db72fc7ef1c852ede33b120d84bf8986e
diff --git a/games-emulation/jrommanager/jrommanager-1.6_p20-r1.ebuild b/games-emulation/jrommanager/jrommanager-1.6_p20-r1.ebuild
new file mode 100644
index 000000000000..6db4f6fa4a94
--- /dev/null
+++ b/games-emulation/jrommanager/jrommanager-1.6_p20-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN=JRomManager
+MY_PV=${PV/_p/b}
+MY_P="${MY_PN}-${MY_PV}"
+
+inherit desktop
+
+DESCRIPTION="A Mame and Retrogaming Rom Manager, Java alternative to ClrMamePro"
+HOMEPAGE="https://github.com/optyfr/JRomManager"
+SRC_URI="https://github.com/optyfr/${MY_PN}/releases/download/${MY_PV}/${MY_P}.zip"
+QA_PREBUILT="*"
+
+S="${WORKDIR}"
+
+LICENSE="GPL-3 GPL-2-with-classpath-exception BSD-2 MIT Apache-2.0 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=virtual/jre-1.8"
+DEPEND="${DEPEND}
+ app-arch/unzip"
+
+src_prepare() {
+ default
+
+ sed -e "/dir=.*/s:.*:cd \"${EROOT}/usr/share/${PN}\" || exit:" -i *.sh || die "sed failed!"
+ unzip -j ${MY_PN}.jar "jrm/resources/rom.png" || die
+}
+
+src_install() {
+ insinto "/usr/share/${PN}"
+ doins *.jar
+ doins -r lib
+ newbin "${MY_PN}-multi.sh" "${PN}"
+ newicon "rom.png" "${PN}.png"
+ make_desktop_entry "${PN}" '' '' 'Utility'
+}
diff --git a/games-emulation/jrommanager/metadata.xml b/games-emulation/jrommanager/metadata.xml
new file mode 100644
index 000000000000..0387c7c893ea
--- /dev/null
+++ b/games-emulation/jrommanager/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>opty@hotmail.fr</email>
+ <name>optyfr</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ JRomManager is a Rom manager made to work mostly anywhere,
+ with decent performance and minimal memory footprint,
+ some attention was also made to work correctly over shared networks.
+ It has also been made available open source to permit enhancements
+ from the retro gaming community. The main focus is to support MAME
+ and derivatives, but should work well with any Dat file from other
+ roms sets.
+ </longdescription>
+</pkgmetadata>