summaryrefslogtreecommitdiff
path: root/games-emulation/jrommanager/jrommanager-1.8_p27-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
commit3f71901f8c228f4de570abed1831ce3ee425343e (patch)
treea2dcd300d05ef8a2ec275b44a92a9d85bd3baa24 /games-emulation/jrommanager/jrommanager-1.8_p27-r1.ebuild
parent12bb627384ddfd47382b9f1b6464481a58d01ebb (diff)
gentoo resync 08.09.2018
Diffstat (limited to 'games-emulation/jrommanager/jrommanager-1.8_p27-r1.ebuild')
-rw-r--r--games-emulation/jrommanager/jrommanager-1.8_p27-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/games-emulation/jrommanager/jrommanager-1.8_p27-r1.ebuild b/games-emulation/jrommanager/jrommanager-1.8_p27-r1.ebuild
new file mode 100644
index 000000000000..5a3f091d0147
--- /dev/null
+++ b/games-emulation/jrommanager/jrommanager-1.8_p27-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN=JRomManager
+MY_PV=${PV/_p/b}
+MY_P="${MY_PN}-${MY_PV}"
+
+inherit desktop
+
+DESCRIPTION="A Mame and Retrogaming Rom Manager, Java alternative to ClrMamePro"
+HOMEPAGE="https://github.com/optyfr/JRomManager"
+SRC_URI="https://github.com/optyfr/${MY_PN}/releases/download/${MY_PV}/${MY_P}.zip"
+QA_PREBUILT="*"
+
+S="${WORKDIR}"
+
+LICENSE="GPL-2 GPL-2-with-classpath-exception BSD-2 MIT Apache-2.0 LGPL-2.1 unRAR"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=virtual/jre-1.8"
+DEPEND="${DEPEND}
+ app-arch/unzip"
+
+src_prepare() {
+ default
+
+ sed -e "/cd.*/s:.*:cd \"${EROOT}/usr/share/${PN}\" || exit:" -i *.sh || die "sed failed!"
+ unzip -j ${MY_PN}.jar "jrm/resources/rom.png" || die
+}
+
+src_install() {
+ insinto "/usr/share/${PN}"
+ doins *.jar
+ doins -r lib
+ newbin "${MY_PN}-multi.sh" "${PN}"
+ newicon "rom.png" "${PN}.png"
+ make_desktop_entry "${PN}" '' '' 'Utility'
+}