summaryrefslogtreecommitdiff
path: root/games-emulation/jollycv-jg
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-15 17:55:24 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-15 17:55:24 +0000
commit3392d5e937023e57811edc670b0ed7d3aba55c6d (patch)
tree32c103a9b86223dcc05105e88f05d471bcaf0886 /games-emulation/jollycv-jg
parent046c3c0984fd20387a9f86cdd0842fd81e70d94f (diff)
gentoo auto-resync : 15:01:2023 - 17:55:24
Diffstat (limited to 'games-emulation/jollycv-jg')
-rw-r--r--games-emulation/jollycv-jg/Manifest4
-rw-r--r--games-emulation/jollycv-jg/jollycv-jg-1.0.1.ebuild46
-rw-r--r--games-emulation/jollycv-jg/jollycv-jg-9999.ebuild46
-rw-r--r--games-emulation/jollycv-jg/metadata.xml21
4 files changed, 117 insertions, 0 deletions
diff --git a/games-emulation/jollycv-jg/Manifest b/games-emulation/jollycv-jg/Manifest
new file mode 100644
index 000000000000..a3817b94a699
--- /dev/null
+++ b/games-emulation/jollycv-jg/Manifest
@@ -0,0 +1,4 @@
+DIST jollycv-1.0.1.tar.bz2 58785 BLAKE2B 1d9897ac7ad8eff10d27f72b0b4d2036266fdcefd208266dab7ae52815b952f35a997b78b53c8c4aa7ba88abee969badec4cefd4c4c0dbfba2114e2f287ce6e5 SHA512 e52866dc70ccdc9829a055158078ddc842adde11fd42b1f06b1af278d7a9edf5c950a4f2297cc47acdac0ad85174c8b8b219ab9c411754d5eec7c190456ef9ef
+EBUILD jollycv-jg-1.0.1.ebuild 889 BLAKE2B a5b49f4a6de24beb53a7b3267bff13d8d7bf1395189749414febaec6638b4a7ac68a12b3d177e952eef0eee481bbe60e85836dedc9078ad530ad3806c600a5d6 SHA512 5042e521b927583a11fa78a29218feaf2e5accc513f024a8e8ff46a6848df85e4cdf93f7c54b47293d6eb44d0a79537bdbeffa352d6b480aa61d135b61272315
+EBUILD jollycv-jg-9999.ebuild 889 BLAKE2B a5b49f4a6de24beb53a7b3267bff13d8d7bf1395189749414febaec6638b4a7ac68a12b3d177e952eef0eee481bbe60e85836dedc9078ad530ad3806c600a5d6 SHA512 5042e521b927583a11fa78a29218feaf2e5accc513f024a8e8ff46a6848df85e4cdf93f7c54b47293d6eb44d0a79537bdbeffa352d6b480aa61d135b61272315
+MISC metadata.xml 759 BLAKE2B e56b25f250b7d989c90aa4890b2378f2c9347623a11857d779b8737098bb39315f39a1fa554cfdaab89ff195d361caa13fb006dc920aaef6bd2cb13d1eca3a85 SHA512 cb04de69167f168046052950c627659e7bfd8ef0bd1b73e135240e61b45747d5d974282da8d65b5e3b44203fcf225aa2b341592a20e1cc35e218e2db0103135b
diff --git a/games-emulation/jollycv-jg/jollycv-jg-1.0.1.ebuild b/games-emulation/jollycv-jg/jollycv-jg-1.0.1.ebuild
new file mode 100644
index 000000000000..5e053a30bdb2
--- /dev/null
+++ b/games-emulation/jollycv-jg/jollycv-jg-1.0.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_PN=${PN%-*}
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Jolly Good ColecoVision Emulator"
+HOMEPAGE="https://gitlab.com/jgemu/jollycv"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/jgemu/${MY_PN}.git"
+else
+ SRC_URI="https://gitlab.com/jgemu/${MY_PN}/-/archive/${PV}/${MY_P}.tar.bz2"
+ S="${WORKDIR}/${MY_P}"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD MIT"
+SLOT="1"
+
+DEPEND="
+ media-libs/jg:1=
+ media-libs/speexdsp
+"
+RDEPEND="
+ ${DEPEND}
+ games-emulation/jgrf
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_compile() {
+ emake CC="$(tc-getCC)" PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_install() {
+ emake install \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}"/usr \
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF} \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)"
+}
diff --git a/games-emulation/jollycv-jg/jollycv-jg-9999.ebuild b/games-emulation/jollycv-jg/jollycv-jg-9999.ebuild
new file mode 100644
index 000000000000..5e053a30bdb2
--- /dev/null
+++ b/games-emulation/jollycv-jg/jollycv-jg-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_PN=${PN%-*}
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Jolly Good ColecoVision Emulator"
+HOMEPAGE="https://gitlab.com/jgemu/jollycv"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/jgemu/${MY_PN}.git"
+else
+ SRC_URI="https://gitlab.com/jgemu/${MY_PN}/-/archive/${PV}/${MY_P}.tar.bz2"
+ S="${WORKDIR}/${MY_P}"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD MIT"
+SLOT="1"
+
+DEPEND="
+ media-libs/jg:1=
+ media-libs/speexdsp
+"
+RDEPEND="
+ ${DEPEND}
+ games-emulation/jgrf
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_compile() {
+ emake CC="$(tc-getCC)" PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_install() {
+ emake install \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}"/usr \
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF} \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)"
+}
diff --git a/games-emulation/jollycv-jg/metadata.xml b/games-emulation/jollycv-jg/metadata.xml
new file mode 100644
index 000000000000..4a63854c7f92
--- /dev/null
+++ b/games-emulation/jollycv-jg/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'https://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>orbea@riseup.net</email>
+ <name>orbea</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ JollyCV is a highly accurate emulator for the ColecoVision,
+ including support for the Super Game Module. It was written in
+ standards compliant ISO C11 specifically for The Jolly Good API.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://gitlab.com/jgemu/jollycv/-/issues</bugs-to>
+ <remote-id type="gitlab">jgemu/jollycv</remote-id>
+ </upstream>
+</pkgmetadata>