summaryrefslogtreecommitdiff
path: root/games-emulation/hatari
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
commit43793fab84041cfc5c60c0151d1591b8a69fb24a (patch)
tree6208a7f4fc744684fce0f55acbb47511acace498 /games-emulation/hatari
parent28e3d252dc8ac8a5635206dfefe1cfe05058d1db (diff)
gentoo resync : 25.08.2018
Diffstat (limited to 'games-emulation/hatari')
-rw-r--r--games-emulation/hatari/Manifest3
-rw-r--r--games-emulation/hatari/files/hatari-2.1.0_caps5_files.patch147
-rw-r--r--games-emulation/hatari/hatari-2.1.0-r1.ebuild (renamed from games-emulation/hatari/hatari-2.1.0.ebuild)7
3 files changed, 154 insertions, 3 deletions
diff --git a/games-emulation/hatari/Manifest b/games-emulation/hatari/Manifest
index b004751ca1f6..8dd62b3390a2 100644
--- a/games-emulation/hatari/Manifest
+++ b/games-emulation/hatari/Manifest
@@ -1,3 +1,4 @@
+AUX hatari-2.1.0_caps5_files.patch 5268 BLAKE2B 8562fee9d01377f368fd5062a26df00297a67eef64fbec5dfdbb789638148f9bcd4ed35132d8b26e6432eb151964a835d96ed828bc151518e4bc19af4f71569c SHA512 9148368f98bddb1083735a9ac9077cf830436c31b69b8e0138080325136f76c65957ca450306fc07ab07c5a47b827a9d2fad026c49af35263f7b0ab070de5358
DIST hatari-2.1.0.tar.bz2 4072778 BLAKE2B 934ab28e799d0d13c26c291005513511367eb2ddbeda0f9756c19f10fa9e6bb8e10451057fa7e0b49a30e3f562eb5f327057d324b2a92e09b1115f63132dca97 SHA512 d1fbf6e60e2df2c43d070bee6a9c1dc93c36a8ea7f75bbf2a67790840952661cee136ebccd6b2ed523ef9b7b56391e058384f2e3f46acb609bb362cac05b9753
-EBUILD hatari-2.1.0.ebuild 1951 BLAKE2B 256870db02e0c0cb6402157af5dc1a108f9dba4b3dbb414a7fa7d0ab3692877dd9baf0462f6a044e027a5d92d313fa479cee7251da75c8a87ed38d140897462b SHA512 7d6b881dfe3d1fbffb800b5ae866699891ee3cdfdbc88dc9633a755b1361d003ef1617648b8b30d1c72b709dc700fb9db4e3b3a5abc030270598b0035cad90d3
+EBUILD hatari-2.1.0-r1.ebuild 2061 BLAKE2B b26dde3a994f4666c25755c3ba79ae8e51c7030f523cfdd7f3d6f4004a7a325479c95df51e0225efdcba190f118dd1d7be9b46f69a08773b0bac99221852217d SHA512 13ca2eec6272b5f40970a6217285c3d850412e3709b484812bb75b5105428546f9c1d589ceba18ceefa1e8b9d0e62eb4316d0e20576ec317d0cb5b8d69d3a977
MISC metadata.xml 318 BLAKE2B be4d8512e3f8fe751fc03aeae422216c9a366fc4cea3a49e4b8050f2a8280054fcc335f820718743fdf49cdb9a1fb73633e596ac8bf989b22f0f5a5fa33bd93b SHA512 2e304611622c91d0bd54f986ac3f02fc504bbd28e5ce03e5b958100b8567012ea0fe2a46884d29dfa18c6a4408fd0283679eb4a4f62c80a40ad748f5c811d943
diff --git a/games-emulation/hatari/files/hatari-2.1.0_caps5_files.patch b/games-emulation/hatari/files/hatari-2.1.0_caps5_files.patch
new file mode 100644
index 000000000000..cac630f66f44
--- /dev/null
+++ b/games-emulation/hatari/files/hatari-2.1.0_caps5_files.patch
@@ -0,0 +1,147 @@
+diff -Nuar hatari-2.1.0-orig/cmake/FindCapsImage.cmake hatari-2.1.0/cmake/FindCapsImage.cmake
+--- hatari-2.1.0-orig/cmake/FindCapsImage.cmake 2018-07-28 20:32:59.164780571 +0300
++++ hatari-2.1.0/cmake/FindCapsImage.cmake 2018-07-28 20:33:16.130781607 +0300
+@@ -1,22 +1,18 @@
+-
+ IF (CAPSIMAGE_INCLUDE_DIR)
+- # Already in cache, be silent
+- SET(CAPSIMAGE_FIND_QUIETLY TRUE)
++ # Already in cache, be silent
++ SET(CAPSIMAGE_FIND_QUIETLY TRUE)
+ ENDIF (CAPSIMAGE_INCLUDE_DIR)
+
+-
+-# Choose the library version to use : 4 or 5
+-SET(CAPSIMAGE_VERSION 5)
+-
+-
+-if(CAPSIMAGE_VERSION STREQUAL 4)
+- SET(CAPSIMAGE_DIR caps)
+- FIND_PATH(CAPSIMAGE_INCLUDE_DIR ${CAPSIMAGE_DIR}/capsimage.h)
++if(ENABLE_CAPSIMAGE5)
++ SET(CAPSIMAGE_VERSION 5)
++ FIND_PATH(CAPSIMAGE_INCLUDE_DIR NAMES CapsAPI.h PATH_SUFFIXES caps5)
+ else()
+- SET(CAPSIMAGE_DIR caps5)
+- FIND_PATH(CAPSIMAGE_INCLUDE_DIR ${CAPSIMAGE_DIR}/CapsAPI.h)
++ SET(CAPSIMAGE_VERSION 4)
++ FIND_PATH(CAPSIMAGE_INCLUDE_DIR NAMES capsimage.h PATH_SUFFIXES caps)
+ endif()
+
++message(${CAPSIMAGE_INCLUDE_DIR})
++
+ if(WIN32)
+ FIND_LIBRARY(CAPSIMAGE_LIBRARY NAMES capsimg PATH_SUFFIXES ${CAPSIMAGE_DIR} )
+ else()
+diff -Nuar hatari-2.1.0-orig/src/CMakeLists.txt hatari-2.1.0/src/CMakeLists.txt
+--- hatari-2.1.0-orig/src/CMakeLists.txt 2018-07-28 20:32:59.152780571 +0300
++++ hatari-2.1.0/src/CMakeLists.txt 2018-07-28 20:33:16.131781607 +0300
+@@ -55,6 +55,10 @@
+ include_directories(${PNG_INCLUDE_DIR})
+ endif(PNG_FOUND)
+
++if(CAPSIMAGE_FOUND)
++ include_directories(${CAPSIMAGE_INCLUDE_DIR})
++endif(CAPSIMAGE_FOUND)
++
+ if(X11_FOUND)
+ include_directories(${X11_INCLUDE_DIR})
+ endif(X11_FOUND)
+diff -Nuar hatari-2.1.0-orig/src/floppy_ipf.c hatari-2.1.0/src/floppy_ipf.c
+--- hatari-2.1.0-orig/src/floppy_ipf.c 2018-07-28 20:32:59.152780571 +0300
++++ hatari-2.1.0/src/floppy_ipf.c 2018-07-28 20:34:32.782786288 +0300
+@@ -30,9 +30,9 @@
+
+ #ifdef HAVE_CAPSIMAGE
+ #if CAPSIMAGE_VERSION == 5
+-#include <caps5/CapsLibAll.h>
++#include <CapsLibAll.h>
+ #else
+-#include <caps/fdc.h>
++#include <fdc.h>
+ #define CAPS_LIB_RELEASE 4
+ #define CAPS_LIB_REVISION 2
+ #endif
+@@ -61,8 +61,8 @@
+
+ struct CapsFdc Fdc; /* Fdc state */
+ struct CapsDrive Drive[ MAX_FLOPPYDRIVES ]; /* Physical drives */
+- CapsLong CapsImage[ MAX_FLOPPYDRIVES ]; /* Image Id or -1 if drive empty */
+- CapsLong CapsImageType[ MAX_FLOPPYDRIVES ]; /* ImageType or -1 if not known */
++ Sint32 CapsImage[ MAX_FLOPPYDRIVES ]; /* Image Id or -1 if drive empty */
++ Sint32 CapsImageType[ MAX_FLOPPYDRIVES ]; /* ImageType or -1 if not known */
+
+ int Rev_Track[ MAX_FLOPPYDRIVES ]; /* Needed to handle CAPSSetRevolution for type II/III commands */
+ int Rev_Side[ MAX_FLOPPYDRIVES ];
+@@ -83,9 +83,9 @@
+ static char *IPF_FilenameFindTrackSide (char *FileName);
+ static bool IPF_Insert_RawStreamImage ( int Drive );
+
+-static void IPF_CallBack_Trk ( struct CapsFdc *pc , CapsULong State );
+-static void IPF_CallBack_Irq ( struct CapsFdc *pc , CapsULong State );
+-static void IPF_CallBack_Drq ( struct CapsFdc *pc , CapsULong State );
++static void IPF_CallBack_Trk ( struct CapsFdc *pc , Uint32 State );
++static void IPF_CallBack_Irq ( struct CapsFdc *pc , Uint32 State );
++static void IPF_CallBack_Drq ( struct CapsFdc *pc , Uint32 State );
+ static void IPF_Drive_Update_Enable_Side ( void );
+ static void IPF_FDC_LogCommand ( Uint8 Command );
+ #endif
+@@ -419,8 +419,8 @@
+ return false;
+
+ #else
+- CapsLong ImageId;
+- CapsLong ImageType;
++ Sint32 ImageId;
++ Sint32 ImageType;
+
+ ImageId = CAPSAddImage();
+ if ( ImageId < 0 )
+@@ -470,7 +470,7 @@
+ ImageType = -1;
+ #endif
+
+- if ( CAPSLockImageMemory ( ImageId , pImageBuffer , (CapsULong)ImageSize , DI_LOCK_MEMREF ) == imgeOk )
++ if ( CAPSLockImageMemory ( ImageId , pImageBuffer , (Uint32)ImageSize , DI_LOCK_MEMREF ) == imgeOk )
+ {
+ struct CapsImageInfo cii;
+ int i;
+@@ -703,7 +703,7 @@
+ * We need to update the track data by calling CAPSLockTrack
+ */
+ #ifdef HAVE_CAPSIMAGE
+-static void IPF_CallBack_Trk ( struct CapsFdc *pc , CapsULong State )
++static void IPF_CallBack_Trk ( struct CapsFdc *pc , Uint32 State )
+ {
+ int Drive = State; /* State is the drive number in that case */
+ struct CapsDrive *pd = pc->drive+Drive; /* Current drive where the track change occurred */
+@@ -732,7 +732,7 @@
+ * Callback function used when the FDC change the IRQ signal
+ */
+ #ifdef HAVE_CAPSIMAGE
+-static void IPF_CallBack_Irq ( struct CapsFdc *pc , CapsULong State )
++static void IPF_CallBack_Irq ( struct CapsFdc *pc , Uint32 State )
+ {
+ LOG_TRACE(TRACE_FDC, "fdc ipf callback irq state=0x%x VBL=%d HBL=%d\n" , (int)State , nVBLs , nHBL );
+
+@@ -751,7 +751,7 @@
+ * -> copy the byte to/from the DMA's FIFO if it's a read or a write to the disk
+ */
+ #ifdef HAVE_CAPSIMAGE
+-static void IPF_CallBack_Drq ( struct CapsFdc *pc , CapsULong State )
++static void IPF_CallBack_Drq ( struct CapsFdc *pc , Uint32 State )
+ {
+ Uint8 Byte;
+
+diff -Nuar hatari-2.1.0-orig/src/uae-cpu/newcpu.c hatari-2.1.0/src/uae-cpu/newcpu.c
+--- hatari-2.1.0-orig/src/uae-cpu/newcpu.c 2018-07-28 20:32:59.158780571 +0300
++++ hatari-2.1.0/src/uae-cpu/newcpu.c 2018-07-28 20:33:16.132781607 +0300
+@@ -167,7 +167,7 @@
+
+ #ifdef HAVE_CAPSIMAGE
+ #if CAPSIMAGE_VERSION == 5
+-#include <caps5/CapsLibAll.h>
++#include <CapsLibAll.h>
+ #endif
+ #endif
+
diff --git a/games-emulation/hatari/hatari-2.1.0.ebuild b/games-emulation/hatari/hatari-2.1.0-r1.ebuild
index 92eba857519e..7bb3815e13af 100644
--- a/games-emulation/hatari/hatari-2.1.0.ebuild
+++ b/games-emulation/hatari/hatari-2.1.0-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=6
PYTHON_COMPAT=( python2_7 )
-inherit toolchain-funcs cmake-utils python-single-r1
+inherit cmake-utils python-single-r1 readme.gentoo-r1
DESCRIPTION="Atari ST emulator"
HOMEPAGE="http://hatari.tuxfamily.org/"
@@ -16,7 +16,7 @@ IUSE="+sdl2"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="${PYTHON_DEPS}
- games-emulation/caps
+ >=dev-libs/spsdeclib-5.1-r1
sdl2? ( media-libs/libsdl2[X,sound,video] )
!sdl2? ( media-libs/libsdl[X,sound,video] )
media-libs/portaudio
@@ -40,6 +40,7 @@ The first time you run hatari, you should configure it to find the
TOS you prefer to use. Be sure to save your settings.
"
+PATCHES=( "${FILESDIR}/${P}_caps5_files.patch" )
DOCS="readme.txt doc/*.txt"
HTML_DOCS="doc/"
@@ -55,6 +56,7 @@ src_configure() {
mycmakeargs=(
"-DDOCDIR=/usr/share/doc/${PF}"
"-DENABLE_SDL2=$(usex sdl2)"
+ "-DENABLE_CAPSIMAGE5=ON"
)
cmake-utils_src_configure
}
@@ -62,6 +64,7 @@ src_configure() {
src_install() {
cmake-utils_src_install
python_fix_shebang "${ED%/}"/usr/share/hatari/{hatariui,hconsole}/
+ readme.gentoo_create_doc
}
pkg_postinst() {