summaryrefslogtreecommitdiff
path: root/games-emulation/gnuboy/gnuboy-1.0.3-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-21 23:14:26 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-21 23:14:26 +0100
commit7c59acba5699c9c58090a7a738669669a7307023 (patch)
treed51d27d020895a6b7a3298d9d1b9846c1fcb59a0 /games-emulation/gnuboy/gnuboy-1.0.3-r4.ebuild
parente2db47eaae00ec33f8971db44b68645c5d3b9590 (diff)
gentoo resync : 21.08.2021
Diffstat (limited to 'games-emulation/gnuboy/gnuboy-1.0.3-r4.ebuild')
-rw-r--r--games-emulation/gnuboy/gnuboy-1.0.3-r4.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/games-emulation/gnuboy/gnuboy-1.0.3-r4.ebuild b/games-emulation/gnuboy/gnuboy-1.0.3-r4.ebuild
new file mode 100644
index 000000000000..6fcd97ea2826
--- /dev/null
+++ b/games-emulation/gnuboy/gnuboy-1.0.3-r4.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Gameboy emulator with multiple renderers"
+HOMEPAGE="https://sourceforge.net/projects/gnuboy/"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X +sdl"
+REQUIRED_USE="!X? ( sdl )"
+
+RDEPEND="
+ X? (
+ x11-libs/libX11
+ x11-libs/libXext
+ )
+ sdl? ( media-libs/libsdl[joystick,sound,video] )"
+DEPEND="
+ ${RDEPEND}
+ X? ( x11-base/xorg-proto )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-exec-stack.patch
+ "${FILESDIR}"/${P}-linux-headers.patch
+ "${FILESDIR}"/${P}-include.patch
+ "${FILESDIR}"/${P}-fix-implicit-decl-sprintf.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ local econfargs=(
+ $(use_with X x)
+ $(use_with sdl)
+ $(use_enable x86 asm)
+ --disable-arch
+ --disable-optimize
+ )
+
+ econf "${econfargs[@]}"
+}
+
+src_install() {
+ use X && dobin xgnuboy
+ use sdl && dobin sdlgnuboy
+
+ dodoc README docs/{CHANGES,CONFIG,CREDITS,FAQ,HACKING,WHATSNEW}
+}