summaryrefslogtreecommitdiff
path: root/games-emulation/gngb/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:58:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:58:29 +0100
commit0cf2f20608308acdf3cb922c3736446bbd8f3388 (patch)
tree07815070629c7c11000a7f51ceb8ccbccb49a809 /games-emulation/gngb/files
parent1798c4aeca70ac8d0a243684d6a798fbc65735f8 (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-emulation/gngb/files')
-rw-r--r--games-emulation/gngb/files/gngb-20060309-amd64.patch30
-rw-r--r--games-emulation/gngb/files/gngb-20060309-gcc34.patch22
-rw-r--r--games-emulation/gngb/files/gngb-20060309-gcc5.patch35
-rw-r--r--games-emulation/gngb/files/gngb-20060309-gcc7.patch73
-rw-r--r--games-emulation/gngb/files/gngb-20060309-inline.patch24
-rw-r--r--games-emulation/gngb/files/gngb-20060309-joystick.patch56
-rw-r--r--games-emulation/gngb/files/gngb-20060309-qwerty.patch24
7 files changed, 0 insertions, 264 deletions
diff --git a/games-emulation/gngb/files/gngb-20060309-amd64.patch b/games-emulation/gngb/files/gngb-20060309-amd64.patch
deleted file mode 100644
index 1e63ee00dd26..000000000000
--- a/games-emulation/gngb/files/gngb-20060309-amd64.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From: Chris Lamb <lamby@debian.org>
-Date: Wed, 16 Aug 2017 22:53:10 +0200
-Subject: reproducible build
-
-Bug-Debian: https://bugs.debian.org/831773
----
- configure.in | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/configure.in b/configure.in
-index 9b8aeec..145bd73 100644
---- a/configure.in
-+++ b/configure.in
-@@ -90,6 +90,7 @@ fi
- dnl Arch
-
- case `uname -m` in
-+*x86_64) arch_info=x86_64 ;;
- *686) arch_info=i686 ;;
- *i586) arch_info=i586 ;;
- *i486) arch_info=i486 ;;
-@@ -107,7 +108,7 @@ sys_info=`uname -s`
- AC_MSG_RESULT(System: $sys_info)
-
- case $arch_info in
--i686|i586|i486|i386) OPT="-O3 -Wno-unused -funroll-loops -fstrength-reduce \
-+x86_64|i686|i586|i486|i386) OPT="-O3 -Wno-unused -funroll-loops -fstrength-reduce \
- -ffast-math -falign-functions=2 -falign-jumps=2 \
- -falign-loops=2 -fomit-frame-pointer -Wall " ;;
- sun4u) OPT="-O3 -Wno-unused -funroll-loops -fstrength-reduce \
diff --git a/games-emulation/gngb/files/gngb-20060309-gcc34.patch b/games-emulation/gngb/files/gngb-20060309-gcc34.patch
deleted file mode 100644
index 112569287fd3..000000000000
--- a/games-emulation/gngb/files/gngb-20060309-gcc34.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From: Debian Games Team <pkg-games-devel@lists.alioth.debian.org>
-Date: Thu, 10 Aug 2017 19:06:35 +0000
-Subject: FTBFS_with_gcc-3.4_conflicting_types
-
-===================================================================
----
- src/save.c | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/src/save.c b/src/save.c
-index c7e4395..bf50bdf 100644
---- a/src/save.c
-+++ b/src/save.c
-@@ -404,6 +404,8 @@ int save_load_rt_info(GNGB_FILE * stream,char op) {
- return 0;
- }
-
-+void movie_add_pad(Uint8 pad);
-+
- int save_load_pad_movie(GNGB_FILE * stream,char op) {
- if (!op) { /* Write */
- PAD_SAVE *p=gngb_movie.first_pad;
diff --git a/games-emulation/gngb/files/gngb-20060309-gcc5.patch b/games-emulation/gngb/files/gngb-20060309-gcc5.patch
deleted file mode 100644
index 72dd21a494fb..000000000000
--- a/games-emulation/gngb/files/gngb-20060309-gcc5.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From: Debian Games Team <pkg-games-devel@lists.alioth.debian.org>
-Date: Thu, 10 Aug 2017 19:06:36 +0000
-Subject: gngb_fcc5_fix
-
----
- src/cpu.c | 2 +-
- src/vram.c | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/src/cpu.c b/src/cpu.c
-index f03a811..57bc209 100644
---- a/src/cpu.c
-+++ b/src/cpu.c
-@@ -2826,7 +2826,7 @@ __inline__ void rom_timer_inc(void) {
- }
- }
-
--__inline__ void cpu_run(void) {
-+extern __inline__ void cpu_run(void) {
- static Uint32 divid_cycle;
- int v=0;
- Uint8 a;
-diff --git a/src/vram.c b/src/vram.c
-index 206b625..7213b4e 100644
---- a/src/vram.c
-+++ b/src/vram.c
-@@ -242,7 +242,7 @@ void switch_fullscreen(void) {
- conf.fs^=1;
- }
-
--__inline__ Uint8 get_nb_spr(void)
-+extern __inline__ Uint8 get_nb_spr(void)
- {
- Uint8 *sp=oam_space;
- Sint16 no_tile,x,y,att;
diff --git a/games-emulation/gngb/files/gngb-20060309-gcc7.patch b/games-emulation/gngb/files/gngb-20060309-gcc7.patch
deleted file mode 100644
index 557e69501dc9..000000000000
--- a/games-emulation/gngb/files/gngb-20060309-gcc7.patch
+++ /dev/null
@@ -1,73 +0,0 @@
-From: Markus Koschany <apo@debian.org>
-Date: Thu, 10 Aug 2017 19:39:05 +0000
-Subject: gcc7
-
-Bug-Debian: https://bugs.debian.org/853425
-Forwarded: no
----
- src/cpu.c | 10 +++++-----
- src/memory.c | 2 +-
- 2 files changed, 6 insertions(+), 6 deletions(-)
-
-diff --git a/src/cpu.c b/src/cpu.c
-index 57bc209..5209548 100644
---- a/src/cpu.c
-+++ b/src/cpu.c
-@@ -61,7 +61,7 @@ static Uint8 a;
- #define H (gbcpu->hl.b.h)
- #define L (gbcpu->hl.b.l)
-
--__inline__ Uint16 get_word(void)
-+extern __inline__ Uint16 get_word(void)
- {
- //Uint16 v=((Uint16)(mem_read(PC)));
- Uint16 v1,v2;
-@@ -74,7 +74,7 @@ __inline__ Uint16 get_word(void)
- //return v;
- }
-
--__inline__ Uint8 get_byte(void)
-+extern __inline__ Uint8 get_byte(void)
- {
- //Uint8 t=mem_read(PC);
- Uint8 t;
-@@ -83,7 +83,7 @@ __inline__ Uint8 get_byte(void)
- return t;
- }
-
--__inline__ void push_r(REG *r)
-+extern __inline__ void push_r(REG *r)
- {
- //mem_write(--SP,(r)->b.h);
- //mem_write(--SP,(r)->b.l);
-@@ -93,7 +93,7 @@ __inline__ void push_r(REG *r)
- mem_write_fast(SP,(r)->b.l);
- }
-
--__inline__ void pop_r(REG *r)
-+extern __inline__ void pop_r(REG *r)
- {
- //(r)->b.l=mem_read(SP);
- mem_read_fast(SP,(r)->b.l);
-@@ -176,7 +176,7 @@ __inline__ Uint8 unknown(void){
-
-
-
--__inline__ Uint8 gbcpu_exec_one(void)
-+extern __inline__ Uint8 gbcpu_exec_one(void)
- {
- static Uint8 opcode;
- if (gbcpu->ei_flag==1) {
-diff --git a/src/memory.c b/src/memory.c
-index 26e42d9..fd06738 100644
---- a/src/memory.c
-+++ b/src/memory.c
-@@ -737,7 +737,7 @@ Uint8 mem_read_default(Uint16 adr)
- return 0xFF;
- }
-
--__inline__ void update_gb_pad(void) {
-+extern __inline__ void update_gb_pad(void) {
- gb_pad=0;
- if (!conf.play_movie) {
-
diff --git a/games-emulation/gngb/files/gngb-20060309-inline.patch b/games-emulation/gngb/files/gngb-20060309-inline.patch
deleted file mode 100644
index d73ed4cb617b..000000000000
--- a/games-emulation/gngb/files/gngb-20060309-inline.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From: Arthur Marble <arthur@info9.net>
-Date: Wed, 16 Aug 2017 23:49:59 +0200
-Subject: clang-ftbfs
-
-Bug-Debian: https://bugs.debian.org/757486
----
- src/global.h | 5 +++++
- 1 file changed, 5 insertions(+)
-
-diff --git a/src/global.h b/src/global.h
-index bb46387..6a6d2b3 100644
---- a/src/global.h
-+++ b/src/global.h
-@@ -22,5 +22,10 @@
- #include <config.h>
- #include <SDL.h>
-
-+#ifdef __clang__
-+#define __inline__
-+#else
-+#define __inline__ inline
-+#endif
-
- #endif
diff --git a/games-emulation/gngb/files/gngb-20060309-joystick.patch b/games-emulation/gngb/files/gngb-20060309-joystick.patch
deleted file mode 100644
index ec5003a52c61..000000000000
--- a/games-emulation/gngb/files/gngb-20060309-joystick.patch
+++ /dev/null
@@ -1,56 +0,0 @@
-From: Markus Koschany <apo@debian.org>
-Date: Wed, 16 Aug 2017 23:25:30 +0200
-Subject: joystick axis
-
-Bug-Debian: https://bugs.debian.org/592777
-Forwarded: http://m.peponas.free.fr/gngb/news.html
-Origin: http://m.peponas.free.fr/gngb/download/memory.c.diff
----
- src/memory.c | 17 +++++++++++++++++
- 1 file changed, 17 insertions(+)
-
-diff --git a/src/memory.c b/src/memory.c
-index fd06738..9eaef1f 100644
---- a/src/memory.c
-+++ b/src/memory.c
-@@ -67,7 +67,11 @@ Uint8 ram_mask;
- MEM_READ_ENTRY mem_read_tab[0x10];
- MEM_WRITE_ENTRY mem_write_tab[0x10];
-
-+/* doesn't work for negative joy_?_min */
-+/*
- Sint16 joy_x_min=0;joy_x_max=0;joy_y_min=0;joy_y_max=0;
-+*/
-+Sint16 joy_x_min=-32767;joy_x_max=32767;joy_y_min=-32767;joy_y_max=32767;
-
- void (*select_rom_page)(Uint16 adr,Uint8 v);
- void (*select_ram_page)(Uint16 adr,Uint8 v);
-@@ -755,15 +759,28 @@ extern __inline__ void update_gb_pad(void) {
- Sint16 joy_x_pos=joy_axis[jmap[PAD_LEFT]];
- Sint16 joy_y_pos=joy_axis[jmap[PAD_UP]];
-
-+ /* unnecessary if joy_?_min and joy_?_max are minimum and maximum
-+ * values of Sint16
- if (joy_x_pos>joy_x_max) joy_x_max=joy_x_pos;
- if (joy_x_pos<joy_x_min) joy_x_min=joy_x_pos;
- if (joy_y_pos>joy_y_max) joy_y_max=joy_y_pos;
- if (joy_y_pos<joy_y_min) joy_y_min=joy_y_pos;
-+ */
-
-+ /* this doesn't work when joy_x_min or joy_y_min < 0 (mid should be ~0),
-+ * because ((+max) - (-min)) / 2 = ((+max) + (+min)) / 2
- Sint16 joy_x_mid=(joy_x_max-joy_x_min) / 2;
- Sint16 joy_y_mid=(joy_y_max-joy_y_min) / 2;
-+ */
-+ Sint16 joy_x_mid=(joy_x_max+joy_x_min) >> 1;
-+ Sint16 joy_y_mid=(joy_y_max+joy_y_min) >> 1;
-+ /* this doesn't work as joy_x_mid or joy_y_mid approaches 0
- Sint16 joy_x_qua=joy_x_mid / 2;
- Sint16 joy_y_qua=joy_y_mid / 2;
-+ */
-+ /* (difference) / 100 = 1% of possible values */
-+ Sint16 joy_x_qua=(joy_x_max - joy_x_min) / 100;
-+ Sint16 joy_y_qua=(joy_y_max - joy_y_min) / 100;
-
- if ((joy_x_pos<(joy_x_mid-joy_x_qua)) || (key[kmap[PAD_LEFT]])) gb_pad|=0x20;
- if ((joy_x_pos>(joy_x_mid+joy_x_qua)) || (key[kmap[PAD_RIGHT]])) gb_pad|=0x10;
diff --git a/games-emulation/gngb/files/gngb-20060309-qwerty.patch b/games-emulation/gngb/files/gngb-20060309-qwerty.patch
deleted file mode 100644
index 29f563b749e9..000000000000
--- a/games-emulation/gngb/files/gngb-20060309-qwerty.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From: Markus Koschany <apo@debian.org>
-Date: Thu, 17 Aug 2017 00:15:26 +0200
-Subject: sample_gngbrc
-
-Bug-Debian: https://bugs.debian.org/597910
-Forwarded: no
----
- sample_gngbrc | 3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/sample_gngbrc b/sample_gngbrc
-index a76b465..d0fdd3f 100644
---- a/sample_gngbrc
-+++ b/sample_gngbrc
-@@ -65,6 +65,9 @@ map_joy 1,1,0,0,3,2,0,1
-
- map_key 273,274,276,275,120,119,13,303
-
-+# Key configuration qwerty example
-+# map_key 273,274,276,275,122,120,13,303
-+
-
- # Normal GB palette (bright to dark)
- pal_1 0xB8A68D,0x917D5E,0x635030,0x211A10