summaryrefslogtreecommitdiff
path: root/games-emulation/gcube/gcube-0.4-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-emulation/gcube/gcube-0.4-r2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-emulation/gcube/gcube-0.4-r2.ebuild')
-rw-r--r--games-emulation/gcube/gcube-0.4-r2.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/games-emulation/gcube/gcube-0.4-r2.ebuild b/games-emulation/gcube/gcube-0.4-r2.ebuild
new file mode 100644
index 000000000000..6194fc6a2103
--- /dev/null
+++ b/games-emulation/gcube/gcube-0.4-r2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit flag-o-matic
+
+DESCRIPTION="Gamecube emulator"
+HOMEPAGE="http://gcube.exemu.net/"
+SRC_URI="http://gcube.exemu.net/downloads/${P}-src.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ virtual/opengl
+ media-libs/libsdl[joystick,opengl,sound,video]
+ virtual/jpeg:0
+ sys-libs/ncurses:0=
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PV}"
+
+src_prepare() {
+ default
+
+ sed -i -e '/^CFLAGS=-g/d' Makefile.rules || die
+
+ eapply "${FILESDIR}"/${P}-ldflags.patch \
+ "${FILESDIR}"/${P}-underlink.patch \
+ "${FILESDIR}"/${P}-gcc47.patch
+
+ sed -i -e '/^CC=/d' Makefile || die
+
+ append-cflags -std=gnu89 # build with gcc5 (bug #570504)
+}
+
+src_install() {
+ local x
+
+ dobin gcmap gcube
+ for x in bin2dol isopack thpview tplx ; do
+ newbin ${x} ${PN}-${x}
+ done
+
+ einstalldocs
+}