summaryrefslogtreecommitdiff
path: root/games-emulation/dosbox-staging/dosbox-staging-0.77.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-26 00:10:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-26 00:10:07 +0100
commit95461df035e3867364495f065e5e805bf629b2d7 (patch)
tree867dce371a84a696e91be255d89f282975aa0480 /games-emulation/dosbox-staging/dosbox-staging-0.77.1.ebuild
parent46eedbedafdb0040c37884982d4c775ce277fb7b (diff)
gentoo resync : 25.10.2021
Diffstat (limited to 'games-emulation/dosbox-staging/dosbox-staging-0.77.1.ebuild')
-rw-r--r--games-emulation/dosbox-staging/dosbox-staging-0.77.1.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/games-emulation/dosbox-staging/dosbox-staging-0.77.1.ebuild b/games-emulation/dosbox-staging/dosbox-staging-0.77.1.ebuild
index 1cb6c2e10ce3..21a9a75fb1a9 100644
--- a/games-emulation/dosbox-staging/dosbox-staging-0.77.1.ebuild
+++ b/games-emulation/dosbox-staging/dosbox-staging-0.77.1.ebuild
@@ -11,7 +11,9 @@ SRC_URI="https://github.com/dosbox-staging/dosbox-staging/archive/v${PV}.tar.gz
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~ppc64 ~x86"
-IUSE="+alsa debug dynrec +fluidsynth mt-32 network opengl"
+IUSE="+alsa debug dynrec +fluidsynth mt-32 network opengl test"
+
+RESTRICT="!test? ( test )"
RDEPEND="alsa? ( media-libs/alsa-lib )
debug? ( sys-libs/ncurses:0= )
@@ -28,7 +30,7 @@ RDEPEND="alsa? ( media-libs/alsa-lib )
sys-libs/zlib
!games-emulation/dosbox"
DEPEND="${RDEPEND}"
-BDEPEND=""
+BDEPEND="test? ( dev-cpp/gtest )"
DOCS=( AUTHORS README THANKS )
@@ -41,6 +43,10 @@ src_prepare() {
# Disable license and docs install (handled by ebuild)
sed -e "/licenses_dir\|doc_dir/d" -i meson.build || die
+
+ # Test failing on some platforms, bug #817908
+ # https://github.com/dosbox-staging/dosbox-staging/issues/1230
+ sed -i 's/.*soft_limit.*//' tests/meson.build || die
}
src_configure() {
@@ -52,6 +58,7 @@ src_configure() {
$(meson_use mt-32 use_mt32emu)
$(meson_use network use_sdl2_net)
$(meson_use opengl use_opengl)
+ $(meson_feature test unit_tests)
)
meson_src_configure
}