summaryrefslogtreecommitdiff
path: root/games-emulation/dosbox-staging/dosbox-staging-0.77.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-20 23:24:40 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-20 23:24:40 +0100
commit3f9a144d38a57497a44a583d11a6e3dfbe8319d5 (patch)
treecb0e6beb4b79e1f7ccd95c75c9f434fdad11a071 /games-emulation/dosbox-staging/dosbox-staging-0.77.1.ebuild
parent800c4c398cad9dd837da33062e71ccc84114fe05 (diff)
gentoo auto-resync : 20:09:2022 - 23:24:40
Diffstat (limited to 'games-emulation/dosbox-staging/dosbox-staging-0.77.1.ebuild')
-rw-r--r--games-emulation/dosbox-staging/dosbox-staging-0.77.1.ebuild64
1 files changed, 0 insertions, 64 deletions
diff --git a/games-emulation/dosbox-staging/dosbox-staging-0.77.1.ebuild b/games-emulation/dosbox-staging/dosbox-staging-0.77.1.ebuild
deleted file mode 100644
index 652dbe698a9a..000000000000
--- a/games-emulation/dosbox-staging/dosbox-staging-0.77.1.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 2020-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit meson xdg
-
-DESCRIPTION="Modernized DOSBox soft-fork"
-HOMEPAGE="https://dosbox-staging.github.io/"
-SRC_URI="https://github.com/dosbox-staging/dosbox-staging/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="+alsa debug dynrec +fluidsynth mt-32 network opengl test"
-
-RESTRICT="!test? ( test )"
-
-RDEPEND="alsa? ( media-libs/alsa-lib )
- debug? ( sys-libs/ncurses:0= )
- fluidsynth? (
- media-sound/fluid-soundfont
- media-sound/fluidsynth
- )
- mt-32? ( media-libs/munt-mt32emu )
- network? ( media-libs/sdl2-net )
- opengl? ( virtual/opengl )
- media-libs/libpng:0=
- media-libs/libsdl2[joystick,opengl?,video,X]
- media-libs/opusfile
- sys-libs/zlib
- !games-emulation/dosbox"
-DEPEND="${RDEPEND}"
-BDEPEND="test? ( dev-cpp/gtest )"
-
-DOCS=( AUTHORS README THANKS )
-
-src_prepare() {
- default
-
- # We do not have default.sf2, use actual name from fluid-soundfont
- sed -e "s/default.sf2/FluidR3_GM.sf2/" \
- -i src/midi/midi_fluidsynth.cpp || die
-
- # Disable license and docs install (handled by ebuild)
- sed -e "/licenses_dir\|doc_dir/d" -i meson.build || die
-
- # Test failing on some platforms, bug #817908
- # https://github.com/dosbox-staging/dosbox-staging/issues/1230
- sed -i 's/.*soft_limit.*//' tests/meson.build || die
-}
-
-src_configure() {
- local emesonargs=(
- $(meson_use alsa use_alsa)
- $(meson_use debug)
- -Ddynamic_core=$(usex dynrec dynrec dyn-x86)
- $(meson_use fluidsynth use_fluidsynth)
- $(meson_use mt-32 use_mt32emu)
- $(meson_use network use_sdl2_net)
- $(meson_use opengl use_opengl)
- $(meson_feature test unit_tests)
- )
- meson_src_configure
-}