summaryrefslogtreecommitdiff
path: root/games-emulation/cega-jg
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-15 17:55:24 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-15 17:55:24 +0000
commit3392d5e937023e57811edc670b0ed7d3aba55c6d (patch)
tree32c103a9b86223dcc05105e88f05d471bcaf0886 /games-emulation/cega-jg
parent046c3c0984fd20387a9f86cdd0842fd81e70d94f (diff)
gentoo auto-resync : 15:01:2023 - 17:55:24
Diffstat (limited to 'games-emulation/cega-jg')
-rw-r--r--games-emulation/cega-jg/Manifest4
-rw-r--r--games-emulation/cega-jg/cega-jg-0.5.2.ebuild46
-rw-r--r--games-emulation/cega-jg/cega-jg-9999.ebuild46
-rw-r--r--games-emulation/cega-jg/metadata.xml21
4 files changed, 117 insertions, 0 deletions
diff --git a/games-emulation/cega-jg/Manifest b/games-emulation/cega-jg/Manifest
new file mode 100644
index 000000000000..c4f69805ea03
--- /dev/null
+++ b/games-emulation/cega-jg/Manifest
@@ -0,0 +1,4 @@
+DIST cega-0.5.2.tar.bz2 221146 BLAKE2B eba8dcee12ebc2c4f290b7c4546e110bd4d154e3a2d9572fe8a0141c435e45fcd270085882754bf46e0a26388c8b92c5ac390c52b0be3a56a08122acd98d052b SHA512 e2177079a984e531480572e3552d3e52cc14ee2f55ba5d7836becda1c893c9721a637c3e89e992a0fe4039471b41c718f92c53b74f7165690cbc2e709623d7cb
+EBUILD cega-jg-0.5.2.ebuild 914 BLAKE2B 13f71fd8b0a163dbfc55b80d393c060601ea16312789bb638e6e0848d9afff72e90043c7261fb39248505b6789a89986e3191fff3b40e2de0e0f36eb7e8411db SHA512 4ecf68b72baf0acca7fd216837b4250aec68ff26cf193c1d934b5cb31fea398fb8be7270d77001959aea65605714fbda8205721d099741de00788c1a612f3548
+EBUILD cega-jg-9999.ebuild 914 BLAKE2B 13f71fd8b0a163dbfc55b80d393c060601ea16312789bb638e6e0848d9afff72e90043c7261fb39248505b6789a89986e3191fff3b40e2de0e0f36eb7e8411db SHA512 4ecf68b72baf0acca7fd216837b4250aec68ff26cf193c1d934b5cb31fea398fb8be7270d77001959aea65605714fbda8205721d099741de00788c1a612f3548
+MISC metadata.xml 695 BLAKE2B 55931b5cebed94871c4c68d7da3a007150580eea69d4fbdb690d64662c7c4ba14dae657a4c6b3d7153f03b06747154013abbec8c348b56260381b127d6a8aaaa SHA512 860649393496fc099755f0903bad5cb298c26a0f0ebd977defb9958b1926f297d44ab991d07be72036380a5bc744c0f0c56c5d2a9912a20c9e600b5ba24b935e
diff --git a/games-emulation/cega-jg/cega-jg-0.5.2.ebuild b/games-emulation/cega-jg/cega-jg-0.5.2.ebuild
new file mode 100644
index 000000000000..5c0d962a4614
--- /dev/null
+++ b/games-emulation/cega-jg/cega-jg-0.5.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_PN=${PN%-*}
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Jolly Good SG-1000, SMS, and Game Gear Emulator"
+HOMEPAGE="https://gitlab.com/jgemu/cega"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/jgemu/${MY_PN}.git"
+else
+ SRC_URI="https://gitlab.com/jgemu/${MY_PN}/-/archive/${PV}/${MY_P}.tar.bz2"
+ S="${WORKDIR}/${MY_P}"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD MIT MPL-2.0 ZLIB"
+SLOT="1"
+
+DEPEND="
+ media-libs/jg:1=
+ media-libs/speexdsp
+"
+RDEPEND="
+ ${DEPEND}
+ games-emulation/jgrf
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_compile() {
+ emake CC="$(tc-getCC)" PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_install() {
+ emake install \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}"/usr \
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF} \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)"
+}
diff --git a/games-emulation/cega-jg/cega-jg-9999.ebuild b/games-emulation/cega-jg/cega-jg-9999.ebuild
new file mode 100644
index 000000000000..5c0d962a4614
--- /dev/null
+++ b/games-emulation/cega-jg/cega-jg-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_PN=${PN%-*}
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Jolly Good SG-1000, SMS, and Game Gear Emulator"
+HOMEPAGE="https://gitlab.com/jgemu/cega"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/jgemu/${MY_PN}.git"
+else
+ SRC_URI="https://gitlab.com/jgemu/${MY_PN}/-/archive/${PV}/${MY_P}.tar.bz2"
+ S="${WORKDIR}/${MY_P}"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD MIT MPL-2.0 ZLIB"
+SLOT="1"
+
+DEPEND="
+ media-libs/jg:1=
+ media-libs/speexdsp
+"
+RDEPEND="
+ ${DEPEND}
+ games-emulation/jgrf
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_compile() {
+ emake CC="$(tc-getCC)" PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_install() {
+ emake install \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}"/usr \
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF} \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)"
+}
diff --git a/games-emulation/cega-jg/metadata.xml b/games-emulation/cega-jg/metadata.xml
new file mode 100644
index 000000000000..2ee830e4d1ab
--- /dev/null
+++ b/games-emulation/cega-jg/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'https://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>orbea@riseup.net</email>
+ <name>orbea</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ Cega is a cycle accurate emulator for the Sega SG-1000,
+ Master System, and Game Gear written specifically for
+ The Jolly Good API.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://gitlab.com/jgemu/cega/-/issues</bugs-to>
+ <remote-id type="gitlab">jgemu/cega</remote-id>
+ </upstream>
+</pkgmetadata>