summaryrefslogtreecommitdiff
path: root/games-emulation/atari800
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-emulation/atari800
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-emulation/atari800')
-rw-r--r--games-emulation/atari800/Manifest6
-rw-r--r--games-emulation/atari800/atari800-3.1.0-r1.ebuild92
-rw-r--r--games-emulation/atari800/files/atari800-3.1.0-tgetent-detection.patch12
-rw-r--r--games-emulation/atari800/files/atari800.cfg24
-rw-r--r--games-emulation/atari800/metadata.xml29
5 files changed, 163 insertions, 0 deletions
diff --git a/games-emulation/atari800/Manifest b/games-emulation/atari800/Manifest
new file mode 100644
index 000000000000..5ebd2c1ca923
--- /dev/null
+++ b/games-emulation/atari800/Manifest
@@ -0,0 +1,6 @@
+AUX atari800-3.1.0-tgetent-detection.patch 690 BLAKE2B 49016e922f66214dadd0da179679e61f9359f93020d964f4ccd4b0b27da5ceb0fcdc0eedee6b891f8090bfe2c2d4fb23bbbc8130e660a1b84df8434101248f90 SHA512 dc045dc72b011fe2fab1b440a5fc50c3a34dcb4cd867efa9a8276cc770f21778732adf6c59e5a3daec0cd37364a83f877c739d1120d468af9372d088895850e5
+AUX atari800.cfg 467 BLAKE2B 76caa8d4f73d292adb36ce66186bf657a25f4ef5404f0dedc0456fa933bc672bc5a89819b92555d88033bc47bdff4cd5b376571de01339a1b60a82a3210dcd11 SHA512 17f43f9f1b8dcf1513eefc8b89e94ecdaeb3f4e324a669e09c1f8b180e3c545b474164f73bc4c319dde27dda8effa1f2786957854ade81d161221e081c87d358
+DIST atari800-3.1.0.tar.gz 1492289 BLAKE2B cad7a3111bf714321d01aff1f8b30408efc1eca0876d9b795395d62d18eabdf78b71d3b2af887e8ba03e33e3824fcd5b45070e39cddd0e5ad0bda2d853f724b1 SHA512 c8f035c9be000c67dd854a14a236d165e6e2d30b5138f8772c6ea5c5290b0410525570e3ed9dcb2f9bcb129f97a36e6eef5993f0a5ad3cc993c6b59b127bcabe
+DIST xf25.zip 188942 BLAKE2B c10b9108eebc571ac334ea6fca76d227e3d2fcde1595e8823a3d178dc31d9efa9b209572ee03875461289093615470192cf5c9a06cf0b4363d097a9eac201db4 SHA512 306612fc2af41ed10d76103af83e141cfd8bd3ba2ea3cbd1d0b81d4d5b0108c06948a5c626648c8a2424536757a42a3f8b9af1fb63fa3c31096447ffed0f9923
+EBUILD atari800-3.1.0-r1.ebuild 1860 BLAKE2B c286b79674f42d3a421be8e5e5c8ac02387c81ee5994fc7e9657e0732c46d1a38ee93ba240530f5072baaad88b648c28ed533114a9aa986a8b51a3f4e18ffede SHA512 ad3fc9d642d739fd8024c81db883d5b5bffa46e6e5b9967aa5dcbb1d45373eafb7cb399118e01354fbdb878b7ea49d5d76b38189d1bd643503a78ed2ed3ed0e4
+MISC metadata.xml 961 BLAKE2B 5f5e394a1ea4099f9d33f1e4f542b98ea31038e2855d839a86ea55fca18f02b9d99f2b0b554e0816142d80ca84adcbe2e1af1c664d773fb8df2794600fe21b48 SHA512 f31b0309a14446c07f11c72be8bb0cda851e5e0f424211f7a26eb5030935119a31eccfc1d81d80987cf6a6ef22d56e74edd258eba13d2635cccd584fadaaf123
diff --git a/games-emulation/atari800/atari800-3.1.0-r1.ebuild b/games-emulation/atari800/atari800-3.1.0-r1.ebuild
new file mode 100644
index 000000000000..31aa318cdebb
--- /dev/null
+++ b/games-emulation/atari800/atari800-3.1.0-r1.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop autotools
+
+DESCRIPTION="Atari 800 emulator"
+HOMEPAGE="http://atari800.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+ mirror://sourceforge/${PN}/xf25.zip"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ncurses oss opengl readline +sdl +sound"
+
+NOTSDL_DEPS="
+ sys-libs/ncurses:0=
+ sound? (
+ !oss? ( media-libs/libsdl[sound] )
+ )
+"
+RDEPEND="
+ sdl? ( >=media-libs/libsdl-1.2.0[opengl?,sound?,video] )
+ ncurses? ( ${NOTSDL_DEPS} )
+ !sdl? ( !ncurses? ( ${NOTSDL_DEPS} ) )
+ readline? (
+ sys-libs/readline:0=
+ sys-libs/ncurses:0= )
+ media-libs/libpng:0=
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+"
+
+src_prepare() {
+ default
+
+ # remove some not-so-interesting ones
+ rm -f DOC/{INSTALL.*,*.in,CHANGES.OLD} || die
+ sed -i \
+ -e '1s/ 1 / 6 /' \
+ src/atari800.man || die
+ sed "s:/usr/share/games:/usr/share:" \
+ "${FILESDIR}"/atari800.cfg > "${T}"/atari800.cfg || die
+
+ # Bug 544608
+ eapply "${FILESDIR}/${P}-tgetent-detection.patch"
+ pushd src > /dev/null && eautoreconf
+ popd > /dev/null
+}
+
+src_configure() {
+ local video="ncurses"
+ local sound=no
+
+ use sdl && video="sdl"
+ if use sound ; then
+ if use sdl ; then
+ sound=sdl
+ elif use oss ; then
+ sound=oss
+ else
+ echo
+ elog "Sound requested but neither sdl nor oss specified."
+ elog "Disabling sound suport."
+ fi
+ fi
+
+ cd src && \
+ econf \
+ $(use_with readline) \
+ --with-video=${video} \
+ --with-sound=${sound}
+}
+
+src_compile() {
+ emake -C src
+}
+
+src_install () {
+ dobin src/atari800
+ newman src/atari800.man atari800.6
+ dodoc README.1ST DOC/*
+ insinto "/usr/share/${PN}"
+ doins "${WORKDIR}/"*.ROM
+ insinto /etc
+ doins "${T}"/atari800.cfg
+ newicon data/atari2.svg ${PN}.svg
+ make_desktop_entry ${PN} "Atari 800 emulator"
+}
diff --git a/games-emulation/atari800/files/atari800-3.1.0-tgetent-detection.patch b/games-emulation/atari800/files/atari800-3.1.0-tgetent-detection.patch
new file mode 100644
index 000000000000..018e423af6b4
--- /dev/null
+++ b/games-emulation/atari800/files/atari800-3.1.0-tgetent-detection.patch
@@ -0,0 +1,12 @@
+diff -ruN atari800-3.1.0/src/configure.ac new/src/configure.ac
+--- atari800-3.1.0/src/configure.ac 2014-04-12 15:58:16.000000000 +0200
++++ new/src/configure.ac 2015-03-26 23:36:24.419178078 +0100
+@@ -982,7 +982,7 @@
+ dnl existence of the tgetent symbol in readline. If not, we search for tgetent
+ dnl in a few other libraries. All done with a single AC_SEARCH_LIBS statement.
+ have_readline=no
+- AC_SEARCH_LIBS(tgetent, [readline termcap ncursesw ncurses curses], [
++ AC_SEARCH_LIBS(tgetent, [readline termcap tinfow ncursesw ncurses curses], [
+ AC_SEARCH_LIBS(readline, readline, [
+ AC_CHECK_HEADER([readline/readline.h], [
+ have_readline=yes
diff --git a/games-emulation/atari800/files/atari800.cfg b/games-emulation/atari800/files/atari800.cfg
new file mode 100644
index 000000000000..b31c67de0958
--- /dev/null
+++ b/games-emulation/atari800/files/atari800.cfg
@@ -0,0 +1,24 @@
+Atari 800 Emulator, Version 1.2.2
+OS/A_ROM=atariosa.rom
+OS/B_ROM=/usr/share/games/atari800/ATARIOSB.ROM
+XL/XE_ROM=/usr/share/games/atari800/ATARIXL.ROM
+BASIC_ROM=/usr/share/games/atari800/ATARIBAS.ROM
+5200_ROM=
+DISK_DIR=
+ROM_DIR=
+H1_DIR=
+H2_DIR=
+H3_DIR=
+H4_DIR=
+HD_READ_ONLY=1
+EXE_DIR=
+STATE_DIR=
+PRINT_COMMAND=lpr %s
+SCREEN_REFRESH_RATIO=1
+MACHINE_TYPE=Atari OS/B
+RAM_SIZE=48
+DEFAULT_TV_MODE=NTSC
+DISABLE_BASIC=1
+ENABLE_SIO_PATCH=1
+ENABLE_H_PATCH=1
+ENABLE_P_PATCH=1
diff --git a/games-emulation/atari800/metadata.xml b/games-emulation/atari800/metadata.xml
new file mode 100644
index 000000000000..6489dd5ca137
--- /dev/null
+++ b/games-emulation/atari800/metadata.xml
@@ -0,0 +1,29 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <longdescription>
+Atari800 is an Atari 800, 800XL, 130XE and 5200 emulator for Unix, Amiga, MS-DOS, Atari
+TT/Falcon, SDL and WinCE. Our main objective is to create a freely distributable portable
+emulator (i.e. with source code available). It can be configured to run in the following
+ways :
+
+ * BASIC mode
+ * CURSES mode
+ * SVGALIB for Linux Systems
+ * X Window + Optional XVIEW or MOTIF User Interface
+ * CBM Amiga
+ * MS-DOS
+ * TOS (Atari Falcon030/TT030 and compatible)
+ * MS Windows (DirectX)
+ * SDL (many different platforms and systems)
+ * WinCE
+ * MacOS X
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">atari800</remote-id>
+ </upstream>
+</pkgmetadata>