summaryrefslogtreecommitdiff
path: root/games-board
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
commitc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (patch)
treec44943ee0563a3fa957716de909fed683117fcb9 /games-board
parent69051588e2f955485fe5d45d45e616bc60a2de57 (diff)
gentoo (valentine's day) resync : 14.02.2021
Diffstat (limited to 'games-board')
-rw-r--r--games-board/Manifest.gzbin10535 -> 10535 bytes
-rw-r--r--games-board/gmchess/Manifest3
-rw-r--r--games-board/gmchess/files/gmchess-0.29.6_fix_build_segfault.patch102
-rw-r--r--games-board/gmchess/gmchess-0.29.6-r3.ebuild (renamed from games-board/gmchess/gmchess-0.29.6-r2.ebuild)28
4 files changed, 113 insertions, 20 deletions
diff --git a/games-board/Manifest.gz b/games-board/Manifest.gz
index a93d10dbd109..89ff266f7231 100644
--- a/games-board/Manifest.gz
+++ b/games-board/Manifest.gz
Binary files differ
diff --git a/games-board/gmchess/Manifest b/games-board/gmchess/Manifest
index bd195bff786b..c3351cd6637e 100644
--- a/games-board/gmchess/Manifest
+++ b/games-board/gmchess/Manifest
@@ -1,4 +1,5 @@
AUX gmchess-0.29.6-gentoo-r1.patch 871 BLAKE2B eb99dc2a6b5199c104a608990e5da84ebeb4b04df560a365f9c884e2a7f788d0daac6063680ce1b87b833f2bb3fd0c4592b2507ab4b825e6676a106348f2ed59 SHA512 b7466bcc8b734a7449f99ec0b9fcc16d0820628866945710b681dc5c97b5ba37f359e938aeec76fbe411061c88a706b552a9df48d7e7115a84ddfc05143d7e4c
+AUX gmchess-0.29.6_fix_build_segfault.patch 2790 BLAKE2B b69941ed89ea95eadffcf6080ccb93893034c6ade6b26e6d71619c466e4d599e8b303e61faf3ff7da87e01bc5d64566aafbf8aaab02797a280007b151793bb2f SHA512 5f022dd5ed2d2a6058733c217e0d7d12339b95d2d27df8da814bf4b1484186908819c055a50de0e2dc74e83d73f95e1e1128e626d7db01d599d5c528a7adcd12
DIST gmchess-0.29.6.tar.bz2 1437904 BLAKE2B fdc98a317e62a455c394f3486c61abb49ad76bc2a77fae6f3a71271a56e8fc95e58dbf6cd387401a172bafc19379ca1ee971b6ce3911d0aa6b9d97b400a62d28 SHA512 b6af5205dc087c9fdea4cee81f9002c5dd56282be10b09c99f6f4105730676abff8d036843b7c0232937f43d87d222555a0b9c86e192a5ac8c039509841467a6
-EBUILD gmchess-0.29.6-r2.ebuild 1013 BLAKE2B c65ea797d422c3f32c85e5b3f813c34411bcf3b0cf4879d207c145347e22bd6273855334c1efef37f49642543640b2764d949ac215da7ad163d902165139c574 SHA512 7821ab51111a1dad74beb4e47329361867faa074095a58eea061deba213d2daef54b56f3f62dd193e7a6d8ec39ac22387d734884c608ec3bf0df338414d7e93b
+EBUILD gmchess-0.29.6-r3.ebuild 979 BLAKE2B 6f4f277acec3de520e4c96053de0a5f480b540d5cd2722827732469fcb7250b30d69962b6e1fc86e0c111ccc59e12f22de2efff5e340773499d0d7a90f3c8c51 SHA512 5d306dd6ee862917de16696c1569f0974df4b1c487cbd5e0c8e9b9576bc9501f1061feca635a42250ecf13c620f70f72d964c9cbdb21aea1abc219547fc8eb2a
MISC metadata.xml 330 BLAKE2B 04e8696c37299e01d7554cc6f370b25facaeb67a994f97d0829fe77bc15fda99af19e56d304a8424bcdd4791f5512da0d06b3ae4da2400a6b5ae457dbec65bb7 SHA512 172b4a1ec7cb67f32ab991337ecc058be002d35f8867819b54d28d65ba1ade6217318460f7560c96a03357d262d76bc7e6eaf810be78e32b3a0290037ddbaaa2
diff --git a/games-board/gmchess/files/gmchess-0.29.6_fix_build_segfault.patch b/games-board/gmchess/files/gmchess-0.29.6_fix_build_segfault.patch
new file mode 100644
index 000000000000..04b06551ace7
--- /dev/null
+++ b/games-board/gmchess/files/gmchess-0.29.6_fix_build_segfault.patch
@@ -0,0 +1,102 @@
+diff --git a/src/Board.cc b/src/Board.cc
+index 4395a5c..11c4f31 100644
+--- gmchess-0.29.6-r3/src/Board.cc
++++ gmchess-0.29.6-r3/src/Board.cc
+@@ -297,12 +297,13 @@ void Board::on_map()
+
+ bool Board::on_configure_event(GdkEventConfigure* ev)
+ {
+- //if(ui_pixmap)
+- // return true;
+ ui_pixmap = Gdk::Pixmap::create(this->get_window(),get_width(),get_height());
+
+- redraw();
+-
++ if(ui_pixmap) {
++ redraw();
++ return true;
++ }
++ return false;
+ }
+ bool Board::on_expose_event(GdkEventExpose* ev)
+ {
+@@ -1146,7 +1147,7 @@ bool Board::robot_log(const Glib::IOCondition& condition)
+
+ if (buf_len > 0) {
+ *p = 0;
+- printf(buf);
++ printf("%s",buf);
+ std::string str_buf(buf);
+ parent.show_textview_engine_log(str_buf);
+
+diff --git a/src/ConfWindow.cc b/src/ConfWindow.cc
+index 1ff03c8..4aa61f2 100644
+--- gmchess-0.29.6-r3/src/ConfWindow.cc
++++ gmchess-0.29.6-r3/src/ConfWindow.cc
+@@ -117,7 +117,7 @@ void ConfWindow::on_button_color_set()
+ bool ConfWindow::on_delete_event(GdkEventAny*)
+ {
+ on_button_cancel();
+-
++ return(true);
+ }
+ void ConfWindow::write_to_GMConf()
+ {
+diff --git a/src/Engine.cc b/src/Engine.cc
+index d316c0e..050b01c 100644
+--- gmchess-0.29.6-r3/src/Engine.cc
++++ gmchess-0.29.6-r3/src/Engine.cc
+@@ -509,7 +509,7 @@ bool Engine::mate()
+ case RED_KNIGHT:
+ case BLACK_KNIGHT:
+ for(int k=0;k<8;k++){
+- dst=src+ KingMoveTab[k];
++ dst=src+ KnightMoveTab[k];
+ if(in_board(dst)){
+ int mv = get_move(src,dst);
+ if(make_move(mv)){
+@@ -2098,7 +2098,7 @@ uint32_t Engine::hanzi_to_iccs(uint32_t f_hanzi)
+ n++;
+ }
+ }
+- DLOG(" n=%d\n");
++ DLOG(" n=%d\n", n);
+ /** 为纵线上的棋子排序*/
+ for(int k=start;k<n-1;k++)
+ for(int j=n-2;j>=k;j--){
+diff --git a/src/MainWindow.cc b/src/MainWindow.cc
+index 528680e..cbd5ff1 100644
+--- gmchess-0.29.6-r3/src/MainWindow.cc
++++ gmchess-0.29.6-r3/src/MainWindow.cc
+@@ -1176,6 +1176,7 @@ bool MainWindow::on_end_game(OVERSTATUS _over)
+ auto_save_chess_file();
+ board->free_game(false);
+ set_status();
++ return(true);
+ }
+
+ void MainWindow::set_red_war_time(const Glib::ustring& f_time,const Glib::ustring& c_time)
+diff --git a/src/Sound.cc b/src/Sound.cc
+index 517d126..5efd736 100644
+--- gmchess-0.29.6-r3/src/Sound.cc
++++ gmchess-0.29.6-r3/src/Sound.cc
+@@ -78,7 +78,7 @@ void CSound::play_file(const char* filename)
+ {
+ gchar* argv[3];
+ #ifdef __linux__
+- argv[0] = "aplay";
++ argv[0] = (gchar *)"aplay";
+ #elif __APPLE__
+ argv[0] = "afplay";
+ #endif
+--- gmchess-0.29.6/src/engine/cchess.cpp
++++ gmchess-0.29.6/src/engine/cchess.cpp
+@@ -690,7 +690,7 @@
+ }
+ lpSrc ++;
+ };
+- while(lpSrc != '\0' && lpDst < lpDstLimit) {
++ while(lpSrc != NULL && lpDst < lpDstLimit) {
+ *lpDst = *lpSrc;
+ lpSrc ++;
+ lpDst ++;
diff --git a/games-board/gmchess/gmchess-0.29.6-r2.ebuild b/games-board/gmchess/gmchess-0.29.6-r3.ebuild
index e46a6f84334a..fbd0e59250a6 100644
--- a/games-board/gmchess/gmchess-0.29.6-r2.ebuild
+++ b/games-board/gmchess/gmchess-0.29.6-r3.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit autotools flag-o-matic libtool gnome2-utils ltprune
+EAPI=7
+inherit autotools flag-o-matic xdg
DESCRIPTION="Chinese chess with gtkmm and c++"
HOMEPAGE="https://github.com/lerosua/gmchess"
@@ -16,9 +16,11 @@ IUSE=""
DEPEND="dev-cpp/gtkmm:2.4"
RDEPEND=${DEPEND}
+BDEPEND="virtual/pkgconfig"
PATCHES=(
"${FILESDIR}"/${P}-gentoo-r1.patch
+ "${FILESDIR}"/${P}_fix_build_segfault.patch
)
src_prepare() {
@@ -36,22 +38,10 @@ src_configure() {
src_install() {
emake DESTDIR="${D}" \
- itlocaledir='/usr/share/locale' \
- pixmapsdir='/usr/share/pixmaps' \
- desktopdir='/usr/share/applications' \
+ localedir="${EPREFIX}"/usr/share/locale \
+ pixmapsdir="${EPREFIX}"/usr/share/pixmaps \
+ desktopdir="${EPREFIX}"/usr/share/applications \
install
dodoc AUTHORS NEWS README
- prune_libtool_files
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
+ find "${ED}" -name "*.la" -delete || die
}