summaryrefslogtreecommitdiff
path: root/games-board
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-04 20:01:09 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-04 20:01:09 +0000
commit3daf38ec350b4e25244c69eea165b18afd090459 (patch)
tree5489bd5abdccd746fe68e98b9164e887bfbcfde4 /games-board
parent84bfe2244c544bae8dcaffbaf4cfb80f59f88f64 (diff)
gentoo auto-resync : 04:01:2024 - 20:01:09
Diffstat (limited to 'games-board')
-rw-r--r--games-board/Manifest.gzbin10032 -> 10031 bytes
-rw-r--r--games-board/stockfish/Manifest1
-rw-r--r--games-board/stockfish/stockfish-16-r1.ebuild83
3 files changed, 84 insertions, 0 deletions
diff --git a/games-board/Manifest.gz b/games-board/Manifest.gz
index 58be4026d51b..7c7be34f60a0 100644
--- a/games-board/Manifest.gz
+++ b/games-board/Manifest.gz
Binary files differ
diff --git a/games-board/stockfish/Manifest b/games-board/stockfish/Manifest
index 87047e62b6bd..0b2ff26c9f37 100644
--- a/games-board/stockfish/Manifest
+++ b/games-board/stockfish/Manifest
@@ -17,5 +17,6 @@ EBUILD stockfish-14.1.ebuild 2057 BLAKE2B b8d62d5b1ee91c8b1e5b5527066daf379f2f55
EBUILD stockfish-14.ebuild 2057 BLAKE2B fa29e939556a7160ee5e7627e88cb1ddbca77ab05fa8d8da6d018a36a3a1e5521a893d2a345f6780ecee978cfe66b29ae7500a0c87b7f31daf7f70b867ffbe2b SHA512 4e5b45721ca9e38708d512195592e9e913822803e13684628280396ab2351e2d073253a30e4e87276aaa0a32b7dd3219508de0c327788a58e32be530f4b06aa5
EBUILD stockfish-15-r1.ebuild 2061 BLAKE2B c325b860195d42d491739aca6388544cb70422aa8c2697752dcc68e2d4881c8f156f71676498d815f60b6261d85e0ae1d57d22b27d7dcf0d429d3958f5f02faf SHA512 d76c57acc76b3284250743d9f499dc5298b2c0d45a557e77d197007c92b0ba0b4ee2ebeb70a03e3b523afbb03c39cc051ab69c7f3d0779dc452c2b4a6b398194
EBUILD stockfish-15.1.ebuild 2056 BLAKE2B cdb0cda0addb04458862ce3d703910bf682717e29be7bc44a3f6caeaebc4b901742d055f85da56978d064548d45fed61d78124dab54409061a2a9b9819d0ea9d SHA512 7b638b6a9993657311531048d7e83f3994a9733e2233da479ef4511212f17a72e40d7e2c1e50fb4a9d934a79652b2a9e37c62bee4cb9e11f64510aa3ae4ce189
+EBUILD stockfish-16-r1.ebuild 2410 BLAKE2B a9a9d85a56c3791a8e28c57d48dfd8234789c76ba03e7462a53b4dd731b2ae77639df86008b95a42e8961482146c0a45e50acac48b4623aed3997bc2892541f6 SHA512 75d8c17f91cf23bdcf4fc8ef75a1cf70f64432f36dfe8616b0728b0138e92c2201913f7e8fa2e1bce2b687ee364b75bb76ca50d97744a0d1917a114776ac0bdd
EBUILD stockfish-16.ebuild 2153 BLAKE2B c339d21349fe00bf041341eb782a5dcac012ecd4545322ccbc17d09e815e44b309719af2c52a88dc0dfe9a0307aef4db28c1be7989adf37ec0d14b0d7609e868 SHA512 2b47ba885226469c7d1a7bfa410e61f3412942c374d6bee75b85c12115a27b67e63bd33aae9ccdddb316d167173cf80716e8481f70d9804d9122e6dbef2efc25
MISC metadata.xml 480 BLAKE2B 4ad3d2104e203f37003ce529235acd6043a8f1141870699340b7739e946f758409b6587bcabe0052fcbdb0afb872ec5e6e89d982dd18cea0c76efc8a4f323c15 SHA512 dff895e7ad3f5006cf82694914bedaaa144ced87c3b338982bce3b727bf8fa8107622aaa0edf6c0960c00137c3f78e788d5df3df5782f776b7644386280c5df1
diff --git a/games-board/stockfish/stockfish-16-r1.ebuild b/games-board/stockfish/stockfish-16-r1.ebuild
new file mode 100644
index 000000000000..a6734bf75de8
--- /dev/null
+++ b/games-board/stockfish/stockfish-16-r1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Free UCI chess engine, claimed to be the strongest in the world"
+HOMEPAGE="https://stockfishchess.org/"
+
+NNUE_FILE="nn-5af11540bbfe.nnue"
+
+SRC_URI="https://github.com/official-stockfish/Stockfish/archive/sf_${PV}.tar.gz -> ${P}.tar.gz
+ https://tests.stockfishchess.org/api/nn/${NNUE_FILE} -> ${P}-${NNUE_FILE}"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~loong ~riscv ~x86"
+IUSE="cpu_flags_arm_v7 cpu_flags_x86_avx2 cpu_flags_x86_popcnt cpu_flags_x86_sse cpu_flags_x86_avx512f
+ cpu_flags_x86_avx512dq debug general-32 general-64 +optimize"
+
+DEPEND="|| ( app-arch/unzip app-arch/zip )"
+RDEPEND=""
+
+S="${WORKDIR}/Stockfish-sf_${PV}/src"
+
+src_prepare() {
+ default
+
+ # remove config sanity check that doesn't like our COMPILER settings
+ sed -i -e 's/ config-sanity//g' Makefile || die
+
+ cp "${DISTDIR}"/${P}-${NNUE_FILE} ${NNUE_FILE} || die "copying the nnue file failed"
+
+ # prevent pre-stripping
+ sed -e 's:-strip $(BINDIR)/$(EXE)::' -i Makefile \
+ || die 'failed to disable stripping in the Makefile'
+
+ # Makefile is a bit optimistic
+ sed -e 's:-flto=full:-flto:g' -i Makefile || die
+}
+
+src_compile() {
+ local my_arch
+
+ # generic unoptimized first
+ use general-32 && my_arch=general-32
+ use general-64 && my_arch=general-64
+
+ # x86
+ use x86 && my_arch=x86-32-old
+ use cpu_flags_x86_sse && my_arch=x86-32
+
+ # amd64
+ use amd64 && my_arch=x86-64
+ use cpu_flags_x86_popcnt && my_arch=x86-64-modern
+
+ # both bmi2 and avx2 are part of hni (haswell new instructions)
+ use cpu_flags_x86_avx2 && my_arch=x86-64-bmi2
+
+ # avx512
+ # we currently can't express 'avx512vnni' 'avx512dq' 'avx512f' 'avx512bw' 'avx512vl'
+ # so only enable basic support
+ use cpu_flags_x86_avx512f && use cpu_flags_x86_avx512dq && my_arch=x86-64-avx512
+
+ # other architectures
+ use cpu_flags_arm_v7 && my_arch=armv7
+ use ppc && my_arch=ppc
+ use ppc64 && my_arch=ppc64
+
+ # There's a nice hack in the Makefile that overrides the value of CXX with
+ # COMPILER to support Travis CI and we abuse it to make sure that we
+ # build with our compiler of choice.
+ emake profile-build ARCH="${my_arch}" \
+ COMP="$(tc-getCXX)" \
+ COMPILER="$(tc-getCXX)" \
+ debug=$(usex debug "yes" "no") \
+ optimize=$(usex optimize "yes" "no")
+}
+
+src_install() {
+ dobin "${PN}"
+ dodoc ../AUTHORS ../README.md
+}