summaryrefslogtreecommitdiff
path: root/games-board/xskat/xskat-4.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-11 07:37:54 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-11 07:37:54 +0100
commit81db58116c7a9c27f54243a4d8f364c7e94c6f36 (patch)
treeeb568d2a6d5b95a55b7f5a5ec305e1e6f5566e93 /games-board/xskat/xskat-4.0-r2.ebuild
parent179be85ade6b2b47bf362865b5c375969ab5ddc8 (diff)
gentoo auto-resync : 11:10:2022 - 07:37:54
Diffstat (limited to 'games-board/xskat/xskat-4.0-r2.ebuild')
-rw-r--r--games-board/xskat/xskat-4.0-r2.ebuild21
1 files changed, 14 insertions, 7 deletions
diff --git a/games-board/xskat/xskat-4.0-r2.ebuild b/games-board/xskat/xskat-4.0-r2.ebuild
index da925919f0cc..34b32c4049b9 100644
--- a/games-board/xskat/xskat-4.0-r2.ebuild
+++ b/games-board/xskat/xskat-4.0-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit desktop toolchain-funcs
+inherit desktop flag-o-matic toolchain-funcs
DESCRIPTION="Famous german card game"
HOMEPAGE="http://www.xskat.de/xskat.html"
@@ -15,21 +15,28 @@ LICENSE="freedist"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
-DEPEND="x11-libs/libX11"
+COMMON_DEPEND="x11-libs/libX11"
RDEPEND="
- ${DEPEND}
+ ${COMMON_DEPEND}
media-fonts/font-misc-misc"
-BDEPEND="
- virtual/pkgconfig
+DEPEND="
+ ${COMMON_DEPEND}
x11-base/xorg-proto"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-clang16.patch
+)
src_configure() { :; }
src_compile() {
tc-export CC
+ append-cflags -std=gnu89 # old codebase, will break with c2x
local emakeargs=(
- CFLAGS="${CFLAGS} ${CPPFLAGS}"
+ CFLAGS="${CFLAGS} ${CPPFLAGS} $($(tc-getPKG_CONFIG) --cflags x11 || die)"
+ CPPFLAGS= # force everywhere above, but avoid implicit duplication
LDFLAGS="${LDFLAGS} $($(tc-getPKG_CONFIG) --libs x11 || die)"
)