summaryrefslogtreecommitdiff
path: root/games-board/simsu
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-board/simsu
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-board/simsu')
-rw-r--r--games-board/simsu/Manifest3
-rw-r--r--games-board/simsu/metadata.xml8
-rw-r--r--games-board/simsu/simsu-1.3.6.ebuild45
3 files changed, 56 insertions, 0 deletions
diff --git a/games-board/simsu/Manifest b/games-board/simsu/Manifest
new file mode 100644
index 000000000000..013b363497db
--- /dev/null
+++ b/games-board/simsu/Manifest
@@ -0,0 +1,3 @@
+DIST simsu-1.3.6-src.tar.bz2 597982 BLAKE2B acf13fe4e3e228cecc76a16352a4df06f14cf58307008f5679b63f1209b4cf191b28544ed3b002375afdf0de8cd92ce179f3cb367f9a5201099da99a806d60c5 SHA512 04e60ccab8345002078b7dbd253bc2a9701f9b8edbbdd9a01ac3ddffd9a5f3ccd32399216b9e497b309b6718646db11a55717e5bd201bfd2aaa80ad9b171cb94
+EBUILD simsu-1.3.6.ebuild 764 BLAKE2B 4564efd4a6d6519ec1875b03ca96c55c59d47fc28319318fdbbf94e587821c70eabbf2ee5f147c3259ed9fff3c103671ed562ecfc0893da6d5a417827594426b SHA512 f6881a3c818fe9507a71d7c23c2329bd725bb75630eb8d8e8d02115f09b2758c28e2886e6cf1be809c8c0408260892f03664585753cea486d1092ba2d68c783c
+MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-board/simsu/metadata.xml b/games-board/simsu/metadata.xml
new file mode 100644
index 000000000000..78274e0fa550
--- /dev/null
+++ b/games-board/simsu/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/games-board/simsu/simsu-1.3.6.ebuild b/games-board/simsu/simsu-1.3.6.ebuild
new file mode 100644
index 000000000000..75b793631b42
--- /dev/null
+++ b/games-board/simsu/simsu-1.3.6.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils qmake-utils
+
+DESCRIPTION="A basic sudoku game"
+HOMEPAGE="https://gottcode.org/simsu/"
+SRC_URI="https://gottcode.org/${PN}/${P}-src.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+"
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ dobin ${PN}
+ insinto /usr/share/${PN}/translations
+ doins translations/*qm
+ dodoc ChangeLog
+ doicon -s scalable icons/hicolor/scalable/apps/${PN}.svg
+ domenu icons/${PN}.desktop
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}