summaryrefslogtreecommitdiff
path: root/games-board/pychess
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-04 23:23:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-04 23:23:41 +0100
commit3b4ca161c9d7f5a66a93191da2c9ec02dbdde1b7 (patch)
tree05ee189fbf7a80ad6a8a565742051527322cbbdd /games-board/pychess
parent0f3400581b3370a12b1581c6394b74327181f3e8 (diff)
gentoo auto-resync : 04:04:2023 - 23:23:40
Diffstat (limited to 'games-board/pychess')
-rw-r--r--games-board/pychess/Manifest2
-rw-r--r--games-board/pychess/pychess-1.0.4.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/games-board/pychess/Manifest b/games-board/pychess/Manifest
index 88c275961734..911aa23a5fc2 100644
--- a/games-board/pychess/Manifest
+++ b/games-board/pychess/Manifest
@@ -1,6 +1,8 @@
AUX pychess-1.0.3-setuptools-warning.patch 221 BLAKE2B 791a195548b3b4f49368f85045c8c604754bf6eb9b00cc672d32afdc45dcfefe9557b4d945ec50ee28e68875ad3aefc889870cf6b447d79850e63294b0a72814 SHA512 ecc7aa1427d5a17792aa468676263c05adbb85b28b2b4a08228b0ade72a5722b30899bcc591833c9d43391cde04ddb2e6b0c0358876f56803802175e24016cbd
DIST pychess-1.0.3.tar.gz 14898032 BLAKE2B 0993bcf26d3284847815b37f570b7482c5359595f9649f9546ed090b6c090c3686d71478c9ecdaacde4bdf56f8f57da89623023d25809b46fe4e2800beeba91d SHA512 ca69555b1d952274fc4850f20bc66569e2f08120109908489c584231c754345b16fc1b1e9fa5b44a10582590145cf472604e5f5bd22522037666414418f5fda5
+DIST pychess-1.0.4.tar.gz 14553786 BLAKE2B 25855090d8d24f75ac519cc3f28f97c82229a72ca1e9c96bdb129271e487ff84b32fd644c953628c917bb2a1f5c71d3feaa18e10883cb207441ecf3c5119c64e SHA512 668fef78352f6aab9dabb3c061403dd7cad4db9b699d4f562820f0ae6732c337ba2aab789ad70c7e01eb3bd6f2602291afd43ddc25826f5f132b4e78b3dba4b4
DIST pychess-1.0.4a1.tar.gz 14553856 BLAKE2B d9d6d77993f4bb65330b9e07a043054261970a829bf278e9644f60876de243a6dfdbbe83dba065272bd26f0bbb046120db8498d77fb2a388b46c19cd03ef87d1 SHA512 240989ae118a5b267b0d71c8dfeea14a38c342801a33e20ebef6659d90f221c6b6debbcee2c4ebf726ad4e69b48991ed1d3eab78b78f4f0a3785e213de7e8318
EBUILD pychess-1.0.3-r3.ebuild 1316 BLAKE2B 75a4d6bbde9c7b3ca8d6bd10e032b0f1a07bd1992b5c06a6c1672a17ecb1292bdc1fc9ad63db67870b6373108046bb8bb6fcfa1972c3c01c6ed6de555270f52a SHA512 4c3bd19eab8981d6ae518dc41f2aab6094bce989b103dafe0ffbce1685a3a1eae2156345ad066485390a81337f6712918ea3fd2819ddcba5a1d101ce8d50c7af
+EBUILD pychess-1.0.4.ebuild 1223 BLAKE2B 7afd8f9e9b109c090e521ff0da5c81c779ba0a3c19f19ba467196c07e8e1ed617933e951bf94d06ccdfb1c5bc061c917bbccb93bc6929f57340146866bd138a1 SHA512 a1f8bc914fbe224c673c8a95c7989d9349fe872adfd7050f6acf301da6ad65471edf5d105534858a1fcddffbd60b89bc9c88ba86938c2a759f82fb9a696d4a40
EBUILD pychess-1.0.4_alpha1.ebuild 1297 BLAKE2B 88a3c8e5f6304181e1a9d635fb653296efff807f08f0cc353c0924325b0fbc53302d9830294f43cd199c798a3189d852c5329a54083e5e061b29797c5c884159 SHA512 1144ae7601eac645c9aa84c5abbe9107d505afd0034d289649eca34ef63eca4dc445813b3bda7b0d5955917c53afc108741638688de832f3388127be3c48fcdb
MISC metadata.xml 334 BLAKE2B bbee149d1aa743ca9b8d6cdafcf46996c100563fbcd60f994b4b26ea428123966465468d5c834baba5d8346efae67d8f0d78fe8d63a28dd12dcb91a3ed040f0b SHA512 f168de876d77b7b029f708199aefeba0be4da48c2fb08e672ec7ba7ba580c4d9958aa08c3d7548c49dea76d77d3255bb476aea463319963a549f5346c8fda63c
diff --git a/games-board/pychess/pychess-1.0.4.ebuild b/games-board/pychess/pychess-1.0.4.ebuild
new file mode 100644
index 000000000000..05ae518edf13
--- /dev/null
+++ b/games-board/pychess/pychess-1.0.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="sqlite"
+inherit distutils-r1 xdg
+
+DESCRIPTION="GTK chess client"
+HOMEPAGE="https://pychess.github.io/"
+SRC_URI="https://github.com/pychess/pychess/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gstreamer"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP},cairo]
+ >=dev-python/sqlalchemy-2[${PYTHON_USEDEP},sqlite]
+ dev-python/websockets[${PYTHON_USEDEP}]
+ gstreamer? ( dev-python/gst-python:1.0[${PYTHON_USEDEP}] )')
+ gnome-base/librsvg:2[introspection]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/gtksourceview:3.0[introspection]
+ x11-libs/pango[introspection]
+ x11-themes/adwaita-icon-theme"
+BDEPEND="${RDEPEND}" # setup.py fails if introspection deps not found
+
+src_install() {
+ distutils-r1_src_install
+
+ # https://github.com/pychess/pychess/pull/1825
+ gunzip -v "${ED}"/usr/share/man/man1/${PN}.1.gz || die
+}