summaryrefslogtreecommitdiff
path: root/games-board/polyglot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /games-board/polyglot
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'games-board/polyglot')
-rw-r--r--games-board/polyglot/Manifest3
-rw-r--r--games-board/polyglot/files/polyglot-1.4.70b-musl.patch30
-rw-r--r--games-board/polyglot/polyglot-1.4.70b-r3.ebuild5
3 files changed, 36 insertions, 2 deletions
diff --git a/games-board/polyglot/Manifest b/games-board/polyglot/Manifest
index b721c8009eb4..541e94e6fd2e 100644
--- a/games-board/polyglot/Manifest
+++ b/games-board/polyglot/Manifest
@@ -1,4 +1,5 @@
+AUX polyglot-1.4.70b-musl.patch 733 BLAKE2B 784fcc233b4e13e5bee9e6efd083a227c65b88e8e58ff8b1260a9229d085b414c35bbd86a1273a6ace219b8513c131b6c3b43f34d157c79e09a984fe04ce3052 SHA512 4330b5b82a0881a0a43ef54d77fbaf204aca4a00f7166a8d42cf20837d5ebe68d541d3a808d1d85a8b160e3ca85e4652762dda790c2b66f2d24fb8b9ff7ca350
AUX polyglot-1.4.70b-no-common.patch 325 BLAKE2B 162f0205e5c1590a1c009e6f0f4a8cc91a590580b1816640c063f50bb0cb5bf261d327561c3d92bf8a4dffe582454d470a877aef921685ce87f5094fe694f2d3 SHA512 126d824d206288a9cbbd2fa0a83083f064db7ab652e880e9a6c4f2109d46ffaf9bfede2bc0fc7ecbe183ce14d67bde66054dc2d363d01d6d2e7ad4214838d5a0
DIST polyglot-1.4.70b.tar.gz 269938 BLAKE2B bcefdb1157ca70438e60e77b0f3242527fd2b2cf0616727f3d09c30d6d7713f2c38482041fa0a0002cd7a730429915c913a2d282cdbb4f3b6556a202d3382e5d SHA512 23ffa735b44ebbdaa991d96ac7d09e368f99640265bea3a30e0623665a8a9567f7c5c3e9518e06348a9b34ef70b43de2000b85f4e6101f4d8f866ae9cac9abec
-EBUILD polyglot-1.4.70b-r3.ebuild 514 BLAKE2B 3a30a6ebb0ab1dab30681cd43b39a20860a98b02d80d5f19ee4b9d2c202c921e6d22ac0cf8a0d215ef1711010af303a31051d581c735cfb1fe653a65470738a9 SHA512 1174bb2191016724a763e8f320bde494102dc3d5ee299dbb0b046cd2741cef11b65d8b7949349dc820cb16cc4db3021580428fea1e5b41510e278ee34fc684b0
+EBUILD polyglot-1.4.70b-r3.ebuild 546 BLAKE2B 3062646c9b4cd6bf869ba5e0242944c02d21568aeef6caf8950e790f8125a433b40b4094321eb0aba1a688ce90df2bfe97cf5e463bef45ffb2f97087c04304bc SHA512 b4bc1df71de6f253299b576f0e852686febac233e885bde23fb4085a45b80ca5569b0cd9b4ecce217321afcffe97d9b334be0ce33d4dda7d1f39b4eb794d3f90
MISC metadata.xml 488 BLAKE2B d49d8efb7834bce6cf6c49bea636306cc67ea1bb2f72625c5e3af945a59406bd7b782c217683c7abdd36b215cf586f44b43eba600ef157ce716f7d3310651918 SHA512 73200bcc5b340c191d80b87f3b44af5339b259ebe2e7c5668a5066a6e07cdf87d4e15db0361f7b5f65f5032216625fd1591c548c506576ac56174d9dffc94002
diff --git a/games-board/polyglot/files/polyglot-1.4.70b-musl.patch b/games-board/polyglot/files/polyglot-1.4.70b-musl.patch
new file mode 100644
index 000000000000..5ccbdea4a43d
--- /dev/null
+++ b/games-board/polyglot/files/polyglot-1.4.70b-musl.patch
@@ -0,0 +1,30 @@
+Rename uint64_t to uint64 (same as in util.h) to avoid a name collision.
+https://bugs.gentoo.org/715560
+
+--- polyglot-1.4.70b-orig/pgheader.c
++++ polyglot-1.4.70b/pgheader.c
+@@ -49,12 +49,12 @@
+ #endif
+
+ #ifdef _MSC_VER
+- typedef unsigned __int64 uint64_t;
++ typedef unsigned __int64 uint64;
+ #else
+- typedef unsigned long long int uint64_t;
++ typedef unsigned long long int uint64;
+ #endif
+
+-static int int_from_file(FILE *f, int l, uint64_t *r){
++static int int_from_file(FILE *f, int l, uint64 *r){
+ int i,c;
+ for(i=0;i<l;i++){
+ c=fgetc(f);
+@@ -69,7 +69,7 @@
+
+ int pgheader_detect(const char *infile){
+ FILE *fin;
+- uint64_t r0,r1,r2;
++ uint64 r0,r1,r2;
+ int i;
+
+ fin=fopen(infile,"rb");
diff --git a/games-board/polyglot/polyglot-1.4.70b-r3.ebuild b/games-board/polyglot/polyglot-1.4.70b-r3.ebuild
index 23043395c452..a69460e036c7 100644
--- a/games-board/polyglot/polyglot-1.4.70b-r3.ebuild
+++ b/games-board/polyglot/polyglot-1.4.70b-r3.ebuild
@@ -12,5 +12,8 @@ LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-PATCHES=( "${FILESDIR}"/${P}-no-common.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-no-common.patch
+ "${FILESDIR}"/${P}-musl.patch
+)
DOCS="AUTHORS ChangeLog TODO" # README* installed by build system