summaryrefslogtreecommitdiff
path: root/games-board/pioneers/pioneers-15.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-board/pioneers/pioneers-15.3-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'games-board/pioneers/pioneers-15.3-r1.ebuild')
-rw-r--r--games-board/pioneers/pioneers-15.3-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/games-board/pioneers/pioneers-15.3-r1.ebuild b/games-board/pioneers/pioneers-15.3-r1.ebuild
new file mode 100644
index 000000000000..da4fa55fbc93
--- /dev/null
+++ b/games-board/pioneers/pioneers-15.3-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="A clone of the popular board game The Settlers of Catan"
+HOMEPAGE="http://pio.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pio/${P}.tar.gz"
+
+LICENSE="GPL-2 CC-BY-SA-4.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dedicated help nls"
+
+# dev-util/gob only for autoreconf
+RDEPEND=">=dev-libs/glib-2.26:2
+ !dedicated? (
+ >=x11-libs/gtk+-3.4:3
+ >=x11-libs/libnotify-0.7.4
+ help? (
+ app-text/rarian
+ >=gnome-base/libgnome-2.10
+ )
+ )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ dev-util/gob:2
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable nls) \
+ $(use_enable help) \
+ --includedir=/usr/include \
+ $(use_with !dedicated gtk)
+}
+
+src_install() {
+ DOCS='AUTHORS ChangeLog README TODO NEWS' \
+ gnome2_src_install scrollkeeper_localstate_dir="${ED%/}"/var/lib/scrollkeeper/
+}