summaryrefslogtreecommitdiff
path: root/games-board/phalanx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-board/phalanx
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-board/phalanx')
-rw-r--r--games-board/phalanx/Manifest3
-rw-r--r--games-board/phalanx/metadata.xml16
-rw-r--r--games-board/phalanx/phalanx-22-r1.ebuild41
3 files changed, 60 insertions, 0 deletions
diff --git a/games-board/phalanx/Manifest b/games-board/phalanx/Manifest
new file mode 100644
index 000000000000..db404c0c6458
--- /dev/null
+++ b/games-board/phalanx/Manifest
@@ -0,0 +1,3 @@
+DIST Phalanx-XXII.tar.gz 356831 BLAKE2B 11eacd51a77df0a0b25315145a3519e0ae34f97b1498b691167978700fe038770db24e0ce3dec4141a4f5f4c38ab38bf90b338a1320a09191f1757b895ce7307 SHA512 e959556bb29eb2178dbf77c656d6c6520a8568e93e03350c5141bee8808a04d0a0c1050a3db53b1fef4a7b6e6b724272700e52feb6c5d7f8308cebca91c51d67
+EBUILD phalanx-22-r1.ebuild 930 BLAKE2B edd80d4bcd0c850e67ed5c378d290c256c2acd320652a0becda1cc3cb188f3f0cd44f5a0cc68342e6e050144ac839d06f88a9f35b85891839fb63b78db39270b SHA512 e335f8cbf3d84867d7062d35ab2905d8da9df656fcffadb239abccb5e032c9a1b3d305d1be77f8ead81d584384c44a44cd30e5b751a2422b8121dd9cf3c1df5a
+MISC metadata.xml 590 BLAKE2B cc0d80f3eb03f6aab26996d3773c68b2f64328b1d9b8d4798fc4168d924c87d87f196d2dea76484cadcbd3d0d45ca4da9a34407cf57d59f9ce314203f2fcfee0 SHA512 48daed32c34b1183e44136d4da6572da67508c2782e6a28aebbf6d6d52b94eb2cf8c6dd079d8eab61a4180d82e1894271eb56e32d73f6bc302c2aa3050949fd6
diff --git a/games-board/phalanx/metadata.xml b/games-board/phalanx/metadata.xml
new file mode 100644
index 000000000000..525b2313bb60
--- /dev/null
+++ b/games-board/phalanx/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <longdescription lang="en">
+This is the Phalanx chess engine. Phalanx's playing style is quite human-like;
+when it plays at full strength, it may be compared to a intermediate-to-strong
+player; beginners will be right at home with it, too.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">phalanx</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-board/phalanx/phalanx-22-r1.ebuild b/games-board/phalanx/phalanx-22-r1.ebuild
new file mode 100644
index 000000000000..cb72a63812f8
--- /dev/null
+++ b/games-board/phalanx/phalanx-22-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs
+
+MY_PN="Phalanx"
+MY_PV="XXII"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="A chess engine suitable for beginner and intermediate players"
+HOMEPAGE="http://phalanx.sourceforge.net/"
+SRC_URI="mirror://sourceforge/phalanx/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ # configure is not used in the project; confs are in Makefile,
+ # and here we override them:
+ local define="-DGNUFUN" myvar
+ for myvar in "PBOOK" "SBOOK" "LEARN" ; do
+ define="${define} -D${myvar}_DIR=\"\\\"/usr/share/${PN}\\\"\""
+ done
+ emake \
+ DEFINES="${define}" \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin phalanx
+ insinto /usr/share/${PN}
+ doins pbook.phalanx sbook.phalanx learn.phalanx
+ einstalldocs
+}