summaryrefslogtreecommitdiff
path: root/games-board/peg-e
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-board/peg-e
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-board/peg-e')
-rw-r--r--games-board/peg-e/Manifest4
-rw-r--r--games-board/peg-e/files/peg-e-1.2.5-gentoo.patch11
-rw-r--r--games-board/peg-e/metadata.xml8
-rw-r--r--games-board/peg-e/peg-e-1.2.5.ebuild43
4 files changed, 66 insertions, 0 deletions
diff --git a/games-board/peg-e/Manifest b/games-board/peg-e/Manifest
new file mode 100644
index 000000000000..98ea89d1a4a1
--- /dev/null
+++ b/games-board/peg-e/Manifest
@@ -0,0 +1,4 @@
+AUX peg-e-1.2.5-gentoo.patch 253 BLAKE2B e9bb860a02f87bc255b2161e3a98c860cde367fede9d5b9bc8bef52d4934cb959fbccb50fe4a79687670fb9a264ea038a37d67c14b2f60c51a59b4818c1ee602 SHA512 8c5952603a748ba7e156451c2d0338a6dd8b89d7f8485f4360b8d353993cfd7e6c03c7b9976c649059c788f80cc4a48441ff628b342e791ba833f2c700af505a
+DIST peg-e-1.2.5-src.tar.bz2 598322 BLAKE2B f717d3e378fe69e087631abd8f0cbe3cc3bf2479ab86a608c256100778bc94baa40752463a4cb511c4ffd431ce38333318803a1dc289be4bd7d3aad595cd76d1 SHA512 cfd15e2c8cba678d64c9289ab2aa3803af48aebb3e4e545439c247d622dd914dac0735a0fd786cdba1678b448c22a9e40f48a9a1db6391fa6532e3d918c0ca10
+EBUILD peg-e-1.2.5.ebuild 688 BLAKE2B ff8b8fc6a40e90aa69d2dc7513ca2e8b662f072d22bdff72a19591a16668912e186eed8239fae5e19d1271e034ffd63e8d4939adfc52b8819c7bcf2562b965d5 SHA512 c6c27f4aea964f185e2e49f1acbcf2533ea748ad0cde2800ec68c6cde83940d89a8488000e3313f6965c018af1c9d7db632926db0d11ad31e32226935a956402
+MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-board/peg-e/files/peg-e-1.2.5-gentoo.patch b/games-board/peg-e/files/peg-e-1.2.5-gentoo.patch
new file mode 100644
index 000000000000..e6430001cf35
--- /dev/null
+++ b/games-board/peg-e/files/peg-e-1.2.5-gentoo.patch
@@ -0,0 +1,11 @@
+--- a/peg-e.pro 2018-05-29 13:01:32.000000000 +0200
++++ b/peg-e.pro 2018-07-11 20:15:46.151082792 +0200
+@@ -75,7 +75,7 @@
+ RESOURCES = icons/icon.qrc
+
+ isEmpty(PREFIX) {
+- PREFIX = /usr/local
++ PREFIX = /usr
+ }
+ isEmpty(BINDIR) {
+ BINDIR = bin
diff --git a/games-board/peg-e/metadata.xml b/games-board/peg-e/metadata.xml
new file mode 100644
index 000000000000..78274e0fa550
--- /dev/null
+++ b/games-board/peg-e/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/games-board/peg-e/peg-e-1.2.5.ebuild b/games-board/peg-e/peg-e-1.2.5.ebuild
new file mode 100644
index 000000000000..e53cb97a9303
--- /dev/null
+++ b/games-board/peg-e/peg-e-1.2.5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit desktop gnome2-utils qmake-utils
+
+DESCRIPTION="A peg solitaire game"
+HOMEPAGE="https://gottcode.org/peg-e/"
+SRC_URI="https://gottcode.org/peg-e/${P}-src.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+"
+
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}