summaryrefslogtreecommitdiff
path: root/games-board/openyahtzee/openyahtzee-1.9.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-board/openyahtzee/openyahtzee-1.9.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'games-board/openyahtzee/openyahtzee-1.9.2.ebuild')
-rw-r--r--games-board/openyahtzee/openyahtzee-1.9.2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/games-board/openyahtzee/openyahtzee-1.9.2.ebuild b/games-board/openyahtzee/openyahtzee-1.9.2.ebuild
new file mode 100644
index 000000000000..26e39498a63e
--- /dev/null
+++ b/games-board/openyahtzee/openyahtzee-1.9.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+WX_GTK_VER="3.0"
+inherit eutils wxwidgets toolchain-funcs versionator games
+
+DESCRIPTION="A full-featured wxWidgets version of the classic dice game Yahtzee"
+HOMEPAGE="http://openyahtzee.sourceforge.net/"
+SRC_URI="mirror://sourceforge/openyahtzee/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="x11-libs/wxGTK:${WX_GTK_VER}[X]"
+DEPEND="${RDEPEND}
+ >=sys-devel/gcc-4.6
+ dev-libs/boost"
+
+pkg_pretend() {
+ local ver=4.6
+ local msg="You need at least GCC ${ver}.x for C++11 range-based 'for' and nullptr support."
+ if ! version_is_at_least ${ver} $(gcc-version); then
+ eerror ${msg}
+ die ${msg}
+ fi
+}
+
+src_prepare() {
+ # Debian patch that was upstreamed and accepted
+ # This can be dropped on next version then
+ epatch "${FILESDIR}"/${P}-wx3.0.patch
+}
+
+src_configure() {
+ need-wxwidgets unicode
+ egamesconf --datadir=/usr/share
+}
+
+src_install() {
+ default
+ prepgamesdirs
+}