summaryrefslogtreecommitdiff
path: root/games-board/hexxagon/hexxagon-1.0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-board/hexxagon/hexxagon-1.0.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'games-board/hexxagon/hexxagon-1.0.2.ebuild')
-rw-r--r--games-board/hexxagon/hexxagon-1.0.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/games-board/hexxagon/hexxagon-1.0.2.ebuild b/games-board/hexxagon/hexxagon-1.0.2.ebuild
new file mode 100644
index 000000000000..f124724d1707
--- /dev/null
+++ b/games-board/hexxagon/hexxagon-1.0.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils flag-o-matic games
+
+DESCRIPTION="Clone of the original DOS game"
+HOMEPAGE="http://www.nesqi.se/"
+SRC_URI="http://www.nesqi.se/download/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-cpp/glibmm:2
+ dev-cpp/gtkmm:2.4
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ append-cxxflags -std=c++11
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ newicon images/board_N_2.xpm ${PN}.xpm
+ make_desktop_entry ${PN} Hexxagon
+ dodoc README
+ prepgamesdirs
+}