summaryrefslogtreecommitdiff
path: root/games-board/hexxagon/hexxagon-1.0.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
commit7f0ccc917c7abe6223784c703d86cd14755691fb (patch)
tree8c6793f68896b341e22f33d7e6cef88e481f4a8b /games-board/hexxagon/hexxagon-1.0.2-r1.ebuild
parent9aa80713372911cec499b3adb2cd746790920916 (diff)
gentoo resync : 03.07.2021
Diffstat (limited to 'games-board/hexxagon/hexxagon-1.0.2-r1.ebuild')
-rw-r--r--games-board/hexxagon/hexxagon-1.0.2-r1.ebuild27
1 files changed, 15 insertions, 12 deletions
diff --git a/games-board/hexxagon/hexxagon-1.0.2-r1.ebuild b/games-board/hexxagon/hexxagon-1.0.2-r1.ebuild
index 467bf1e50f50..6ec2c8059c34 100644
--- a/games-board/hexxagon/hexxagon-1.0.2-r1.ebuild
+++ b/games-board/hexxagon/hexxagon-1.0.2-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit eutils flag-o-matic
+EAPI=8
+
+inherit desktop toolchain-funcs
DESCRIPTION="Clone of the original DOS game"
HOMEPAGE="https://www.nesqi.se/"
@@ -11,23 +12,25 @@ SRC_URI="https://www.nesqi.se/download/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-RDEPEND="dev-cpp/glibmm:2
+RDEPEND="
+ dev-cpp/glibmm:2
dev-cpp/gtkmm:2.4
x11-libs/gtk+:2"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
-src_prepare() {
- default
+PATCHES=(
+ "${FILESDIR}"/${P}-glibc-2.31.patch
+)
- append-cxxflags -std=c++11
+src_compile() {
+ emake AR="$(tc-getAR)"
}
src_install() {
- emake DESTDIR="${D}" install
+ default
+
newicon images/board_N_2.xpm ${PN}.xpm
make_desktop_entry ${PN} Hexxagon
- dodoc README
}