summaryrefslogtreecommitdiff
path: root/games-board/gtkboard
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-board/gtkboard
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-board/gtkboard')
-rw-r--r--games-board/gtkboard/Manifest5
-rw-r--r--games-board/gtkboard/files/gtkboard-0.11_pre0-gcc41.patch24
-rw-r--r--games-board/gtkboard/files/gtkboard-0.11_pre0-gcc45.patch22
-rw-r--r--games-board/gtkboard/gtkboard-0.11_pre0-r1.ebuild51
-rw-r--r--games-board/gtkboard/metadata.xml11
5 files changed, 113 insertions, 0 deletions
diff --git a/games-board/gtkboard/Manifest b/games-board/gtkboard/Manifest
new file mode 100644
index 000000000000..be9ebb0bbe9a
--- /dev/null
+++ b/games-board/gtkboard/Manifest
@@ -0,0 +1,5 @@
+AUX gtkboard-0.11_pre0-gcc41.patch 591 BLAKE2B e3480d0969645815db2cdd9bf32e840bb671a2f9f89c96f5a7e6c61d258d52edc59eca03df64d461298d2afd478f9cccb396a75c31ecd701dc476d304b1f2b32 SHA512 ce7b16643054fd9171c867b6ee7db946577d610fe9f9f6ac9fab98378182934b2eca1828ec8550664c1c67bc2b0f6631ed4538feb9e52d6b9f0ac7e73c1cd656
+AUX gtkboard-0.11_pre0-gcc45.patch 696 BLAKE2B 922d0fdaf0352d21aaa5eaae8bd4eec92b0b2f4321afdf8430096fcf46e7749a06a35c1582d8f6752b0462c96ea150457b58df5d1d32d1f24e0d540e854b3e34 SHA512 7e95753b1a69fbb7031deeb160a7b6da2113171984d8680630317f121e0a12ba97c3230342a3beb5ece6d3579ac4d65a0e9fa1b78e635c690e9e5fac15b54cd9
+DIST gtkboard-0.11pre0.tar.gz 459581 BLAKE2B efe6fc70d8b7c144f0db33502fbce509a0e600008747a5e9bd42d84d0d43de1c790436b731273c36d39356fb489f5616539655fd37ed5cfb802365dcd826e013 SHA512 09d4a1d5203ef0e21d21b5b6cb351add71d0a415ad83808b6e281dcf3f869221e99ae683846462d465eaac54f5eb292e1d8447ea7cdfb07602a8add49e2db283
+EBUILD gtkboard-0.11_pre0-r1.ebuild 971 BLAKE2B 64ccae830a9a59c7d22539b522b4c6c8b2fc12a410c8f26d00ab663a479dd7412af3dbfb2ddc7a2578b93401679c8f9fcbdbec2efd29a97b523b3c7f939cb477 SHA512 dfd3cbefeedb47642fff2171f602883cede95f975bc1e66b3c0a41d469abec852d4e198e0e4f0b5b4f7778140a0b906fa32f275a3940ec7b1e6559364e1fa767
+MISC metadata.xml 331 BLAKE2B e0040c6aa21b5a10ccde6c6dd7ab3463f3821cfdf21e778b4e2dabc93b0bbf902081859f781697949aee8adc870641a7ce449a84e8e451875ebd62a4ef21d970 SHA512 809518470fc270114a602f396c94e42ed33a87e6a46924679e9f1c23dae1863ee4b5a4419bd73d95a069b3810e53f3dd59bfb40ddaa888c9683ac6e2c1c52fb3
diff --git a/games-board/gtkboard/files/gtkboard-0.11_pre0-gcc41.patch b/games-board/gtkboard/files/gtkboard-0.11_pre0-gcc41.patch
new file mode 100644
index 000000000000..f14096e155d1
--- /dev/null
+++ b/games-board/gtkboard/files/gtkboard-0.11_pre0-gcc41.patch
@@ -0,0 +1,24 @@
+gcc-4.1 patch from debian.
+
+--- a/src/board.c
++++ b/src/board.c
+@@ -74,7 +74,7 @@
+ //! default background
+ char board_default_colors [9] = {215, 215, 215, 215, 215, 215, 0, 0, 0};
+
+-static int cell_size, num_pieces;
++int cell_size, num_pieces;
+
+ extern void ui_make_human_move (byte *move, int *rmove);
+
+--- a/src/menu.c
++++ b/src/menu.c
+@@ -829,7 +829,7 @@
+
+ {
+ int i;
+- GtkItemFactoryEntry help_items [3];
++ GtkItemFactoryEntry help_items [4];
+ help_items[0].path = g_strdup_printf ("/Help/%s", opt_game->name);
+ help_items[0].accelerator = NULL;
+ help_items[0].callback = NULL;
diff --git a/games-board/gtkboard/files/gtkboard-0.11_pre0-gcc45.patch b/games-board/gtkboard/files/gtkboard-0.11_pre0-gcc45.patch
new file mode 100644
index 000000000000..dd5a2f92a1e2
--- /dev/null
+++ b/games-board/gtkboard/files/gtkboard-0.11_pre0-gcc45.patch
@@ -0,0 +1,22 @@
+--- a/src/menu.c 2010-05-24 12:35:15.000000000 +0200
++++ b/src/menu.c 2010-05-24 12:35:48.000000000 +0200
+@@ -176,7 +176,7 @@
+ {
+ #if GTK_MAJOR_VERSION == 2
+ // FIXME: can't get existing bgcolor
+- const int size = 20;
++#define size 20
+ static char pixbufs [7][size*(size+1)];
+ char **pixmap_data;
+ static GdkPixmap *pixmaps[7];
+--- a/src/wordtris.c 2010-05-24 12:36:50.000000000 +0200
++++ b/src/wordtris.c 2010-05-24 12:38:30.000000000 +0200
+@@ -122,7 +122,7 @@
+
+ // TODO: change this so that we only need to specify pixmaps for individual squares
+
+-static const int lava_xpm_header_size = 253+1;
++#define lava_xpm_header_size 253+1
+ static char * lava_xpm_header[] =
+ {
+ "144 504 253 2",
diff --git a/games-board/gtkboard/gtkboard-0.11_pre0-r1.ebuild b/games-board/gtkboard/gtkboard-0.11_pre0-r1.ebuild
new file mode 100644
index 000000000000..fe97dee177fa
--- /dev/null
+++ b/games-board/gtkboard/gtkboard-0.11_pre0-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils
+
+MY_P=${P/_}
+DESCRIPTION="Board games system"
+HOMEPAGE="http://gtkboard.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnome"
+
+RDEPEND="x11-libs/gtk+:2
+ media-libs/libsdl:0[sound]
+ media-libs/sdl-mixer[vorbis]
+ gnome? ( gnome-base/libgnomeui )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc41.patch
+ "${FILESDIR}"/${P}-gcc45.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i -e "/^LIBS/s:@LIBS@:@LIBS@ -lgmodule-2.0 -lm:" \
+ src/Makefile.in
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ --enable-gtk2 \
+ --enable-sdl \
+ $(use_enable gnome)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ doicon pixmaps/${PN}.png
+ make_desktop_entry ${PN} Gtkboard
+ dodoc AUTHORS ChangeLog TODO doc/index.html
+}
diff --git a/games-board/gtkboard/metadata.xml b/games-board/gtkboard/metadata.xml
new file mode 100644
index 000000000000..e06235899db3
--- /dev/null
+++ b/games-board/gtkboard/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">gtkboard</remote-id>
+ </upstream>
+</pkgmetadata>