summaryrefslogtreecommitdiff
path: root/games-board/grhino
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-board/grhino
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-board/grhino')
-rw-r--r--games-board/grhino/Manifest3
-rw-r--r--games-board/grhino/grhino-0.16.1-r1.ebuild47
-rw-r--r--games-board/grhino/metadata.xml17
3 files changed, 67 insertions, 0 deletions
diff --git a/games-board/grhino/Manifest b/games-board/grhino/Manifest
new file mode 100644
index 000000000000..7c2805bfb365
--- /dev/null
+++ b/games-board/grhino/Manifest
@@ -0,0 +1,3 @@
+DIST grhino-0.16.1.tar.gz 1178091 BLAKE2B aa5d0c7aab142aabc39d849cbf18cce5aeb57d42f74ad1e2117c57e735d9a6b383fc284cae82c64d5ed8ac809eb364568133e06f42a1062312512becf87df315 SHA512 17fd5539a9d74a715237a51cbf2f3119feae2bed6a26496b02d7882385d5567571ba4b4c4018554944d07322e5a0c3b3235e141579281621f5a030acbe6480e2
+EBUILD grhino-0.16.1-r1.ebuild 961 BLAKE2B bb979c3934c7a110f9bd1f9999716abf14240e18c5433a0af211dc77c69c2130fad8d9f537493916a7f9c7a9a4e5f9e371f9409e870a9d6bf89f8d29b42f0e47 SHA512 e399e36b3bc2e812d64cc8770bd27186c8c16e6950b42b6b514ee7b77fb2551300ac39b3e89d5995af9226866ed2dd052244aa373575081c9eb40717be38c65e
+MISC metadata.xml 513 BLAKE2B a54919c1b021a9e66b91ba91a110e75b9dd687538bc0da2c2beb5f738615e0f034954a7f19273022199efeb47cf1d3933ab5db7ddd8649a492846fd6a020eb05 SHA512 783fb713c40369df38b8aebba6ac6234ee646e097c1992b1ebeb790c3ddd1fa1915c5fcf4f1505f1b6450d9a4ca85e6be7eb38613316a3a475b625906fea6fc4
diff --git a/games-board/grhino/grhino-0.16.1-r1.ebuild b/games-board/grhino/grhino-0.16.1-r1.ebuild
new file mode 100644
index 000000000000..2697f40697f5
--- /dev/null
+++ b/games-board/grhino/grhino-0.16.1-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="Reversi game for GNOME, supporting the Go/Game Text Protocol"
+HOMEPAGE="http://rhino.sourceforge.net/"
+SRC_URI="mirror://sourceforge/rhino/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnome gtp nls"
+
+RDEPEND="gnome? ( =gnome-base/libgnomeui-2* )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ default
+
+ sed -i '/^(\|locale\|help\|omf\|icon\|)/s:@datadir@:/usr/share:' \
+ Makefile.in || die
+}
+
+src_configure() {
+ if use gnome || use gtp; then
+ econf \
+ --localedir=/usr/share/locale \
+ $(use_enable gnome) \
+ $(use_enable gtp) \
+ $(use_enable nls)
+ else
+ econf \
+ --localedir=/usr/share/locale \
+ --enable-gtp \
+ --disable-gnome \
+ $(use_enable nls)
+ fi
+}
+
+src_install() {
+ default
+ use gnome && make_desktop_entry ${PN} GRhino
+}
diff --git a/games-board/grhino/metadata.xml b/games-board/grhino/metadata.xml
new file mode 100644
index 000000000000..5a4a37d191d9
--- /dev/null
+++ b/games-board/grhino/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <longdescription lang="en">
+An Othello game with strong AI.
+</longdescription>
+ <use>
+ <flag name="gtp">Install the GTP (Go/Game Text Protocol) frontend</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">rhino</remote-id>
+ </upstream>
+</pkgmetadata>