summaryrefslogtreecommitdiff
path: root/games-board/gnugo/gnugo-3.9.1-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
commit90c88731bd036e5698b281fbc0a5f3aa4c9983ac (patch)
tree83fc5facb6b12be510a37bc3d241cc63e965b13a /games-board/gnugo/gnugo-3.9.1-r2.ebuild
parentfeb0daf81d888e9160f9f94502de09b66f2a63fd (diff)
gentoo resync : 29.06.2020
Diffstat (limited to 'games-board/gnugo/gnugo-3.9.1-r2.ebuild')
-rw-r--r--games-board/gnugo/gnugo-3.9.1-r2.ebuild17
1 files changed, 13 insertions, 4 deletions
diff --git a/games-board/gnugo/gnugo-3.9.1-r2.ebuild b/games-board/gnugo/gnugo-3.9.1-r2.ebuild
index cfcbcca0fbbb..b0bf4b8a8278 100644
--- a/games-board/gnugo/gnugo-3.9.1-r2.ebuild
+++ b/games-board/gnugo/gnugo-3.9.1-r2.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
+inherit autotools
DESCRIPTION="A Go-playing program"
HOMEPAGE="https://www.gnu.org/software/gnugo/devel.html"
@@ -14,15 +16,22 @@ IUSE="readline"
RDEPEND="
readline? ( sys-libs/readline:0= )
- >=sys-libs/ncurses-5.2-r3:0=
-"
+ >=sys-libs/ncurses-5.2-r3:0="
DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}"/${P}-invalid-move.patch
"${FILESDIR}"/${P}-format-security.patch
+ "${FILESDIR}"/${P}-autotools.patch
+ "${FILESDIR}"/${P}-fno-common.patch
)
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
src_configure() {
econf \
$(use_with readline) \