summaryrefslogtreecommitdiff
path: root/games-board/gnono/gnono-1.9.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-board/gnono/gnono-1.9.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'games-board/gnono/gnono-1.9.1.ebuild')
-rw-r--r--games-board/gnono/gnono-1.9.1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/games-board/gnono/gnono-1.9.1.ebuild b/games-board/gnono/gnono-1.9.1.ebuild
new file mode 100644
index 000000000000..eee6e7653027
--- /dev/null
+++ b/games-board/gnono/gnono-1.9.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit autotools eutils gnome2-utils games
+
+DESCRIPTION="A rewrite for GNOME of the Windows card game WUNO"
+HOMEPAGE="https://sourceforge.net/projects/gnono/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="gnome-base/libgnomeui
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-gentoo.patch \
+ "${FILESDIR}"/${P}-glib-single-include.patch
+ eautoreconf
+}
+
+src_install() {
+ default
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}