summaryrefslogtreecommitdiff
path: root/games-board/gnome-chess
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /games-board/gnome-chess
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'games-board/gnome-chess')
-rw-r--r--games-board/gnome-chess/Manifest2
-rw-r--r--games-board/gnome-chess/gnome-chess-40.1.ebuild56
2 files changed, 58 insertions, 0 deletions
diff --git a/games-board/gnome-chess/Manifest b/games-board/gnome-chess/Manifest
index 75f013782dca..dcf572dca27a 100644
--- a/games-board/gnome-chess/Manifest
+++ b/games-board/gnome-chess/Manifest
@@ -1,3 +1,5 @@
DIST gnome-chess-3.36.1.tar.xz 738308 BLAKE2B 14d328b9939afb12f14b513cfa009e3fb197f6c35c5272df107ce844890339caecbb5dafbd0bd28a19d001ebc0574464b33ea2ca10a9f7578b49d1e6f637e190 SHA512 4c89f91fe16323a799cf1eb3fe1f8e37fd506248ca32ad605ca3d5ecd37cf29f046da50383e0d0c3d82acf4e472843f3fd40927283f37e02d42cee5d8c72d8b3
+DIST gnome-chess-40.1.tar.xz 741168 BLAKE2B 3691f7aa03532456f9437588641417af4db45b99ffb0f211eca8dffd7a7ba7cf834c7f1e3e2cf6933df96c05b981edb7db3aac430be2c7256d96fca6ecb73db4 SHA512 aae1690724c068717045d70f4fbd5a6cf1fc169ae0bd5df0ae7f0d7a2609c93c482da545008dd3c5d11e975ec8f2c5fc6f4b0007a8f2a1128a75aec2f3fcb083
EBUILD gnome-chess-3.36.1.ebuild 1038 BLAKE2B 4af1426f1efe41ac44aed3169d5bbd16da26caf62602cca500afb382e636db4d372025abc072378313be0a6bd7226bbe75cd46e923943a3fda3da4f6d8c6d69d SHA512 5f6b6b3ca6b21f2429d1f52152af42637da78b9cae81c2902ba777dcdee1f7b90854c874d4014a4be17ea687c275f9e26e056214fe8831593bd172954a3417dd
+EBUILD gnome-chess-40.1.ebuild 1085 BLAKE2B 4a00c69855b2a11e713b87463b45b0e7e85db8b301907e78dd68f4ab81610fe719fac840ca0b92f86ddbde42d01b9da6a1c0c735e21f66e861edbc3b0161e7de SHA512 4e435424b8ac4600893b2508f92aceed353533462c87533504c86225bbbbc5db57121524928307f7bf3fbba4520acce197555992da0b332d616e4d6df833bb84
MISC metadata.xml 249 BLAKE2B e71e1b95fee768c696704acbf7e3cf0e599ed2bc8de92bae0141d1194ef9e842bdc292798904487a9b90ddfda9b0e84abd3b76b1518576c1d288240e4e46f110 SHA512 c40662134899a5c9f0369a1017806f35adf3280a0b3c91726f7a8ca6012a073a8b471583f5bfb6fe95faac1dcf607e8e2e43f8c91d48ec46f4a8824e2f551506
diff --git a/games-board/gnome-chess/gnome-chess-40.1.ebuild b/games-board/gnome-chess/gnome-chess-40.1.ebuild
new file mode 100644
index 000000000000..d0026406ab65
--- /dev/null
+++ b/games-board/gnome-chess/gnome-chess-40.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+VALA_MIN_API_VERSION="0.52"
+
+inherit gnome.org gnome2-utils meson python-any-r1 readme.gentoo-r1 vala xdg
+
+DESCRIPTION="Play the classic two-player boardgame of chess"
+HOMEPAGE="https://wiki.gnome.org/Apps/Chess"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.44:2
+ gui-libs/gtk:4
+ >=gnome-base/librsvg-2.46.0:2
+"
+DEPEND="${RDEPEND}
+ gnome-base/librsvg:2[vala]
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ $(vala_depend)
+ dev-util/itstool
+ dev-libs/appstream-glib
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+DOC_CONTENTS="To be able to play against a computer you will need
+to install a chess engine package, for example games-board/gnuchess"
+
+src_prepare() {
+ xdg_src_prepare
+ vala_src_prepare
+}
+
+src_install() {
+ meson_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}