summaryrefslogtreecommitdiff
path: root/games-board/gmchess/gmchess-0.29.6-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-board/gmchess/gmchess-0.29.6-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'games-board/gmchess/gmchess-0.29.6-r1.ebuild')
-rw-r--r--games-board/gmchess/gmchess-0.29.6-r1.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/games-board/gmchess/gmchess-0.29.6-r1.ebuild b/games-board/gmchess/gmchess-0.29.6-r1.ebuild
new file mode 100644
index 000000000000..915470a4b0bb
--- /dev/null
+++ b/games-board/gmchess/gmchess-0.29.6-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit autotools flag-o-matic libtool gnome2-utils games
+
+DESCRIPTION="Chinese chess with gtkmm and c++"
+HOMEPAGE="https://code.google.com/p/gmchess/"
+SRC_URI="https://${PN}.googlecode.com/files/${P}.tar.bz2"
+RESTRICT="test"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-cpp/gtkmm:2.4"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ sed -i \
+ -e "s:GAMES_LIBDIR:$(games_get_libdir):" \
+ -e "s:GAMES_DATADIR:${GAMES_DATADIR}:" \
+ src/engine/eleeye.cpp || die
+ eautoreconf
+}
+
+src_configure() {
+ append-cxxflags -std=c++11
+ egamesconf \
+ --disable-static \
+ --localedir='/usr/share/locale'
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ itlocaledir='/usr/share/locale' \
+ pixmapsdir='/usr/share/pixmaps' \
+ desktopdir='/usr/share/applications' \
+ install
+ dodoc AUTHORS NEWS README
+ prune_libtool_files
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}