summaryrefslogtreecommitdiff
path: root/games-board/gambit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
commitb17a3ef12038de50228bade1f05502c74e135321 (patch)
tree9026dffec53f92cba48ca9a500a4f778e6304380 /games-board/gambit
parent3cf7c3ef441822c889356fd1812ebf2944a59851 (diff)
gentoo resync : 02.09.2020
Diffstat (limited to 'games-board/gambit')
-rw-r--r--games-board/gambit/Manifest3
-rw-r--r--games-board/gambit/files/gambit-1.0.4-compile-flags.patch28
-rw-r--r--games-board/gambit/gambit-1.0.4-r1.ebuild (renamed from games-board/gambit/gambit-1.0.4.ebuild)6
3 files changed, 35 insertions, 2 deletions
diff --git a/games-board/gambit/Manifest b/games-board/gambit/Manifest
index aece8b881dd7..63645bccf5ec 100644
--- a/games-board/gambit/Manifest
+++ b/games-board/gambit/Manifest
@@ -1,3 +1,4 @@
+AUX gambit-1.0.4-compile-flags.patch 1478 BLAKE2B b57ae05465ce29f81a69e438f50f3bfa310b38b6427a150ccda7a434cf14789d26ac25075d3902423a07c3f40f9252d3b046b121d2d7067804538be30fe9df60 SHA512 97682079ea3c3b8e751df8acf71db0f32a6dd2c615e0a4178e9babbe9f6a0b624bee80d326d2a4a3c6eb82451abc5f77dfa38909dc02f4b28a3f2ff7d3f9520f
DIST Gambit-1.0.4-src.tar.xz 1675576 BLAKE2B 4545bee38509d44f80af874473ff562b441e570be3681b166b064574e12bfad8b8a2fb5043b9d0b9089160de2d97407160336cb58864168232cf0921244cf92d SHA512 9ba12e0e9598e2b08228aa009690e6a05677916dcea1413a42be20d620accbe7cef4f4300e3ccc5d4d99e37c7fb85d923df8f5fa9146ee8049bbde2ce66ab7a9
-EBUILD gambit-1.0.4.ebuild 1163 BLAKE2B 38cd5c10193233956e100427e733988f3ce4a7559ebece715166fd72154887ceef6fa5bdb88803c1c75cd1b54ebdc6a6810065fb0c15c30aacc213dd6b79c3d8 SHA512 8bbc7170cf3095533c331d5f974f2bae421e2097cffe44d9031c748f873561039d0f8bdbd67db77f7fb61f3e9d61f6359c2cb123c809c98b60ac8a3f1ade2605
+EBUILD gambit-1.0.4-r1.ebuild 1213 BLAKE2B 074a10ba30baa167d5fc98e5944352598cb2611346ac352073f1af5effebd402cb81f3f6bdb9c5b2aefdc3c364211ce196e1149a68ba822ae2ad6a2e16285100 SHA512 6dd7dd6cb811623f8288fa9230f5011e612e652cf317ff8b624a24d140434a53973bea3dc008cce014ed2e2d10335558eab24d97fb26a25bf1e862ebd1fdf60a
MISC metadata.xml 330 BLAKE2B b37539dff6327ec46e89a9a93c5a23c0efdf321cafc5e851e98b9b265f1d561e8c70f96737b455b65958dbbd9b8a8e6efd7b44e9d589e26fb768851e23fb23ef SHA512 284c29ce4b5ae3cb4e7f1b3472cd3430ce474cd395f44b730301b37fed45c57387646e6643ab9ba2f80885e7bf2e36bd9dd018045d7a0ccefa2c73dbcfae2146
diff --git a/games-board/gambit/files/gambit-1.0.4-compile-flags.patch b/games-board/gambit/files/gambit-1.0.4-compile-flags.patch
new file mode 100644
index 000000000000..c8df686b86af
--- /dev/null
+++ b/games-board/gambit/files/gambit-1.0.4-compile-flags.patch
@@ -0,0 +1,28 @@
+From f573e47d095b114e07255537d754ef4ee4bf2885 Mon Sep 17 00:00:00 2001
+From: Sebastian Pipping <sebastian@pipping.org>
+Date: Mon, 31 Aug 2020 19:51:56 +0200
+Subject: [PATCH] Respect custom CFLAGS and CXXFLAGS
+
+---
+ CMakeLists.txt | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 1be8b83..fa5f5b6 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -114,9 +114,9 @@ if(POLICY CMP0020)
+ cmake_policy(SET CMP0020 NEW)
+ endif()
+
+-set(CMAKE_C_FLAGS "-Wall -Wextra -Wshadow -Wpointer-arith -Wcast-align -Wwrite-strings -Wmissing-prototypes -Wmissing-declarations -Wredundant-decls -Wnested-externs -Wstrict-prototypes -Wbad-function-cast -Wformat=2 -Wundef -pedantic -Wno-long-long")
++set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -Wextra -Wshadow -Wpointer-arith -Wcast-align -Wwrite-strings -Wmissing-prototypes -Wmissing-declarations -Wredundant-decls -Wnested-externs -Wstrict-prototypes -Wbad-function-cast -Wformat=2 -Wundef -pedantic -Wno-long-long")
+
+-set(CMAKE_CXX_FLAGS "-std=c++11 -Wall -Wextra -Wshadow -Wpointer-arith -Wcast-align -Wwrite-strings -Wredundant-decls -Wformat=2 -Wundef -pedantic -Wno-long-long")
++set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -Wall -Wextra -Wshadow -Wpointer-arith -Wcast-align -Wwrite-strings -Wredundant-decls -Wformat=2 -Wundef -pedantic -Wno-long-long")
+
+ if(DEVELOPER_MODE)
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Werror -pedantic-errors")
+--
+2.27.0
+
diff --git a/games-board/gambit/gambit-1.0.4.ebuild b/games-board/gambit/gambit-1.0.4-r1.ebuild
index e078316f6b20..fd20cc73c5d7 100644
--- a/games-board/gambit/gambit-1.0.4.ebuild
+++ b/games-board/gambit/gambit-1.0.4-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -28,6 +28,10 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}/${MY_P}-src"
+PATCHES=(
+ "${FILESDIR}"/${P}-compile-flags.patch
+)
+
src_configure() {
local mycmakeargs=(
-DCONFIG_ENABLE_UPDATE_CHECKER=OFF