summaryrefslogtreecommitdiff
path: root/games-board/gambit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-board/gambit
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-board/gambit')
-rw-r--r--games-board/gambit/Manifest3
-rw-r--r--games-board/gambit/gambit-1.0.4.ebuild56
-rw-r--r--games-board/gambit/metadata.xml11
3 files changed, 70 insertions, 0 deletions
diff --git a/games-board/gambit/Manifest b/games-board/gambit/Manifest
new file mode 100644
index 000000000000..0783c77a7573
--- /dev/null
+++ b/games-board/gambit/Manifest
@@ -0,0 +1,3 @@
+DIST Gambit-1.0.4-src.tar.xz 1675576 BLAKE2B 4545bee38509d44f80af874473ff562b441e570be3681b166b064574e12bfad8b8a2fb5043b9d0b9089160de2d97407160336cb58864168232cf0921244cf92d SHA512 9ba12e0e9598e2b08228aa009690e6a05677916dcea1413a42be20d620accbe7cef4f4300e3ccc5d4d99e37c7fb85d923df8f5fa9146ee8049bbde2ce66ab7a9
+EBUILD gambit-1.0.4.ebuild 1157 BLAKE2B 81b54e2ebde3e3fbf8fb0232525724a13838f62ab4877ee4b547d74d09292e184e162f2fa21a1fdd3187b9994bb9320866356e4f0cadbc84093924b54dbccd64 SHA512 2bea1801c158aebe969d0b577dd9c2d94cc646630047754f3d14606bc58c70d2e2602555bae4f5199d8e4091eb2eef4402feef85e36ba145575c4f8775be14d1
+MISC metadata.xml 330 BLAKE2B b37539dff6327ec46e89a9a93c5a23c0efdf321cafc5e851e98b9b265f1d561e8c70f96737b455b65958dbbd9b8a8e6efd7b44e9d589e26fb768851e23fb23ef SHA512 284c29ce4b5ae3cb4e7f1b3472cd3430ce474cd395f44b730301b37fed45c57387646e6643ab9ba2f80885e7bf2e36bd9dd018045d7a0ccefa2c73dbcfae2146
diff --git a/games-board/gambit/gambit-1.0.4.ebuild b/games-board/gambit/gambit-1.0.4.ebuild
new file mode 100644
index 000000000000..28abd503a2c2
--- /dev/null
+++ b/games-board/gambit/gambit-1.0.4.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+CMAKE_IN_SOURCE_BUILD=true
+inherit cmake-utils
+
+MY_P="${P^}"
+
+DESCRIPTION="Qt-based chess application + engine \"gupta\""
+HOMEPAGE="https://sourceforge.net/projects/gambitchess/"
+SRC_URI="mirror://sourceforge/project/${PN}chess/${MY_P}/${MY_P}-src.tar.xz"
+
+LICENSE="CC0-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtopengl:5
+ dev-qt/qtwidgets:5
+ media-libs/mesa
+ x11-libs/libX11"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}-src"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCONFIG_ENABLE_UPDATE_CHECKER=OFF
+ -DCONFIG_GUPTA_ENGINE_DIRECTORY=/usr/bin
+ -DCONFIG_RESOURCE_PATH_PREFIX=/usr/share/${PN}/
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ emake -C engine/gupta VERBOSE=1 STRIP=/bin/true CFLAGS_RELEASE= release
+}
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins -r data/*
+
+ doicon artwork/icons/${PN}/${PN}.svg
+ make_desktop_entry ${PN}chess ${PN^} ${PN} Game
+ dodoc doc/contributors.txt
+
+ dobin engine/gupta/gupta
+ dobin ${PN}chess
+}
diff --git a/games-board/gambit/metadata.xml b/games-board/gambit/metadata.xml
new file mode 100644
index 000000000000..2c6e3977dfd1
--- /dev/null
+++ b/games-board/gambit/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sping@gentoo.org</email>
+ <name>Sebastian Pipping</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">gambitchess</remote-id>
+ </upstream>
+</pkgmetadata>