summaryrefslogtreecommitdiff
path: root/games-board/fruit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-board/fruit
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-board/fruit')
-rw-r--r--games-board/fruit/Manifest4
-rw-r--r--games-board/fruit/files/fruit-2.1-gentoo.patch11
-rw-r--r--games-board/fruit/fruit-2.1-r1.ebuild41
-rw-r--r--games-board/fruit/metadata.xml11
4 files changed, 67 insertions, 0 deletions
diff --git a/games-board/fruit/Manifest b/games-board/fruit/Manifest
new file mode 100644
index 000000000000..1d07168b0415
--- /dev/null
+++ b/games-board/fruit/Manifest
@@ -0,0 +1,4 @@
+AUX fruit-2.1-gentoo.patch 590 BLAKE2B 0ff77b71537b8b2062413e1fe888014d69371c8cb29260e02cae8e3789b572c9175750be31abd5dfaebbdf517bc2c8f98b3132c8526beaa1cf1ebcbd35c77f79 SHA512 db32e30dcd60df1c0dabcab4589cdfb779ef619d2bdfdb35b77b5b6b224adb0b9826c310b2f3fd97c0591e4c63931dfec733578429c749b691a5dafbc8a954b4
+DIST fruit_21_linux.zip 716762 BLAKE2B ffdc38ca4a3021b69e95c876c419bc85102412ef6632cfc5d8d1370b59fdc6e1bb5e10e5066fd39197d16042286e0cac07ae76a39eb1ed3d96bfe804225a9948 SHA512 80d80141ca3c2a4521b241a750bd237e0971b531bc4e8e89ae3bdcdbb1436b99b35e64f505b9a61413726744646b6b4ce126bcdb53b90adc727f88a50adee889
+EBUILD fruit-2.1-r1.ebuild 795 BLAKE2B 669fa5a30b6173ad0dc3c92e78b8e87ef4b87b037caf4248b6928cb670e9b05e50410495b730b2f67290a683c593922748f06d43df02c9f06109d33a085d1af4 SHA512 655f8e1b74330fb41d4609a72bda62383fc492b7ef04c94edfca6310e95b50bb3f6980cba50452ce3669b824bd4342ba7379f3cd6baff005e543d8b2be48e9fc
+MISC metadata.xml 330 BLAKE2B e38a1b870857c880700f94c087932aee6c4236bdd38e87c61b93837c72235dc5f8e37c322fec5f8b87403a498e459035f13037a1b0711a9902405ea15d8e03e4 SHA512 f568c54581b78f36c6aaaba340be04f0396dbb62f133426b0dddf4a1ed39b0675fd64b6b2d14f9c41bf49851dc25156bf71566ef9b207570cc7e57a92380c4ef
diff --git a/games-board/fruit/files/fruit-2.1-gentoo.patch b/games-board/fruit/files/fruit-2.1-gentoo.patch
new file mode 100644
index 000000000000..815b184d9dc2
--- /dev/null
+++ b/games-board/fruit/files/fruit-2.1-gentoo.patch
@@ -0,0 +1,11 @@
+--- a/option.cpp.old 2007-02-07 23:32:25.000000000 +0100
++++ b/option.cpp 2007-02-07 23:32:51.000000000 +0100
+@@ -29,7 +29,7 @@
+ { "Ponder", true, "false", "check", "", NULL },
+
+ { "OwnBook", true, "true", "check", "", NULL },
+- { "BookFile", true, "book_small.bin", "string", "", NULL },
++ { "BookFile", true, "@GENTOO_DATADIR@/book_small.bin", "string", "", NULL },
+
+ { "NullMove Pruning", true, "Fail High", "combo", "var Always var Fail High var Never", NULL },
+ { "NullMove Reduction", true, "3", "spin", "min 1 max 3", NULL },
diff --git a/games-board/fruit/fruit-2.1-r1.ebuild b/games-board/fruit/fruit-2.1-r1.ebuild
new file mode 100644
index 000000000000..bb8f7635cf15
--- /dev/null
+++ b/games-board/fruit/fruit-2.1-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit versionator
+
+MY_PV="$(replace_all_version_separators '')"
+MY_P="${PN}_${MY_PV}_linux"
+
+DESCRIPTION="UCI-only chess engine"
+HOMEPAGE="http://arctrix.com/nas/fruit/"
+SRC_URI="http://arctrix.com/nas/${PN}/${MY_P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}/${MY_P}/src"
+
+src_prepare() {
+ default
+ eapply "${FILESDIR}/${P}"-gentoo.patch
+ sed -i \
+ -e "s:@GENTOO_DATADIR@:/usr/share/${PN}:" \
+ option.cpp || die
+ sed -i \
+ -e '/^CXX/d' \
+ -e '/^LDFLAGS/d' \
+ Makefile || die
+}
+
+src_install() {
+ dobin ${PN}
+ insinto "/usr/share/${PN}"
+ doins ../book_small.bin
+ dodoc ../readme.txt ../technical_10.txt
+}
diff --git a/games-board/fruit/metadata.xml b/games-board/fruit/metadata.xml
new file mode 100644
index 000000000000..f9731bb70a84
--- /dev/null
+++ b/games-board/fruit/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+<longdescription lang="en">
+Fruit is a UCI-only chess engine.
+</longdescription>
+</pkgmetadata>